F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Coding Newbie - Corrupted FEM_BODY? Help?
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      06-19-2021, 10:59 AM   #23
atzebmw
Colonel
Germany
495
Rep
2,139
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by F30BMWWHITE View Post
Are you able to supply me with the latest files?

Can I just do it with the regular esys?


I have also ordered another cable, just incase!
Here i uploaded different newer versions of E-Sys and the newest psdzdata.

https://mega.nz/folder/pSQwmLob#-0ltXS6RykDELDHZS9IqIg

You can install different E-Sys versions if you name each folder differently during installation.
And you can install different psdzdata if you name the folder for example to old_psdzdata.
E-Sys will always use the psdzdata from the folder ...Data/psdzdata.

Last edited by atzebmw; 06-19-2021 at 11:52 AM..
Appreciate 0
      06-21-2021, 09:06 AM   #24
F30BMWWHITE
New Member
4
Rep
27
Posts

Drives: BMW f30
Join Date: Jun 2021
Location: UK

iTrader: (0)

Quote:
Originally Posted by atzebmw View Post
Here i uploaded different newer versions of E-Sys and the newest psdzdata.

https://mega.nz/folder/pSQwmLob#-0ltXS6RykDELDHZS9IqIg

You can install different E-Sys versions if you name each folder differently during installation.
And you can install different psdzdata if you name the folder for example to old_psdzdata.
E-Sys will always use the psdzdata from the folder ...Data/psdzdata.
Thank you for that!

Although, I tried to do it, and Im still getting the same errors.

Although I did also try another older CAFD from that tree. And it made a 'ding" on the car, when I tried to connect back to the car, it doesn't show the 255_255_255, it does show different numbers, but they seem to be black as opposed to the blue that the other ecu's have, is this a positive step?

Although - I did still get a sort of error when that happened too?

<Caf's suchen>
TAL calculation started.
Locally NCD signature calculation started
Processing ncd signing finished
TAL execution started.
<>
Read SVT before TAL execution started.
Read SVT before TAL execution finished.
TAL execution started.
VCM Update: VCM-Update is deactivated. VCM will not be updated.
<ExecutionID=2021/06/21-15:54:54.530>
<[] prepareTALExecution started [PROGRESS]>
<[] prepareTALExecution finished [PROGRESS]>
<[] prepareVehicleForCoding started [PROGRESS]>
<[] prepareVehicleForCoding finished [PROGRESS]>
<[FEM_BODY - 40] prepareECUforCoding started [PROGRESS]>
<[FEM_BODY - 40] prepareECUforCoding finished [PROGRESS]>
<[FEM_BODY - 40] authenticateECUforCoding started [PROGRESS]>
<[FEM_BODY - 40] authenticateECUforCoding finished [PROGRESS]>
<[FEM_BODY - 40 - cafd_00000794-007_031_010] Transaction type: cdDeploy; Message: TA started [TRANSACTION]>
<MCDDiagService<id=62900, job=com.bmw.psdz.jobs.uds.MCD3_PerformECUCoding, service=WDBI_PLAIN - WriteDataByIdentifier with unlimited Data-ID (plain hex value), description=error: timeout, link=FEM_BODY_40_ETHERNET> [DIAGSERVICE]>
<MCDDiagService<id=62900, job=com.bmw.psdz.jobs.uds.MCD3_PerformECUCoding, service=WDBI_PLAIN - WriteDataByIdentifier with unlimited Data-ID (plain hex value), description=error: timeout, link=FEM_BODY_40_ETHERNET> [DIAGSERVICE]>
<[FEM_BODY - 40 - cafd_00000794-007_031_010] Transaction type: cdDeploy; Message: TA finished [TRANSACTION]>
<[FEM_BODY - 40] finalizeECUCoding started [PROGRESS]>
<[FEM_BODY - 40] finalizeECUCoding finished [PROGRESS]>
<[] finalizeVehicleCoding started [PROGRESS]>
<[] finalizeVehicleCoding finished [PROGRESS]>
<[] finalizeTALExecution started [PROGRESS]>
<[] finalizeTALExecution finished [PROGRESS]>
<TAL execution finished [TAL_EXECUTION_FINISHED]>
TAL-Execution finished with status: "FinishedWithWarnings".
TAL execution finished. Duration: "27s".
<>
Read SVT after TAL execution started.
Read SVT after TAL execution finished.
TAL execution finished.

Appreciate 0
      06-21-2021, 04:07 PM   #25
atzebmw
Colonel
Germany
495
Rep
2,139
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by F30BMWWHITE View Post
Thank you for that!

Although, I tried to do it, and Im still getting the same errors.

Although I did also try another older CAFD from that tree. And it made a 'ding" on the car, when I tried to connect back to the car, it doesn't show the 255_255_255, it does show different numbers, but they seem to be black as opposed to the blue that the other ecu's have, is this a positive step?
This looks positive.
Do you have currently any problems with the car or error messages in the IDrive?
Can you now FDL Code again some things in the FEM_Body?
Appreciate 0
      06-22-2021, 03:11 PM   #26
F30BMWWHITE
New Member
4
Rep
27
Posts

Drives: BMW f30
Join Date: Jun 2021
Location: UK

iTrader: (0)

Quote:
Originally Posted by atzebmw View Post
This looks positive.
Do you have currently any problems with the car or error messages in the IDrive?
Can you now FDL Code again some things in the FEM_Body?
It was very passive! It worked, and then I coded in two options, and it coded perfectly.

then I came back in, coded something else and its currently corrupted again, so Im going to assume its the cable being inconsistent.
Appreciate 0
      06-23-2021, 06:48 AM   #27
F30BMWWHITE
New Member
4
Rep
27
Posts

Drives: BMW f30
Join Date: Jun 2021
Location: UK

iTrader: (0)

Quote:
Originally Posted by atzebmw View Post
This looks positive.
Do you have currently any problems with the car or error messages in the IDrive?
Can you now FDL Code again some things in the FEM_Body?
Just a note for closure, it seemed to be the cable, tried with another cable and it worked flawlessly! Un-corrupted without error and coded the Module

Thank you again for your help!
Appreciate 1
atzebmw495.00
      06-23-2021, 07:37 AM   #28
atzebmw
Colonel
Germany
495
Rep
2,139
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

I am glad to hear that.
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:33 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST