F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > N20 Random Misfire and Cylinder 2&3
VIBE Motorsports
Post Reply
 
Thread Tools Search this Thread
      03-14-2018, 09:49 AM   #23
BunkerJ
Colonel
BunkerJ's Avatar
1006
Rep
2,382
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by Domotron View Post
shit i guess well see lol don't really want to have any drive-train issues since ill be starting on my motor build this summer
I've been built (With the exception of the turbo that goes in tomorrow) for about 15k (EDIT: Miles). No issues drivetrain-wise and don't expect anything big tbh. I'm sure it won't hurt to do a drain/fill if you want to.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit

Last edited by BunkerJ; 03-14-2018 at 10:06 AM..
Appreciate 0
      07-14-2018, 10:53 AM   #24
slow.f32
New Member
3
Rep
28
Posts

Drives: Alpine White F32 M Sport
Join Date: Sep 2017
Location: N. California

iTrader: (0)

Hey guys,

So I was on the way home from work yesterday. As I exited the freeway, my car just suddenly went into " Drivetrain malfunction: Drive moderately. Maximum drivetrain output not available. Consult Service center." The check engine light was also flashing and is now on when I start the car. The car feels like it loss so much power and engine shakes heavily when idling. It feels like the car is about to stall or shut down. I replaced all spark plugs and ignition coils 5 months ago in February. Also found out my car is an N26 and not N20, unsure if that makes a difference.

I just went to Autozone and used their scanner.

This time, I am getting:

P0301 Cylinder 1 Misfire Detected


If you look at the original post above, I had a random and Cylinder 2 & 3 misfires before, but those were fixed. Can this new code P0301 be related? What can be a cause of this? Any insight on this is much appreciated.
__________________
IG: slow.f32
Appreciate 0
      07-18-2018, 04:23 PM   #25
slow.f32
New Member
3
Rep
28
Posts

Drives: Alpine White F32 M Sport
Join Date: Sep 2017
Location: N. California

iTrader: (0)

Turned out to just be a bad ignition coil on cyl 1
__________________
IG: slow.f32
Appreciate 0
      09-10-2019, 06:01 AM   #26
D Griff
New Member
D Griff's Avatar
United_States
11
Rep
27
Posts

Drives: 2014 328i, 2003 Corvette
Join Date: Mar 2019
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by slow.f32 View Post
Turned out to just be a bad ignition coil on cyl 1
Resurrecting this from the dead as I have the same thing going on. How many miles were on your car? Did you try plugs first? I don't know that there's any way to tell if it's plugs versus ignition coil. I have the same issue on cylinder two.
__________________
2014 328i M Sport Estoril Blue Six Speed - Daily
2003 Corvette 50 AE Six Speed - Track/Fun
Appreciate 0
      09-10-2019, 08:54 AM   #27
OC_F32
Private First Class
OC_F32's Avatar
92
Rep
107
Posts

Drives: 2015 428i
Join Date: Jan 2016
Location: Orange County, CA

iTrader: (0)

Quote:
Originally Posted by D Griff View Post
Quote:
Originally Posted by slow.f32 View Post
Turned out to just be a bad ignition coil on cyl 1
Resurrecting this from the dead as I have the same thing going on. How many miles were on your car? Did you try plugs first? I don't know that there's any way to tell if it's plugs versus ignition coil. I have the same issue on cylinder two.
I had the same issue a few weeks ago. I started with the less expensive option and replaced the plugs with NGK laser platinums. It didn't correct the issue. Replacing the coil packs did the trick.

N20
56k miles

Cheers
Appreciate 0
      09-13-2019, 08:57 AM   #28
D Griff
New Member
D Griff's Avatar
United_States
11
Rep
27
Posts

Drives: 2014 328i, 2003 Corvette
Join Date: Mar 2019
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by OC_F32 View Post
I had the same issue a few weeks ago. I started with the less expensive option and replaced the plugs with NGK laser platinums. It didn't correct the issue. Replacing the coil packs did the trick.

N20
56k miles

Cheers
Thanks. I'll switch the coil pack from two to one... hopefully everything is good to go, but otherwise I'll replace that one if the code comes back on cylinder one.
__________________
2014 328i M Sport Estoril Blue Six Speed - Daily
2003 Corvette 50 AE Six Speed - Track/Fun
Appreciate 1
OC_F3292.00

      09-13-2019, 09:23 AM   #29
OC_F32
Private First Class
OC_F32's Avatar
92
Rep
107
Posts

Drives: 2015 428i
Join Date: Jan 2016
Location: Orange County, CA

iTrader: (0)

Quote:
Originally Posted by D Griff View Post
Quote:
Originally Posted by OC_F32 View Post
I had the same issue a few weeks ago. I started with the less expensive option and replaced the plugs with NGK laser platinums. It didn't correct the issue. Replacing the coil packs did the trick.

N20
56k miles

Cheers
Thanks. I'll switch the coil pack from two to one... hopefully everything is good to go, but otherwise I'll replace that one if the code comes back on cylinder one.
That makes sense. Let us know how it turns out.
Appreciate 0
      09-16-2019, 04:51 PM   #30
D Griff
New Member
D Griff's Avatar
United_States
11
Rep
27
Posts

Drives: 2014 328i, 2003 Corvette
Join Date: Mar 2019
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by OC_F32 View Post
That makes sense. Let us know how it turns out.
So far no code
__________________
2014 328i M Sport Estoril Blue Six Speed - Daily
2003 Corvette 50 AE Six Speed - Track/Fun
Appreciate 0
      09-16-2019, 04:53 PM   #31
OC_F32
Private First Class
OC_F32's Avatar
92
Rep
107
Posts

Drives: 2015 428i
Join Date: Jan 2016
Location: Orange County, CA

iTrader: (0)

Quote:
Originally Posted by D Griff View Post
Quote:
Originally Posted by OC_F32 View Post
That makes sense. Let us know how it turns out.
So far no code
Sweet! Fingers crossed!
Appreciate 0
      09-18-2019, 07:01 PM   #32
Zanity
Captain
Zanity's Avatar
Canada
533
Rep
925
Posts

Drives: F32
Join Date: Oct 2018
Location: YVR

iTrader: (0)

Quote:
Originally Posted by BunkerJ View Post
Quote:
Originally Posted by Slow_F32 View Post
So last Friday, I started my car during my lunch break, drove down the street and the check engine light came on. I haven't felt any symptoms yet but not sure since I haven't drove it much since then. I went to Autozone and used the scanner:

Error codes:
P0300 Random Misfire detected
P0303 Cylinder 3 Misfire detected
P0302 Cylinder 2 Misfire detected

Autozone printed out the results as well as a solution, which is to replace ignition coils and spark plugs. I ordered the kit that includes delphi ignition coils and spark plugs and plan on replacing this Friday.

I get regular maintenance at BMW with my upgrade maintenance plan whenever the maintenance light comes on. They said that spark plugs are included in the plan. When I asked why spark plugs were never replaced if they were included they stated spark plugs aren't due until 100k miles. Currently almost at 62k. They quoted me $175 just to diagnose the misfire. My engine is stock and I don't have any coding done.

Besides replacing the ignition coils and spark plugs, anyone else have any recommendations? Really hoping when I replace the parts this weekend and reset the cel that the problem is fixed.
Strange... I wonder if 100k is normal for them... Mine got replaced at 30k and then I replaced them with NGK iridium plugs at about 77k..

Just install those and you should be fine. Report back if it doesn't fix it.
100k is not normal, they're due for replacement at 60k (miles)
__________________
4 wheel moves the car, 2 wheel moves the soul.

Last edited by Zanity; 09-19-2019 at 11:12 AM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:20 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST