F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > ESYS Install Help
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      08-17-2019, 03:21 PM   #1
SirFisher
New Member
SirFisher's Avatar
United_States
0
Rep
10
Posts

Drives: 2016 BMW 340i xDrive 6MT
Join Date: Mar 2019
Location: Chicago

iTrader: (0)

ESYS Install Help

Hello, I have been searching around forums for the past few hours and have not found a solution to my problem so I figured I would post this here. I recently purchased a new laptop and after freshly installing Esys v 3.27.1 with the free token master v 2.82.162 free installer, when launching I am met with the error; "Loading: E-Sys Launcher PSdZ API Module Failed! Error C:\ProgramData\TokenMaster\E-Sys Launcher Pro\bin\PSdzAPI.dll: Can't find dependent libraries."

Is there a newer way to provide the est token to E-sys, I have this exact software setup on a different laptop where it runs without this error. I have checked through my entire c: drive and have now found the PSdzAPI.dll file anywhere. Is this something I need to download from somewhere or have I set my E-sys up incorrectly...

Older posts say to upgrade the pro launcher version, but as far as I know this is the newest reliable method. I looked into purchasing the premium as donation ware but I do not know when I would receive this product.

I followed the E-sys installation instructions provided by shawnsheridan to the best of my ability and have done a clean install of windows on my laptop as well as copied all of the files I used to install from my other laptop and that has not helped.

Any and all input is greatly appreciated, I just retrofitted NBT EVO id6, the 6wb cluster and rear parking sensors to my vehicle and I am in desperate need of coding it.

Thank you so much
Appreciate 0
      08-23-2019, 08:41 AM   #2
torobravo33
New Member
-2
Rep
12
Posts

Drives: BMW 340ix
Join Date: Aug 2019
Location: NYC

iTrader: (0)

Sounds like you need to download the PSdZ data and add it to C:/data/PSdZdata.
Appreciate 0
      08-23-2019, 11:19 AM   #3
SirFisher
New Member
SirFisher's Avatar
United_States
0
Rep
10
Posts

Drives: 2016 BMW 340i xDrive 6MT
Join Date: Mar 2019
Location: Chicago

iTrader: (0)

I will double check that I installed the PSdZdata in the correct location. I downloaded the latest Lite folder and installed it per the ESYS install instructions under C:/data/PSdZdata.


I tried redownloading the data but I got the same weird error saying its missing a file in the ProgramData folder, which is odd because the Pro Launcher is 32bit meaning that the tokenmaster folder is in ProgramData(x86)
Appreciate 0
      08-23-2019, 11:22 AM   #4
SirFisher
New Member
SirFisher's Avatar
United_States
0
Rep
10
Posts

Drives: 2016 BMW 340i xDrive 6MT
Join Date: Mar 2019
Location: Chicago

iTrader: (0)

I wanted to mention as well that I installed Esys on a separate windows surface in the exact method I did for the other laptop which has the response listed above. Interestingly the surface so far has not had any issues nor does it run into this error. I just would like to try and figure out what I did wrong on my own laptop because I am unable to borrow the other surface laptop that often.
Appreciate 0
      09-20-2019, 07:17 AM   #5
Fettler
Registered
0
Rep
1
Posts

Drives: BMW 520d 2016
Join Date: Sep 2019
Location: Essex UK

iTrader: (0)

Hi, I have the same problem as SiriFisher above:
New install of E-Sys v3.27.1 build 44813 with TokenMaster's free E-Sys Launcher Pro v2.82.162. When I run the launcher I get error message: "Loading: E-Sys Launcher PSdZ API Module Failed! Error C:\ProgramData\TokenMaster\E-Sys Launcher Pro\bin\PSdzAPI.dll: Can't find dependent libraries." I'm using Windows10 Home laptop.

When I start E-Sys without using the launcher, it runs and connects to my vehicle. I have downloaded PSdZ data and put it in C:/data/PSdZdata

Did you solve this problem? Any help would be much appreciated, thanks
Appreciate 0
      09-21-2019, 02:23 PM   #6
joshaguirre
New Member
0
Rep
11
Posts

Drives: 2016 xDrive28i F25
Join Date: Nov 2017
Location: Houston

iTrader: (0)

Same issue here...
Appreciate 0
      09-23-2019, 11:33 AM   #7
RuleNormaliai
New Member
RuleNormaliai's Avatar
2
Rep
15
Posts

Drives: F31 320d EfficientDynamics
Join Date: Aug 2019
Location: Lithuania

iTrader: (0)

The best working settings for me are:

Download E-Sys 3.27.1
Download ESysLauncherPROSetup_2.8.1_Build_155
Download TokenBuster_1.0

Install Esys
Install Launcher
Run TokenBuster
Follow the instructions and you're done!

Enjoy your fully working E-Sys (offcourse you will need PSdZData of version that you want)

If you want more info you can PM me i will be glad to help you out.
Appreciate 0
      09-30-2019, 08:08 AM   #8
pete in fate
New Member
0
Rep
6
Posts

Drives: 2016 320i
Join Date: Sep 2019
Location: Fate, TX

iTrader: (0)

v3.33.0

Quote:
Originally Posted by RuleNormaliai View Post
The best working settings for me are:

Download E-Sys 3.27.1
Download ESysLauncherPROSetup_2.8.1_Build_155
Download TokenBuster_1.0

Install Esys
Install Launcher
Run TokenBuster
Follow the instructions and you're done!

Enjoy your fully working E-Sys (offcourse you will need PSdZData of version that you want)

If you want more info you can PM me i will be glad to help you out.
Having issue with v3.33.0 Do you have links to the downloads that I need? You are very helpful, really appreciate it! Thanks!!
Appreciate 0
      10-01-2019, 06:10 PM   #9
FIREXTREMESLAYER
Registered
FIREXTREMESLAYER's Avatar
United_States
0
Rep
4
Posts

Drives: 15 BMW 328i
Join Date: Sep 2019
Location: Florida

iTrader: (0)

has this issue been resolved? i'm still being affected by it...
Appreciate 0
      10-05-2019, 11:09 PM   #10
SirFisher
New Member
SirFisher's Avatar
United_States
0
Rep
10
Posts

Drives: 2016 BMW 340i xDrive 6MT
Join Date: Mar 2019
Location: Chicago

iTrader: (0)

I'll be totally honest, I do not know why the issue was resolved. I took a break for two weeks and it was working by the end of it. Now I am having issues with ISTA+, so I do not know if the problems are related...
Appreciate 0
Post Reply

Bookmarks

Tags
e-sys, installation

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:35 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST