F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > Need help to figure out Launch Control
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      08-13-2015, 12:50 PM   #1
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Need help to figure out Launch Control

I'm quite confused whether my car has launch control or not.

I bought a 2015 328i xdrive about 3 months ago. Everyone is saying that my car should have Launch Control but my dealership is saying that it doesn't and that launch control is only reserved for M cars.

I don't know if my dealership really knows what they're talking about so I proceeded to test it out on my own if it really has one. I've watched a couple of videos of how to engage Launch Control and I wasn't successful doing so.

I'm wondering if someone here could help me out try to figure this one out. Is it really possible that my car doesn't have launch control even tho BMW made it standard to F30's starting 2014?
Appreciate 0
      08-13-2015, 01:32 PM   #2
ReadytoRetire
Registered
United_States
2
Rep
2
Posts

Drives: 2015 328 xDrive
Join Date: Aug 2015
Location: Long Island, NY

iTrader: (0)

refer to pg 75 in your manual:

Start with launch control
While the engine is running:
1. Press button or select Sport+ with
the Driving Dynamics Control.
TRACTION is displayed in the instrument
cluster and the indicator lamp for DSC OFF
lights up.
2. Engage selector lever position S.
3. With the left foot, forcefully press down on
the brake.
4. Press and hold down the accelerator pedal
beyond the resistance point at the full
throttle position.
A flag symbol is displayed in the instrument
cluster.
5. The starting engine speed adjusts. Within
3 seconds, release the brake.
Before using Launch Control, allow the transmission
to cool down for approx. 5 minutes.
Launch Control adjusts to the surrounding
conditions, e.g., wet pavement, when used
again.
Appreciate 1
      08-13-2015, 02:34 PM   #3
Livfast335
Lieutenant
Livfast335's Avatar
Canada
147
Rep
501
Posts

Drives: 2018 440i Gran Coupe X-Drive
Join Date: Feb 2015
Location: Montreal

iTrader: (1)

Quote:
Originally Posted by ReadytoRetire View Post
refer to pg 75 in your manual:

Start with launch control
While the engine is running:
1. Press button or select Sport+ with
the Driving Dynamics Control.
TRACTION is displayed in the instrument
cluster and the indicator lamp for DSC OFF
lights up.
2. Engage selector lever position S.
3. With the left foot, forcefully press down on
the brake.
4. Press and hold down the accelerator pedal
beyond the resistance point at the full
throttle position.
A flag symbol is displayed in the instrument
cluster.
5. The starting engine speed adjusts. Within
3 seconds, release the brake.
Before using Launch Control, allow the transmission
to cool down for approx. 5 minutes.
Launch Control adjusts to the surrounding
conditions, e.g., wet pavement, when used
again.
Can this work on the 2013? Or coded into it?
__________________
2020 BMW X3 30i M-Package
2018 BMW 440i X-Drive Gran Coupe l Premium Enhanced Package l M-Performance Package + M-Performance Pack 2 (retired)
2013 BMW 335i X-Drive (retired)
Appreciate 0
      08-13-2015, 02:46 PM   #4
crono06
Captain
crono06's Avatar
Canada
120
Rep
757
Posts

Drives: 2013 335i and 2018 X3
Join Date: Apr 2013
Location: Toronto ON

iTrader: (0)

Do you have Sport Auto?
Appreciate 0
      08-13-2015, 03:29 PM   #5
fecurtis
Banned
United_States
3203
Rep
6,302
Posts

Drives: 2014 BMW 335i M-Sport
Join Date: Jan 2014
Location: Arlington, VA

iTrader: (0)

Quote:
Originally Posted by bimmer_girl89 View Post
I'm quite confused whether my car has launch control or not.

I bought a 2015 328i xdrive about 3 months ago. Everyone is saying that my car should have Launch Control but my dealership is saying that it doesn't and that launch control is only reserved for M cars.

I don't know if my dealership really knows what they're talking about so I proceeded to test it out on my own if it really has one. I've watched a couple of videos of how to engage Launch Control and I wasn't successful doing so.

I'm wondering if someone here could help me out try to figure this one out. Is it really possible that my car doesn't have launch control even tho BMW made it standard to F30's starting 2014?
It's already been addressed on how to do it. I've never used it since it's just a gimmick anyway. You can just launch yourself by holding the brake, revving to around 2k RPM or so and just letting off the brake.
Appreciate 0
      08-13-2015, 03:52 PM   #6
BavarianFanatic
Too much is never enough
United_States
650
Rep
3,070
Posts

Drives: Too Many
Join Date: Mar 2008
Location: SE PA

iTrader: (0)

I question the need for "launch control" on an automatic 328i xDrive... ???
Appreciate 0
      08-13-2015, 04:27 PM   #7
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by crono06 View Post
Do you have Sport Auto?
Yes, I do have sport auto.
Appreciate 0
      08-13-2015, 04:29 PM   #8
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by BavarianFanatic View Post
I question the need for "launch control" on an automatic 328i xDrive... ???
Not that there's a need for it. I just want to try it out.
Appreciate 0
      08-13-2015, 08:47 PM   #9
crono06
Captain
crono06's Avatar
Canada
120
Rep
757
Posts

Drives: 2013 335i and 2018 X3
Join Date: Apr 2013
Location: Toronto ON

iTrader: (0)

You need to drive the car around for a bit first (around 6km) before it can work. Also ensure oil is up to standard operating temp.

I was told this when I got launch control coded on my 2013, but I've yet to ever try it. Unfortunately there's not much places I can even attempt it. I've also not gone out of my way to try it.
Appreciate 0
      08-14-2015, 08:44 AM   #10
jd_perspective
Captain
jd_perspective's Avatar
United_States
294
Rep
839
Posts

Drives: 2019 440i M-Sport
Join Date: Nov 2014
Location: Orlando, FL

iTrader: (0)

I had some fun with it the other night myself. Just kicked it up to Sport +, threw the shifter to the left in sport and floored the brakes and then the gas. After a few seconds it lit up. No problems. Not much effort.

Used it a few times. The last time was the best. laid it out!
__________________
2019 440i Coupe M-Sport
Black Sapphire Metallic / Black Leather

2018 330i Sedan M-Sport - Retired
2015 428i Gran Coupe M-Sport - Retired
Appreciate 0
      08-14-2015, 09:20 AM   #11
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by crono06 View Post
You need to drive the car around for a bit first (around 6km) before it can work. Also ensure oil is up to standard operating temp.

I was told this when I got launch control coded on my 2013, but I've yet to ever try it. Unfortunately there's not much places I can even attempt it. I've also not gone out of my way to try it.
I've tried it a couple times (following step-by-step instructions) but no luck. It won't engage. I was wondering if I would need it coded on my car too but I thought it was standard to 2014 and up models. I will maybe try again this weekend and see if it works.
Appreciate 0
      08-14-2015, 09:29 AM   #12
IndotagSwizz
Major
IndotagSwizz's Avatar
459
Rep
1,169
Posts

Drives: F30 320i
Join Date: Jan 2014
Location: Miami

iTrader: (0)

Quote:
Originally Posted by bimmer_girl89 View Post
I've tried it a couple times (following step-by-step instructions) but no luck. It won't engage. I was wondering if I would need it coded on my car too but I thought it was standard to 2014 and up models. I will maybe try again this weekend and see if it works.
do you have sports+
__________________
Appreciate 0
      08-14-2015, 09:33 AM   #13
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by IndotagSwizz View Post
do you have sports+
Yes I have sport+.
Appreciate 0
      08-14-2015, 09:39 AM   #14
IndotagSwizz
Major
IndotagSwizz's Avatar
459
Rep
1,169
Posts

Drives: F30 320i
Join Date: Jan 2014
Location: Miami

iTrader: (0)

Quote:
Originally Posted by bimmer_girl89 View Post
Yes I have sport+.

i guess the only other thing to double check is to make sure car has warmed up to normal driving temp and make sure the car is driven at least 6 miles without being turned off, i remember the first couple of times i tried it i couldn't get it to work but after a couple of tries it finally worked
__________________
Appreciate 0
      08-14-2015, 09:44 AM   #15
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by IndotagSwizz View Post
i guess the only other thing to double check is to make sure car has warmed up to normal driving temp and make sure the car is driven at least 6 miles without being turned off, i remember the first couple of times i tried it i couldn't get it to work but after a couple of tries it finally worked
I make sure of that too. I wait about 3-5 seconds flooring both the gas the brakes but nothing happens. So far I've only tried a couple times but both times it failed to engage. So not I'm not sure if my car really has it or not.
Appreciate 0
      08-14-2015, 09:45 AM   #16
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by exl_ent_v6 View Post
I had some fun with it the other night myself. Just kicked it up to Sport +, threw the shifter to the left in sport and floored the brakes and then the gas. After a few seconds it lit up. No problems. Not much effort.

Used it a few times. The last time was the best. laid it out!
I followed the same instructions but failed to engage it
Appreciate 0
      08-14-2015, 09:52 AM   #17
IndotagSwizz
Major
IndotagSwizz's Avatar
459
Rep
1,169
Posts

Drives: F30 320i
Join Date: Jan 2014
Location: Miami

iTrader: (0)

Quote:
Originally Posted by bimmer_girl89 View Post
I make sure of that too. I wait about 3-5 seconds flooring both the gas the brakes but nothing happens. So far I've only tried a couple times but both times it failed to engage. So not I'm not sure if my car really has it or not.
press the brake ALL THE WAY DOWN first, don't be scared to mash it, this was my mistake, while you are holding the brake all the way down press the gas ALL THE WAY DOWN, you will hear a click when you mash the gas all the way down, flag should light up then on your dash...let go of the brake and enjoy... hopefully this works
__________________
Appreciate 0
      08-14-2015, 09:52 AM   #18
BDWonder
Captain
126
Rep
737
Posts

Drives: 2016 M5
Join Date: Aug 2013
Location: California/BK NY

iTrader: (0)

Quote:
Originally Posted by ReadytoRetire View Post
refer to pg 75 in your manual:

Start with launch control
While the engine is running:
1. Press button or select Sport+ with
the Driving Dynamics Control.
TRACTION is displayed in the instrument
cluster and the indicator lamp for DSC OFF
lights up.
2. Engage selector lever position S.
3. With the left foot, forcefully press down on
the brake.
4. Press and hold down the accelerator pedal
beyond the resistance point at the full
throttle position.
A flag symbol is displayed in the instrument
cluster.
5. The starting engine speed adjusts. Within
3 seconds, release the brake.
Before using Launch Control, allow the transmission
to cool down for approx. 5 minutes.
Launch Control adjusts to the surrounding
conditions, e.g., wet pavement, when used
again.
This! One thing to add, as i was doing all this and it still didnt work. Hold the brake pedal alllllllllll the way down. Very important. I pressed the brake pedal, i thought was forcefully, but it wasnt. You must really press the brake pedal down hard. Good luck.
Appreciate 0
      08-14-2015, 09:54 AM   #19
IndotagSwizz
Major
IndotagSwizz's Avatar
459
Rep
1,169
Posts

Drives: F30 320i
Join Date: Jan 2014
Location: Miami

iTrader: (0)

Quote:
Originally Posted by BDWonder View Post
This! One thing to add, as i was doing all this and it still didnt work. Hold the brake pedal alllllllllll the way down. Very important. I pressed the brake pedal, i thought was forcefully, but it wasnt. You must really press the brake pedal down hard. Good luck.
+1
__________________
Appreciate 0
      08-14-2015, 10:04 AM   #20
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by IndotagSwizz View Post
press the brake ALL THE WAY DOWN first, don't be scared to mash it, this was my mistake, while you are holding the brake all the way down press the gas ALL THE WAY DOWN, you will hear a click when you mash the gas all the way down, flag should light up then on your dash...let go of the brake and enjoy... hopefully this works
Ok, maybe I'm not pressing it all the way. When you press down the gas, does it feel like you are pressing past the resistance point? Is that when you will hear a click?

The first time I tried it, after pressing the gas all the way down the car jerked forward a little bit and nothing else after that.
Appreciate 0
      08-14-2015, 10:06 AM   #21
IndotagSwizz
Major
IndotagSwizz's Avatar
459
Rep
1,169
Posts

Drives: F30 320i
Join Date: Jan 2014
Location: Miami

iTrader: (0)

Quote:
Originally Posted by bimmer_girl89 View Post
Ok, maybe I'm not pressing it all the way. When you press down the gas, does it feel like you are pressing past the resistance point? Is that when you will hear a click?

The first time I tried it, after pressing the gas all the way down the car jerked forward a little bit and nothing else after that.
yup thats it
__________________
Appreciate 1
      08-14-2015, 10:09 AM   #22
bimmer_girl89
Private First Class
bimmer_girl89's Avatar
Canada
80
Rep
170
Posts

Drives: 2020 F39 X2 xDrive28i
Join Date: Mar 2014
Location: Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by IndotagSwizz View Post
yup thats it
Well thanks! I will try that and see if it works this time.
Appreciate 1
Post Reply

Bookmarks

Tags
f30, launch control, xdrive

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:48 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST