F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > Drivetrain Malfunction - Only in Eco and Comfort
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      10-26-2019, 10:18 AM   #1
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Drivetrain Malfunction - Only in Eco and Comfort

I have a 13 328i n20 xdrive that throws a drivetrain malfunction only when driving in Ecopro and Comfort modes. If it's in Sport, never throws the code. I don't remember the codes off the top of my head but I recall them being a Vanos and boost pressure errors from a previous scan. Does anyone have any thoughts? I can easily get the malfunction to come back on and get the exact codes. Had timing chain replaced at 90k. Currently has 105k. Just don't want to keep blowing through tanks of gas constantly driving in Sport mode.
Appreciate 0
      10-26-2019, 01:33 PM   #2
bmwchue
Captain
228
Rep
800
Posts

Drives: 2013 bmw 328i
Join Date: Oct 2017
Location: California

iTrader: (0)

codes would be helpful
Appreciate 1
      10-26-2019, 04:43 PM   #3
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Quote:
Originally Posted by bmwchue View Post
codes would be helpful
I was able to throw codes on my way home from work. Will scan them and screen shot and post them
Appreciate 1
bmwchue228.00
      10-26-2019, 07:32 PM   #4
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Attached are the codes I pulled. Also noticed there's no clamp around the charge pipe.. any connection?
Attached Images
  
Appreciate 0
      10-26-2019, 07:35 PM   #5
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Quote:
Originally Posted by bmwchue View Post
codes would be helpful
New to using the app sorry. Here are the codes. Also, should there be a clamp around the charge pipe?
Attached Images
  
Appreciate 0
      10-26-2019, 08:23 PM   #6
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5390
Rep
11,498
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Google each of those errors. The links that turn up may contain solutions.
Appreciate 0
      10-26-2019, 10:57 PM   #7
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
Google each of those errors. The links that turn up may contain solutions.
I have. It ranges from vanos issues to a possible charge pipe leak. Then tonight happen to notice the "missing" charge pipe clamp and haven't had the issue since the timing chain was replaced.
Appreciate 0
      10-27-2019, 08:36 AM   #8
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5390
Rep
11,498
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

You haven't had the issue since replacing the timing chain? Or that's when it started? If that's when it started remember there's no such thing as coincidence.
Appreciate 0
      10-27-2019, 11:57 AM   #9
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
You haven't had the issue since replacing the timing chain? Or that's when it started? If that's when it started remember there's no such thing as coincidence.
It started to happen after the timing chain replacement. Just find it odd that when driven in sports mode it will never throw the error.
Appreciate 0
      10-27-2019, 01:47 PM   #10
Polo08816
Brigadier General
1301
Rep
3,487
Posts

Drives: 2014 335i M Sport
Join Date: Sep 2010
Location: MD

iTrader: (0)

I hate these 3rd party code reader apps for diagnosis.

BMW's ISTA records the mileage (km) when each of the faults come up so you have a better idea of the sequence of fault codes.
Appreciate 0
      10-27-2019, 05:04 PM   #11
dditmarsf30
New Member
2
Rep
7
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Oct 2019
Location: NH

iTrader: (0)

Quote:
Originally Posted by Polo08816 View Post
I hate these 3rd party code reader apps for diagnosis.

BMW's ISTA records the mileage (km) when each of the faults come up so you have a better idea of the sequence of fault codes.
Unfortunately not. Current mileage is 105327. I know that doesn't do much of anything but just wanted to throw it out there
Appreciate 0
      08-12-2020, 02:08 AM   #12
Tomasz_
New Member
0
Rep
8
Posts

Drives: f30 320i
Join Date: Aug 2020
Location: EU

iTrader: (0)

Hi,
Did you found out reason ?
Ive got same situation - Drive malfunction is coming only in eco and comfort mode, never in sport. Main error is 130308 - vanos outlet (exhaust), position not reached, it comes when driving in low rpm range (below 2,5k).

I am now waiting for replacing both Vanos units....
Appreciate 0
      08-18-2020, 02:38 AM   #13
Tomasz_
New Member
0
Rep
8
Posts

Drives: f30 320i
Join Date: Aug 2020
Location: EU

iTrader: (0)

If anyone will have same sympthoms, in my case replacing both vanos for new OEM units solved this issue.
Appreciate 0
      08-23-2020, 10:23 AM   #14
ultim
New Member
2
Rep
11
Posts

Drives: F30 320i
Join Date: May 2017
Location: Midlands

iTrader: (0)

Im experiencing similar issue with codes 130308.

Can you link me to the exact part you replaced please?
Appreciate 0
      08-24-2020, 05:58 AM   #15
Tomasz_
New Member
0
Rep
8
Posts

Drives: f30 320i
Join Date: Aug 2020
Location: EU

iTrader: (0)

I have replaced parts no. 7 and 8:
https://www.realoem.com/bmw/enUS/sho...diagId=11_4773

07 Adjustment unit, inlet camshaft 1 11367583818
08 Adjustment unit, outlet camshaft 1 11367583819

In my case only outlet Vanos was suspected and was giving errors, but it was advised to replace both, however it was not cheap....
Appreciate 0
      08-24-2020, 07:24 AM   #16
ultim
New Member
2
Rep
11
Posts

Drives: F30 320i
Join Date: May 2017
Location: Midlands

iTrader: (0)

Thanks for replying back.

What made you change those two parts? I would've suspected the VANOS central valve itself (10)
Appreciate 0
      08-24-2020, 07:38 AM   #17
Tomasz_
New Member
0
Rep
8
Posts

Drives: f30 320i
Join Date: Aug 2020
Location: EU

iTrader: (0)

First, just right after buying this car with about 85k miles I have changed timing chain, and oil. After that, i was getting error 130308 (exhaust vanos, position not reached) every time when driving in comfort or eco mode in low RPM. When i was driving in sport, there was no errors.
First troubleshooting was to swap vanos solenoids, but after that error was still on exhaust side. So i went to local bmw service, and they suspected exhaust vanos units due to some visible wear on it. So it was a bit of blind quess, but i followed their advised and replaced both units - so far error is not coming back.

Another thing is now i am getting some strange rattling while acceleration, but it seems to be not connected....
Appreciate 0
      08-24-2020, 09:16 AM   #18
ultim
New Member
2
Rep
11
Posts

Drives: F30 320i
Join Date: May 2017
Location: Midlands

iTrader: (0)

Thanks for info.

I think im going to approach it by cleaning the valves first and see if the issue goes away (might be temporarily). Like you say, its alot of money replacing the parts, especially if its the wrong one.
Appreciate 0
      08-24-2020, 02:47 PM   #19
Tomasz_
New Member
0
Rep
8
Posts

Drives: f30 320i
Join Date: Aug 2020
Location: EU

iTrader: (0)

You can try clean both vanos solenoids and test them with external voltage to check if they work properly.
Appreciate 0
Post Reply

Bookmarks

Tags
328i, drivetrain, f30, malfunction, n20, xdrive

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:19 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST