F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > N20 still stumbling after injectors replaced under warranty...
Vorsteiner
Post Reply
 
Thread Tools Search this Thread
      02-22-2018, 04:13 PM   #1
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

N20 still stumbling after injectors replaced under warranty...

After storing my car ('16 328i 6MT) for about 2.5 months while I was travelling for work I noticed that when I would drive aggressively - most notably, accelerating with more than 3/4 throttle in third gear when the tach would swing past 4K rpms) it would stumble and feel like it was hitting a soft redline. When it did this I immediately let off of the throttle but it never threw a CEL or acted out of the ordinary other than that or similar situation. I always use 93 octane Shell gas and change the oil every 5-6K with Liqui Molly so it's not a neglect issue. The car has about 26K miles on it and is DME tuned by BPC with an ER catted downpipe, however, that's been done to the car almost the entire 1.5 years I've owned it and never done this despite two track sessions and a weekend at the Tail of the Dragon.

I took the car to my local BMW dealership. They diagnosed and repaired it with the following notes on my work order and parts that were replaced:

"Connected battery charger and found faults for misfire cyl 2 and 4. Swapped coils and plugs test drove car misfire stayed same cyl. Ran test plan found 2 and 4 injectors to be faulty. Replaced with EU6 injectors and no further issue found."

Parts ordered:
Qty 2 13-64-8-625-397 RP Injector WARRANTY
Qty 2 13-53-7-577-649 Decoupling Element WARRANTY


I drove the car home and it seemed fine but I couldn't really push it because of the weather and the traffic. It seemed to stumble like before once a couple days later but seemed fine for the rest of the day and I really pushed it trying to get it to repeat the stumble. Today, getting on a freeway on-ramp I went full throttle in 3rd gear and like before when it got to around 4-5K rpms it stumbled and I immediately let off. So obviously this did not fully fix the problem. I called the dealership and am dropping the car back off early tomorrow morning.

As a future precaution I had F80 M3 spark plugs installed (one step colder) during the last repair just for preventative maintenance since it is tuned. This problem occurred before that switch so the plugs are ruled out. The only thing I can think of is that the coil pack needs to be replaced but the tech's notes seem to indicated that they tested them and were fine. While it may be a totally coincidence, this only started happened after the car sat for a little over 2 months while I was away. The garage is climate controlled so I don't know how that would play into it. I'm really at a loss here. Looking for any and all experience or advice! Thanks!
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit

Last edited by Cammy5; 02-22-2018 at 04:15 PM. Reason: spelling
Appreciate 0
      02-22-2018, 07:51 PM   #2
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Could explain the stumbling? As in you hit the "redline" and it seems to sputter at that point?

I had a similar (if not the same) issue when I was getting my tune done. I had two issues that were fixed. First was gapping my plugs (NGK LI plugs now) at 0.018". I'm pushing around 23psi, so that was the requirement for the plug. Secondly, another part of the sputtering at 5k under WOT had to do with some fueling tables.

Does that sound similar to your issue?
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 0
      02-22-2018, 09:43 PM   #3
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

Quote:
Originally Posted by BunkerJ View Post
Could explain the stumbling? As in you hit the "redline" and it seems to sputter at that point?

I had a similar (if not the same) issue when I was getting my tune done. I had two issues that were fixed. First was gapping my plugs (NGK LI plugs now) at 0.018". I'm pushing around 23psi, so that was the requirement for the plug. Secondly, another part of the sputtering at 5k under WOT had to do with some fueling tables.

Does that sound similar to your issue?
It sounds somewhat familiar. Another way for me to describe it is that as it reaches around 4-5K if feels as though it has hit redline. Tonight it did it again but for the first time I just kept my foot down and after 3/4 to a full second it then continued to accelerate normally. Obviously something is amiss here. My max boost is set to 21.9 according to my OBD Fusion app. Also interesting is that I had that app hooked up to the car while driving tonight and it didn't pick up an trouble codes during that episode.
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit
Appreciate 0
      02-22-2018, 10:24 PM   #4
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by Cammy5 View Post
It sounds somewhat familiar. Another way for me to describe it is that as it reaches around 4-5K if feels as though it has hit redline. Tonight it did it again but for the first time I just kept my foot down and after 3/4 to a full second it then continued to accelerate normally. Obviously something is amiss here. My max boost is set to 21.9 according to my OBD Fusion app. Also interesting is that I had that app hooked up to the car while driving tonight and it didn't pick up an trouble codes during that episode.
I didn't get any CELs or codes in my diagnostics. For my situation, I would like to have assumed it was a fueling issue, but I did both things at the same time. I would check what your plugs are gapped at and see if that might help. Otherwise, because it just came on, I would assume a fueling issue. Is there sputtering or any popping when you hit 5k? Also, is this just under WOT?
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 0
      02-23-2018, 12:14 AM   #5
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

Quote:
Originally Posted by BunkerJ View Post
I didn't get any CELs or codes in my diagnostics. For my situation, I would like to have assumed it was a fueling issue, but I did both things at the same time. I would check what your plugs are gapped at and see if that might help. Otherwise, because it just came on, I would assume a fueling issue. Is there sputtering or any popping when you hit 5k? Also, is this just under WOT?
Yes, 3/4 to WOT only. Mysteriously, not every time though. I'd say, maybe like 1 out of 3 or 4 times I would do those type of acceleration runs.
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit
Appreciate 0
      02-23-2018, 05:33 AM   #6
IssaF32
First Lieutenant
IssaF32's Avatar
United_States
108
Rep
343
Posts

Drives: 2014 428xi Coupe
Join Date: Sep 2017
Location: San diego

iTrader: (0)

Honestly try changing your spark plugs to a gap of .018
__________________
Wagner Comp Evo 1 Intercooler, Injen Cold Air intake, VRSF 4" Catless downpipe, NGK laser iridium .018, Straight piped, Evolution Racewerks Chargepipe, Stage 2 fuel-it lpfp, Bootmod3, HCP Tuned for e50, Snow Performance Stage 2 Meth injection 225cc 50/50. 18lb Konig Race Wheels. Federal 595 SS Tires. Instagram:f32_hunter
Appreciate 0
      02-23-2018, 10:53 AM   #7
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by Cammy5 View Post
Yes, 3/4 to WOT only. Mysteriously, not every time though. I'd say, maybe like 1 out of 3 or 4 times I would do those type of acceleration runs.
If it's happening like that, I'm going to say fuel related. Plugs being gapped at 0.018" is normal for 22psi or so, but you're not getting any misfires. If it were plug related only, you'd be getting the misfire codes. I would take a look at anything fuel related because this sounds exactly like my issue before.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 0
      02-23-2018, 10:57 AM   #8
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

Quote:
Originally Posted by BunkerJ View Post
If it's happening like that, I'm going to say fuel related. Plugs being gapped at 0.018" is normal for 22psi or so, but you're not getting any misfires. If it were plug related only, you'd be getting the misfire codes. I would take a look at anything fuel related because this sounds exactly like my issue before.
Forgive my technical ignorance, but would 'fuel related' encompass coils or would it only be tune related or something like the fuel pump? I'm just trying to wrap my head around it. The car is at the dealership as of this morning but I always get nervous that I'll get the old "cannot duplicate issue, operating as designed" answer. Again, one thing that sets off a flag in my mind is that it only started doing this after it sat for about 2.5 months. Maybe a coincidence of course but just gets me thinking.
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit
Appreciate 0
      02-23-2018, 11:15 AM   #9
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by Cammy5 View Post
Forgive my technical ignorance, but would 'fuel related' encompass coils or would it only be tune related or something like the fuel pump? I'm just trying to wrap my head around it. The car is at the dealership as of this morning but I always get nervous that I'll get the old "cannot duplicate issue, operating as designed" answer. Again, one thing that sets off a flag in my mind is that it only started doing this after it sat for about 2.5 months. Maybe a coincidence of course but just gets me thinking.
Fuel is going to be your Low Pressure Fuel Pump (LPFP), High Pressure FP (HPFP), injectors, etc.

I say fuel because it was the same thing for me. We were testing my tune and under WOT, I wasn't getting the correct fuel amount sent and it would cause it to sputter and not progress past 5k. Sounded like a damn AK, lol. I would tell them to try to replicate several times, in Sport +, under WOT each time.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 0
      02-23-2018, 11:18 AM   #10
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

Quote:
Originally Posted by BunkerJ View Post
Fuel is going to be your Low Pressure Fuel Pump (LPFP), High Pressure FP (HPFP), injectors, etc.

I say fuel because it was the same thing for me. We were testing my tune and under WOT, I wasn't getting the correct fuel amount sent and it would cause it to sputter and not progress past 5k. Sounded like a damn AK, lol. I would tell them to try to replicate several times, in Sport +, under WOT each time.
Thanks for all your help! Like I sad the car is at the dealership so if they can't narrow it down/find it I'll take it back to my tuner and talk with him over going over anything. I'll update this thread this afternoon later with what the dealership comes up with. Thanks!
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit
Appreciate 0
      02-23-2018, 01:08 PM   #11
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by Cammy5 View Post
Thanks for all your help! Like I sad the car is at the dealership so if they can't narrow it down/find it I'll take it back to my tuner and talk with him over going over anything. I'll update this thread this afternoon later with what the dealership comes up with. Thanks!
For sure. IF they don't discover the issue, see if your tuner can put you back to stock. If so, do it and then put it under the same test conditions and test it!
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 1
Cammy5115.00

      02-23-2018, 05:18 PM   #12
IssaF32
First Lieutenant
IssaF32's Avatar
United_States
108
Rep
343
Posts

Drives: 2014 428xi Coupe
Join Date: Sep 2017
Location: San diego

iTrader: (0)

Just take a sledgehammer to your injectors get them deeeeep inside there and u should be good (:
__________________
Wagner Comp Evo 1 Intercooler, Injen Cold Air intake, VRSF 4" Catless downpipe, NGK laser iridium .018, Straight piped, Evolution Racewerks Chargepipe, Stage 2 fuel-it lpfp, Bootmod3, HCP Tuned for e50, Snow Performance Stage 2 Meth injection 225cc 50/50. 18lb Konig Race Wheels. Federal 595 SS Tires. Instagram:f32_hunter
Appreciate 0
      02-24-2018, 12:03 AM   #13
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

As I feared, the dealership said they could not replicate the issue... However, the second time I did the typical full throttle in second or third gear this happened. Car went into limp mode and I limped into to the next exit and pulled into a parking lot where I plugged in my OBDII dongle and app - misfire on every cylinder. I crossed my fingers and shut the car off and restarted it and the limp mode was gone. I drove it like a senior citizen home (about 5 miles away) and will be taking it back up to the dealership tomorrow morning. It's just frustrating at this point.
Attached Images
   
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit
Appreciate 0
      02-24-2018, 12:39 AM   #14
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Damn! Well, I would gap them to 0.018 or 0.02, just to clear that off the table. Pretty easy process.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 1
Cammy5115.00

      02-24-2018, 12:40 AM   #15
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Also, get it to your tuner and ask to go back to stock. Run the same tests several times. If no issue, then you have the problem.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 0
      02-24-2018, 11:55 AM   #16
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

Quote:
Originally Posted by BunkerJ View Post
Also, get it to your tuner and ask to go back to stock. Run the same tests several times. If no issue, then you have the problem.
Dropping it off Sunday night with the tuning shop so they can accurately diagnosis what in the world is going on. Will update here Monday afternoon.
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit
Appreciate 0
      02-26-2018, 10:07 PM   #17
Cammy5
First Lieutenant
United_States
115
Rep
397
Posts

Drives: 2016 BMW 328i M Sport 6MT
Join Date: Oct 2016
Location: Raleigh, NC

iTrader: (6)

Quote:
Originally Posted by BunkerJ View Post
Damn! Well, I would gap them to 0.018 or 0.02, just to clear that off the table. Pretty easy process.
Picked it up from the tuner/performance shop this evening and all is FINALLY well. Of all the things....the dealership did not gap the S55 spark plugs correctly and that was the root of this second round of (worse) misfires after the dealership initially replaced injectors 2 and 4. Such a small thing for them to overlook which caused me so much headache! Oh well, all is well now and BPC (the shop that repaired this and tuned the car) came through for me.
__________________
2016 BMW 328i M Sport 6MT (Mineral Grey over Coral Red)
*BPC DME Custom Stage 1 Tune
*Evolution Racerwerks Competition Intercooler & Chargepipe
*M Performance Big Brake Kit

Last edited by Cammy5; 02-26-2018 at 10:56 PM.
Appreciate 0
      02-27-2018, 10:53 AM   #18
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by Cammy5 View Post
Picked it up from the tuner/performance shop this evening and all is FINALLY well. Of all the things....the dealership did not gap the S55 spark plugs correctly and that was the root of this second round of (worse) misfires after the dealership initially replaced injectors 2 and 4. Such a small thing for them to overlook which caused me so much headache! Oh well, all is well now and BPC (the shop that repaired this and tuned the car) came through for me.
Woohoo! There we go. Glad you're up and running and can finally do some pulls again.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 1
Cammy5115.00

      03-18-2018, 10:36 PM   #19
lowjonathan
Private
8
Rep
52
Posts

Drives: 328i
Join Date: Sep 2014
Location: --------

iTrader: (0)

Quote:
Originally Posted by BunkerJ View Post
Could explain the stumbling? As in you hit the "redline" and it seems to sputter at that point?

I had a similar (if not the same) issue when I was getting my tune done. I had two issues that were fixed. First was gapping my plugs (NGK LI plugs now) at 0.018". I'm pushing around 23psi, so that was the requirement for the plug. Secondly, another part of the sputtering at 5k under WOT had to do with some fueling tables.

Does that sound similar to your issue?
Hi there

may i ask how u resolve this sputtering issue?
i am using bm3 stg 1 OTS map....
Appreciate 0
      03-18-2018, 11:14 PM   #20
BunkerJ
Colonel
BunkerJ's Avatar
902
Rep
2,244
Posts

Drives: 2013 328i
Join Date: Mar 2017
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by lowjonathan View Post
Hi there

may i ask how u resolve this sputtering issue?
i am using bm3 stg 1 OTS map....
Since you're using the OTS map, I would regap your plugs to 0.018 or 0.02 first. If that doesn't work, please let BM3 know that you're experiencing this issue. It could be that the OTS map was wrong, but double check your plugs first.
__________________

2013 F30 328i: MHI Big Turbo, GFB DV+, Mishimoto CAI, ER TIC/CP/Catless DP, AWE Touring Quad Exhaust w/ Resonated Midpipe, NGK LI Plugs, BM3 with PTF Stage 2 91 AGG Tune, Fuel-it Stage 2 LPFP, Solowerks S1 Coilovers, and DEPO/M-Sport Retrofit
Appreciate 0
      03-18-2018, 11:20 PM   #21
lowjonathan
Private
8
Rep
52
Posts

Drives: 328i
Join Date: Sep 2014
Location: --------

iTrader: (0)

Quote:
Originally Posted by BunkerJ View Post
Since you're using the OTS map, I would regap your plugs to 0.018 or 0.02 first. If that doesn't work, please let BM3 know that you're experiencing this issue. It could be that the OTS map was wrong, but double check your plugs first.
yup the plugs are gap already...

i will let bm3 know on this

tks
Appreciate 0
      03-19-2018, 02:58 PM   #22
ChubbyWilly
Second Lieutenant
ChubbyWilly's Avatar
United_States
72
Rep
292
Posts

Drives: 2013 328i FBO
Join Date: Apr 2014
Location: DFW

iTrader: (0)

Quote:
Originally Posted by Cammy5 View Post
Picked it up from the tuner/performance shop this evening and all is FINALLY well. Of all the things....the dealership did not gap the S55 spark plugs correctly and that was the root of this second round of (worse) misfires after the dealership initially replaced injectors 2 and 4. Such a small thing for them to overlook which caused me so much headache! Oh well, all is well now and BPC (the shop that repaired this and tuned the car) came through for me.
Do you know what they re-gapped the plugs to?
__________________

Mods: BM3 Stae 2 93 Octane tune, VRSF FMIC, K&N Drop In Filter, Catless DP, Muffler delete w/ dual exit, H&R Sport Springs, Bilstein B8 Rear Shocks.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:07 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST