F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > Heated Steering Wheel Function Retrofit discussion and sharing
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      08-31-2017, 07:11 AM   #67
gotomoto
Private
gotomoto's Avatar
15
Rep
69
Posts

Drives: F30 3.20ied
Join Date: Jan 2016
Location: Ankara, TR

iTrader: (0)

So i tried to do this. connected the cables as instructed. got a new heating button and not working. ISTA gives the error below. I tried my friends steering column switch. still not working. anybody has an idea?
Attached Images
 
Appreciate 0
      10-21-2017, 11:56 AM   #68
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

3 wire connection from module

I want to tetrofit a heated steering wheel with vibration.
I see the following difference with all previous posts.
I have a 3 wired connection to the 83*4B.
The thicker wires ar masse and + i assume, but who knows where the thinner wire is used for?
I have to connect the wires to the unused pins of the airbag connector but im confused about the thinner wire.
Please can somebody help?
Appreciate 0
      11-12-2017, 07:43 AM   #69
Jhnblckwood
First Lieutenant
31
Rep
392
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Good job guys. So doing it this way as opposed to David's guide (very nice too bro) do we not have to run wires to fuse box or relaxe the steering column cluster? I'm very technically inclined I'm jus not familiar with some of the wording. Lol
Thanks!!
Also I'm going from f30 with no park assist or anything to regular heated steering wheel so basically I jus need the steering wheel n switch?
Appreciate 0
      11-15-2017, 04:28 PM   #70
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by gotomoto View Post
So i tried to do this. connected the cables as instructed. got a new heating button and not working. ISTA gives the error below. I tried my friends steering column switch. still not working. anybody has an idea?
Hi, i hahe followed the procedure mine isn't working either, did you manage to make it work?

Last edited by talharama; 11-16-2017 at 01:51 PM.
Appreciate 0
      11-16-2017, 03:31 AM   #71
gotomoto
Private
gotomoto's Avatar
15
Rep
69
Posts

Drives: F30 3.20ied
Join Date: Jan 2016
Location: Ankara, TR

iTrader: (0)

Quote:
Originally Posted by talharama View Post
Hi, i habe followed the procedure mine isn't working either, did you manage to make it work?
no not really. where did you connect the power? you have the same error like i have?
Appreciate 0
      11-16-2017, 12:28 PM   #72
r0b3r
Private
6
Rep
78
Posts

Drives: Bmw F20 Pack m
Join Date: Nov 2014
Location: Espaņa

iTrader: (0)

Error sorryy

Last edited by r0b3r; 11-16-2017 at 03:47 PM.
Appreciate 0
      11-16-2017, 02:00 PM   #73
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by gotomoto View Post
no not really. where did you connect the power? you have the same error like i have?
I already had the power cables on the back of the SZL on pin 9 and 11, i have connected two wires from airbag harness to the heating control unit. I have checked the diagrams and i don't think we can take power from airbag harness, because all them free pins are for airbag activation in case of crash.

My heating button do not even lit up when i press it.
I have ordered new SZL with heating function, lets see what happens.

Last edited by talharama; 11-16-2017 at 04:38 PM.
Appreciate 0
      11-16-2017, 02:24 PM   #74
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by gotomoto View Post
no not really. where did you connect the power? you have the same error like i have?
I can't check the error as I don't have ISTA.
Appreciate 0
      11-16-2017, 03:09 PM   #75
accloginsell
New Member
0
Rep
7
Posts

Drives: BMW
Join Date: May 2016
Location: DEU

iTrader: (0)

HI all,

where need switch 61319201736 pinned in ?

In FEM? if yes which pins??

Thanks
Appreciate 0
      11-16-2017, 04:40 PM   #76
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by accloginsell View Post
HI all,

where need switch 61319201736 pinned in ?

In FEM? if yes which pins??

Thanks
In the back of switch cluster (SZL) there is a port with three pins.
Appreciate 0
      11-17-2017, 02:01 PM   #77
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by gotomoto View Post
So i tried to do this. connected the cables as instructed. got a new heating button and not working. ISTA gives the error below. I tried my friends steering column switch. still not working. anybody has an idea?
I have the same reading in ISTA
No idea what could be the problem
Appreciate 0
      11-17-2017, 02:36 PM   #78
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

coding

Which part of the FEM should be coded?
I can't really find "lenkradheizung aktiv/nicht aktiv
Appreciate 0
      11-17-2017, 04:36 PM   #79
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by Tibass View Post
I have the same reading in ISTA
No idea what could be the problem
Problem is the SZL, if yours hasn't got heating function it won't work, you would mostl probably need a new szl with heating function.
Appreciate 0
      11-17-2017, 05:22 PM   #80
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by talharama View Post
Problem is the SZL, if yours hasn't got heating function it won't work, you would mostl probably need a new szl with heating function.
i have a szl with heating function.
But i have the idea i haven't got it coded right.
Thats why i was wondering wich part of the embody i have to code.
Another thins is that my car already has the power wires pre installed on the back of the szl but im doubting if the are active (have power 12v)
I will also look at them in the morning..
Appreciate 0
      11-17-2017, 05:24 PM   #81
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by Tibass View Post
i have a szl with heating function.
But i have the idea i haven't got it coded right.
Thats why i was wondering wich part of the embody i have to code.
Another thins is that my car already has the power wires pre installed on the back of the szl but im doubting if the are active (have power 12v)
I will also look at them in the morning..
i ment fembody or other ecu's
Appreciate 0
      11-18-2017, 03:23 AM   #82
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by Tibass View Post
i ment fembody or other ecu's
What i wanted to say is:
My car has the 2 wires for 12v at the back of the SZL installed (pin 9 and 11) and as far as i can see they are factory installed (they are a part of the harness) but i do not measure power on the cable. Do i have to activate the 12v on the wires or is there a fuse?
Appreciate 0
      11-18-2017, 10:18 AM   #83
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by Tibass View Post
What i wanted to say is:
My car has the 2 wires for 12v at the back of the SZL installed (pin 9 and 11) and as far as i can see they are factory installed (they are a part of the harness) but i do not measure power on the cable. Do i have to activate the 12v on the wires or is there a fuse?
You will habe to code the following ECU;

Add option 248 to FA and code following ECU's

FEMBODY
ICM
KOMBI

I have also got two wires factory installed in the back of sz i have jist received the multimeter will check if they have power.

l did you check with multimeter if yours has 12v power?

Incase if it doesn't have the power you can follow instructions on this link;

http://f30.bimmerpost.com/forums/sho....php?t=1231186
Appreciate 0
      11-18-2017, 10:37 AM   #84
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by talharama View Post
You will habe to code the following ECU;

Add option 248 to FA and code following ECU's

FEMBODY
ICM
KOMBI

I have also got two wires factory installed in the back of sz i have jist received the multimeter will check if they have power.

l did you check with multimeter if yours has 12v power?

Incase if it doesn't have the power you can follow instructions on this link;

http://f30.bimmerpost.com/forums/sho....php?t=1231186
Just checked, i have 12v power in pin 9 and 11.
Appreciate 0
      11-18-2017, 05:44 PM   #85
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by talharama View Post
Just checked, i have 12v power in pin 9 and 11.
Thank you!
Im going to check once again at pin 9 and 11.
Can you tell me which parts of Fembody, ICM and Kombi i have to change/code?
I am searching but i can't really find a active/not active coding for the heated steering wheel.
Only heating time.
I would really appreciate it.
Appreciate 0
      11-18-2017, 07:18 PM   #86
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by Tibass View Post
Thank you!
Im going to check once again at pin 9 and 11.
Can you tell me which parts of Fembody, ICM and Kombi i have to change/code?
I am searching but i can't really find a active/not active coding for the heated steering wheel.
Only heating time.
I would really appreciate it.
No problem, You don't have to change any settings on above mentioned ECUs, just add 248 in FA and then code the above three ECUs.

See the attached image as reference.

I assume you know how to change cars FA? If not then Google it there is plenty instructions.
Appreciate 0
      11-18-2017, 07:19 PM   #87
talharama
New Member
2
Rep
20
Posts

Drives: F31 Step Auto Sports
Join Date: Sep 2017
Location: Manchester

iTrader: (0)

Quote:
Originally Posted by talharama View Post
No problem, You don't have to change any settings on above mentioned ECUs, just add 248 in FA and then code the above three ECUs.

See the attached image as reference.

I assume you know how to change cars FA? If not then Google it there is plenty instructions.
Don't know why but image didn't got linked, open the below link

https://ibb.co/cvAKOR

Last edited by talharama; 11-19-2017 at 04:28 AM.
Appreciate 0
      11-19-2017, 05:22 AM   #88
Tibass
New Member
0
Rep
8
Posts

Drives: Bmw 318d
Join Date: May 2013
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by talharama View Post
Don't know why but image didn't got linked, open the below link

https://ibb.co/cvAKOR
It all functions!
I didn't save the VO at the right way.
Thanks for all the help Talharama.
Appreciate 0
Post Reply

Bookmarks

Tags
f30, heated, heating, steering, wheel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:23 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST