F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > Oil issue solved * Oil level saying low level after oil change
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      01-31-2020, 11:23 AM   #1
TheNewGuyxi
Registered
0
Rep
3
Posts

Drives: 2013 Bmw 335 xi
Join Date: Jan 2020
Location: Torrington CT

iTrader: (0)

Oil issue solved * Oil level saying low level after oil change

Hey guys i've been looking for a thread that touches on this issue but could not find one for the life of me. i'm a long time viewer of these forums but i just recently decided to register as my warranty expired on my F30. okay so enough about why. So the issue
* Oil level saying low level after oil change*. Owner manual recommends 5W-30 i put in 5w-40 thinking is shouldnt make a difference.
car warms up and says only 1 quart please add more.( i just put in 6 in a half quarts. Do i have an oil leak ? so i check around and nothing. it would say add another qt after car reached operating temp. So i did some research and found that ow-40 Castro is what bmw recommends. I thought the oil sensor was messed up and not reading accurately. So before i made the choice to buy another sensor i figured lets replace the oil. Now this time i did not just
change the oil. I disconnected the negative terminal on the battery in rear
because the oil sensor is an electronic ? my guess is it needs to be reset this way?? I changed the oil connected it back. Drove the car 20 miles waited for operating temp to be reached and measured the oil in our idrive system and problem has been resolved.

If any is having this problem or has please chime in. I was ready to purchase another sensor. and that would have been money i did not need to spend and im a firm believer in not spending money where it does not need to be spent.
unless its on purchasing an F30
Appreciate 0
      01-31-2020, 12:34 PM   #2
im_an_alien
Private
45
Rep
73
Posts

Drives: 2016 340i
Join Date: Jul 2019
Location: Tha south

iTrader: (0)

Ah electronic dip sticks... The way I see it, if you put in oil, and there is no evidence of a leak, then you have oil.
Appreciate 0
      01-31-2020, 04:02 PM   #3
StannisBaratheon
New Member
5
Rep
29
Posts

Drives: 2016 340i Xdrive
Join Date: Aug 2019
Location: Earth

iTrader: (0)

Quote:
Originally Posted by im_an_alien View Post
Ah electronic dip sticks... The way I see it, if you put in oil, and there is no evidence of a leak, then you have oil.
Not always true, it could be burning the oil.

The first gen 2.0t engines used by VW/Audi had oval shaped pistons and low friction rings (for better fuel economy) which lead to huge oil consumption. My passat was going through a quart every 800 miles. If the consumption was more than a quart ever 1k miles they would replace the rings and pcv system, and eventually extended the warranty for oil consumption to 12 years/120,000 miles.
Appreciate 0
      01-31-2020, 04:28 PM   #4
im_an_alien
Private
45
Rep
73
Posts

Drives: 2016 340i
Join Date: Jul 2019
Location: Tha south

iTrader: (0)

Quote:
Originally Posted by StannisBaratheon View Post
Not always true, it could be burning the oil.
Obviously... But if the car is burning oil at that rate you'll know it... Glad it's sorted OP
Appreciate 0
      02-02-2020, 08:25 PM   #5
TheNewGuyxi
Registered
0
Rep
3
Posts

Drives: 2013 Bmw 335 xi
Join Date: Jan 2020
Location: Torrington CT

iTrader: (0)

Quote:
Originally Posted by im_an_alien View Post
Obviously... But if the car is burning oil at that rate you'll know it... Glad it's sorted OP
oh no most definitely not burning oil at that rate id see some smoke lol.
Appreciate 0
      02-06-2020, 05:49 PM   #6
IraHayes
First Lieutenant
United_States
117
Rep
302
Posts

Drives: 328i
Join Date: Apr 2018
Location: CA

iTrader: (0)

Quote:
Originally Posted by TheNewGuyxi View Post
Hey guys i've been looking for a thread that touches on this issue but could not find one for the life of me. i'm a long time viewer of these forums but i just recently decided to register as my warranty expired on my F30. okay so enough about why. So the issue
* Oil level saying low level after oil change*. Owner manual recommends 5W-30 i put in 5w-40 thinking is shouldnt make a difference.
car warms up and says only 1 quart please add more.( i just put in 6 in a half quarts. Do i have an oil leak ? so i check around and nothing. it would say add another qt after car reached operating temp. So i did some research and found that ow-40 Castro is what bmw recommends. I thought the oil sensor was messed up and not reading accurately. So before i made the choice to buy another sensor i figured lets replace the oil. Now this time i did not just
change the oil. I disconnected the negative terminal on the battery in rear
because the oil sensor is an electronic ? my guess is it needs to be reset this way?? I changed the oil connected it back. Drove the car 20 miles waited for operating temp to be reached and measured the oil in our idrive system and problem has been resolved.

If any is having this problem or has please chime in. I was ready to purchase another sensor. and that would have been money i did not need to spend and im a firm believer in not spending money where it does not need to be spent.
unless its on purchasing an F30
How much oil are you putting in when you do oil change. Non-Xdrive cars take exactly 5 qt, 10 oz. I think X-drive is 5 qt, 3 oz, but don't know if X drive is for sure 5 qt, 10 oz. I got the info from my Bentley manual, and every time I run the oil check after a change, it is spot on.

Last edited by IraHayes; 02-07-2020 at 09:28 AM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:38 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST