F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > How to keep using expired E-Sys Launcher Premium by reverting system date (hack)
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      04-08-2019, 03:59 PM   #595
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by tobyps View Post
Hello, I am located in France and I write to you via a translator
I can not get esys and rearm
I think I do not use the right versions with the right dates
thank you for your support
I recommend using Launcher 2.8.2 and E-sys 3.27.1. There's a very useful guide by Almaretto here, including download links:
https://www.bimmerfest.com/forums/sh...php?p=10193333

You can find the valid dates to use in the readme.txt that's included with my Rearm script.

Cheers, Tony
Appreciate 0
      04-08-2019, 04:02 PM   #596
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by cjn View Post
Looks good, Tony. I ran it in place of 2.0.0 and, while I wasn't actually trying to break anything, it ran perfectly OK. Great work!

Thanks! I hope this helps a lot of people to get their Launcher started again.

Cheers, Tony
Appreciate 0
      04-09-2019, 11:42 AM   #597
tobyps
Registered
France
0
Rep
2
Posts

Drives: bmw x3 f25 xline 2015
Join Date: Apr 2019
Location: FRANCE

iTrader: (0)

Thank you for your support
Appreciate 0
      04-09-2019, 04:42 PM   #598
matteis
Enlisted Member
2
Rep
32
Posts

Drives: bmw 118i f20 sport gp
Join Date: Oct 2015
Location: brazil

iTrader: (0)

Quote:
Originally Posted by digirat View Post
did all of that. launcher won't start. i'm based in canada and have even set my location to london and on US keyboard and got rid of the canada keyboard. no dice. date still says 8/1/2018 when trying it. Even tried 8/5/2018 for the date and still won't give me anything. no errors, no nothing. it just doesn't launch
I tried to install launcher 2.8.2 in a Win8 and I am facing the same issue related above. Launcher simply doesn't start / launch.

I followed every tip previously posted here. Any idea what could I do to make it work?
Appreciate 0
      04-10-2019, 06:10 AM   #599
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by matteis View Post
I tried to install launcher 2.8.2 in a Win8 and I am facing the same issue related above. Launcher simply doesn't start / launch.

I followed every tip previously posted here. Any idea what could I do to make it work?

See FAQ #5 in the readme.txt. Do you have any entries in Windows Event Viewer?

Cheers, Tony
Appreciate 0
      04-11-2019, 12:47 AM   #600
najdawiranao
Registered
0
Rep
3
Posts

Drives: bmw
Join Date: Sep 2018
Location: Iowa

iTrader: (0)

can do it for working with windows 7 64 ? please it's only work woth 32
Appreciate 0
      04-12-2019, 05:36 AM   #601
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by najdawiranao View Post
can do it for working with windows 7 64 ? please it's only work woth 32
It should work for both 64- and 32-bit. Can you elaborate on the problem? Do you get any errors on 64-bit?

Cheers, Tony
Appreciate 0
      04-14-2019, 01:40 AM   #602
kkh27
Registered
kkh27's Avatar
Singapore
0
Rep
4
Posts

Drives: BMW X3 F25 xDrive 35i 2012
Join Date: Apr 2019
Location: Singapore

iTrader: (0)

Hi Tony. I have problem getting the program started. after running the rearm I execute the launcher but it just not coming out at all. Please help. thanks.
Appreciate 0
      04-14-2019, 06:38 AM   #603
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by kkh27 View Post
Hi Tony. I have problem getting the program started. after running the rearm I execute the launcher but it just not coming out at all. Please help. thanks.

See FAQ #5 in the readme.txt. Do you have any entries in Windows Event Viewer?

Cheers, Tony
Appreciate 0
      04-14-2019, 08:52 AM   #604
KingpinRCR
Private First Class
Belgium
51
Rep
148
Posts

Drives: F30 320d ed
Join Date: Mar 2017
Location: Belgium

iTrader: (0)

Hello everyone, i could really need some help...
I run esys on an old laptop with windows vista.
I wasn’t planning on changing anything on mu car anymore but with the summer comming my fingers became itchy to add a few things...
Only problem, esys doesn’t work anymore...
I don’t know wich version of esys i have but i downloaded and installed it at the end of march 2017.
I have esys launcer premium 2.7.1, but when i use the script i either get a date manipulated error or a pin loop.
So i downloaded launcher 2.8.2 and upgraded my laptop to .net framework 4.6.1 in order to be able to install the new launcher. The new launcher throws a “esys launcher isn’t working anymore” error...
So... what are my options? Is it possible to get it to work on vista or should i buy a new laptop? (Which would be a little overkill since i won’t use it for anything else, just a few codings once every year or 2 ) should i upgrade to launcher pro? (But apparently TM is extremely hard to reach...)
Or would esysX be a solution?

Any advice would be welcome...

Thanks,
KingpinRCR
Appreciate 0
      04-14-2019, 04:27 PM   #605
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by KingpinRCR View Post
I have esys launcer premium 2.7.1, but when i use the script i either get a date manipulated error or a pin loop.
So i downloaded launcher 2.8.2 and upgraded my laptop to .net framework 4.6.1 in order to be able to install the new launcher. The new launcher throws a “esys launcher isn’t working anymore” error...
My script should work on Vista. Did you use the latest version (2.0.4) and did it run without any errors (green screen at the end)? Did you use the correct date for your Launcher version(s) (valid ranges are in the readme.txt)? Are you absolutely, 100 percent, without a doubt, no question, really really sure that your system clock did not reset itself to 'now' during your session?

Cheers, Tony
Appreciate 1
      04-15-2019, 05:43 AM   #606
KingpinRCR
Private First Class
Belgium
51
Rep
148
Posts

Drives: F30 320d ed
Join Date: Mar 2017
Location: Belgium

iTrader: (0)

Hello Tony,

Thank you for your quick reply. Apparently i wasn't using the latest version of the script I've downloaded it this morning, re-installed launcher 2.7.1. and the latest script and it works (haven't tested it in the car yet, but esys loads and runs)
i don't know much about computers, but i've learned a lesson: always use the latest version

There's one more thing (not really important). I have multiple users on my laptop: administrator, my profile (wich also says administrator but hasn't full authority apparently because it can't run the script) and one for my wife.
when I use the administrator profile it works, but when i switch to my profile and try the launcher I get the 'date manipulation' warning. When I switch back to the administrator it works normally again...
Like i've said, not important, i'll just use the administrator profile from now on.

Thank you for your help and the script
Appreciate 0
      04-15-2019, 05:59 AM   #607
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by KingpinRCR View Post
Hello Tony,

Thank you for your quick reply. Apparently i wasn't using the latest version of the script I've downloaded it this morning, re-installed launcher 2.7.1. and the latest script and it works (haven't tested it in the car yet, but esys loads and runs)
i don't know much about computers, but i've learned a lesson: always use the latest version

There's one more thing (not really important). I have multiple users on my laptop: administrator, my profile (wich also says administrator but hasn't full authority apparently because it can't run the script) and one for my wife.
when I use the administrator profile it works, but when i switch to my profile and try the launcher I get the 'date manipulation' warning. When I switch back to the administrator it works normally again...
Like i've said, not important, i'll just use the administrator profile from now on.

Thank you for your help and the script
Glad it worked out for you. About the administrator thing: it's normal that the Launcher won't work when you run it on a different account than the one where you used my script. Some of the changes made by my script are account-specific, as are the checks by the Launcher (like the Temp-folder for example).

When you say that you can't run the script under your administrator profile, did you right-click it and choose "run as admin" in the context menu? The right-click should give you more permissions than simply being a member of the Administrators security-group.

Cheers, Tony
Appreciate 0
      04-15-2019, 06:51 AM   #608
KingpinRCR
Private First Class
Belgium
51
Rep
148
Posts

Drives: F30 320d ed
Join Date: Mar 2017
Location: Belgium

iTrader: (0)

Hi Tony,

no, i didn't use right-click, like i've said, i'm not very great with computers...
i'll try that when i get home from work just to check it out, but i'll probably just keep using the 'main' administrator profile from now on.

thank you for your advice, kind regards,

KingpinRCR
Appreciate 0
      04-16-2019, 07:50 PM   #609
NV GUNS
First Lieutenant
NV GUNS's Avatar
United_States
38
Rep
336
Posts

Drives: 19' M2C
Join Date: Jun 2016
Location: chicago

iTrader: (1)

Garage List
2019 M2 Competition  [0.00]
2002 330ci  [0.00]
c:\programdata date can't be changed

can't get your script to work, I changed the date and time (in accordance to the version 2.8.2) and ran your script as admin it started then finished with an error saying that it can't change the time and date for c:\programdata . token master's launcher does not even start now. any help would be much appreciated.
Appreciate 0
      04-17-2019, 02:04 PM   #610
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by NV GUNS View Post
can't get your script to work, I changed the date and time (in accordance to the version 2.8.2) and ran your script as admin it started then finished with an error saying that it can't change the time and date for c:\programdata . token master's launcher does not even start now. any help would be much appreciated.
I've just replied to your PM about this. You'll have to find out what's locking your C:\ProgramData folder in order to change its date.

Cheers, Tony
Appreciate 0
      04-21-2019, 02:45 AM   #611
Clems
New Member
France
0
Rep
6
Posts

Drives: 120d e81
Join Date: Aug 2012
Location: France

iTrader: (0)

Hi !

Still struggled in admin privillege, but for sure Im admin on my computer.

Could you please explain me how to supress this verification of the script ?

thank you !
Appreciate 0
      04-21-2019, 05:30 AM   #612
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by Clems View Post
Hi !

Still struggled in admin privillege, but for sure Im admin on my computer.

Could you please explain me how to supress this verification of the script ?

thank you !

There's a difference between membership of the Administrators group and running a program with Administrator privileges. We're talking about the latter here.

Did you get the error:
"This file must be run with elevated privileges by using Right-click -> 'Run as administrator'. Please try again."?

I thought this would be pretty self-explanatory, but basically you'll have to right-click with your mouse on the .bat-file and choose "Run as administrator" from the menu.

Cheers, Tony
Appreciate 0
      04-21-2019, 01:21 PM   #613
UnfoundLegend
Second Lieutenant
UnfoundLegend's Avatar
United_States
37
Rep
216
Posts

Drives: '14 F13 M6 Coupe
Join Date: Apr 2012
Location: FL, USA

iTrader: (1)

I am having the same issues as users above where the program simply doesn't launch.

I am receiving a .NET Runtime error in the Windows Event Log history.

States that "Virtual Machine is not supported". I've been using Parallels, running Windows 10 Pro for 3 years without an error related to using a virtual machine.

Is it the launcher that is causing this?

E-SYS launcher version 2.8.2
E-SYS version 3.27.1 (downgraded from 3.28)
Attached Images
 
Appreciate 0
      04-21-2019, 03:51 PM   #614
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by UnfoundLegend View Post
I am receiving a .NET Runtime error in the Windows Event Log history. States that "Virtual Machine is not supported". I've been using Parallels, running Windows 10 Pro for 3 years without an error related to using a virtual machine. Is it the launcher that is causing this?
There are several issues causing the Launcher to seemingly not do anything after starting it. In all cases the answer is in the Event viewer. In reality, the Launcher does start for a short period, but it detects some condition and then quits again. The condition encountered most of the time is that the Launcher is still detecting a date manipulation. Another condition, which is the case above, is that it detects running on a virtual machine. Tokenmaster does not allow that and build in checks for it.

I believe 2.8.0 still runs on Parallels. Other solutions are to use real hardware, or use VMware (there was some info posted about that a few weeks earlier, so read back on this thread to find out how).

Cheers, Tony
Appreciate 0
      04-21-2019, 04:40 PM   #615
krossfyah
New Member
0
Rep
5
Posts

Drives: BMW X1 Asteria Blue
Join Date: Sep 2017
Location: Canada

iTrader: (0)

I am running into a problem when launching Eyes launcher premium, I enter my pin (est file is created no problems) and it appears that ESYS launcher cannot find the location for E-SYS although ESYS is installed on my system.
IT keeps prompting me over and over for my pin.

any ideas on this?
Appreciate 0
      04-21-2019, 04:49 PM   #616
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by krossfyah View Post
I am running into a problem when launching Eyes launcher premium, I enter my pin (est file is created no problems) and it appears that ESYS launcher cannot find the location for E-SYS although ESYS is installed on my system.
IT keeps prompting me over and over for my pin.

any ideas on this?
Mostly this is the case when the Launcher still detects your date manipulation for some reason. Did my script run without errors? It could mean that there is still some unknown check being performed. Try disconnecting from the internet (don't forget wifi) before running my script and the Launcher and see if that helps at all.

Cheers, Tony
Appreciate 0
Post Reply

Bookmarks

Tags
clock, date, esys, launcher, premium

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:23 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST