F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > BimmerCode Rear LED Turn Signal Bulbs Coding for F33
ARMA SPEED
Post Reply
 
Thread Tools Search this Thread
      10-16-2021, 06:39 AM   #1
battlecat
New Member
0
Rep
8
Posts

Drives: BMW 428i F33
Join Date: Oct 2021
Location: Dubai

iTrader: (0)

Exclamation BimmerCode Rear LED Turn Signal Bulbs Coding for F33

Hi all,

This is my first post here and hope its not my last. I seem to be getting confused here coding my 2014 F33 convertible.

Ill start by saying I have the standard lighting units on the rear (All filament bulbs). I recently got some high end amber LED turn signal bulbs and now need to code these. Not sure if some things changed on the latest 2021 BimmerCode app but I'll share my screenshots below.

First I changed the bulbs in the rear turn signals to the LED bulbs. These work great (No hyper blink) with the ignition turned off; with either turn signals or the hazards being used.
As soon as I turn the ignition on, I believe the car begins its cold/ warm checks and starts to detect errors seen below.



After this point if I use the turn signals or indicators the bulbs hyper blink and after 2 or 3 blinks turn off altogether (Rear turn signals).

I wanted to code these out using the latest 2021 BimmerCode app. Earlier forum posts talk about going to the Rear Electronics Module and changing a bunch of things (I've posted this right at the bottom), however in the version I am using (As of 12 October 2021) - I just see the flow below:

1. Main ECU Loading Page. After this I select Rear Electronic Module:



2. Next under LED Conversion I see the below options. Should I be choosing this? 'LED conversion rear turn signals' ? All I am doing is changing the filament turn signal bulbs to LED bulbs. I am not changing the full unit to a LCI unit.



3. If point 2 is correct I will finally just Activate the option below? Let me know please.



Are the above procedures all I need to do?

Some other forums had the below steps listed - but I could not find it in the latest BimmerCode app (Unless its a expert mode thing - which I may not have to use?).
Any advice would be greatly appreciated:

Rear indicator signal coding:

3061 FRA_H_L_KALTUEBERWACHUNG -> nicht_aktiv : Disabling cold bulb checks for Rear Left Turn Signal.
3061 FRA_H_L_WARMUEBERWACHUNG -> nicht_aktiv : Disabling warm bulb checks for Rear Left Turn Signal.
3061 FRA_H_L_IS_LED -> aktiv : Setting Rear Left Turn Signal type to LED.

3061 FRA_H_R_KALTUEBERWACHUNG -> nicht_aktiv : Disabling cold bulb checks for Rear Right Turn Signal.
3061 FRA_H_R_WARMUEBERWACHUNG -> nicht_aktiv : Disabling warm bulb checks for Rear Right Turn Signal.
3061 FRA_H_R_IS_LED -> aktiv : Setting Rear Right Turn Signal type to LED.
Appreciate 0
      10-16-2021, 02:13 PM   #2
battlecat
New Member
0
Rep
8
Posts

Drives: BMW 428i F33
Join Date: Oct 2021
Location: Dubai

iTrader: (0)

Anyone? Shameless BUMP. still looking for answers. 🙏
Appreciate 0
      10-16-2021, 03:59 PM   #3
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5761
Rep
12,173
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

You activate LED conversion for the bulbs you changed to LED. LED refers to the bulb, not the lamp.
Appreciate 0
      10-17-2021, 02:10 AM   #4
battlecat
New Member
0
Rep
8
Posts

Drives: BMW 428i F33
Join Date: Oct 2021
Location: Dubai

iTrader: (0)

Exclamation

Hi there - so after changing the rear turn signal bulbs to LED's I did code the BMW to LED rear turn signals conversion in BimmerCode.

Here's whats happened. There are no more errors on the startup of the car.

HOWEVER - When I actually use the indicator it starts fine (1 blink) and then hyper flashes, errors come back on - and the rear indicators do not flash anymore - the ones I programmed!

WHat exactly is a warm and cold check? I have no idea! Maybe I've coded the wrong thing?

Is there additional programming required?
Also if it helps, the hazards and indicators work fine with the ignition off. If the car ignition is turned on, that's when the errors and hyper blink take place.

The below is the status of the REM after coding:

FRA_H_L_KALTUEBERWACHUNG -> nicht_aktiv : Disabling cold bulb checks for Rear Left Turn Signal.
FRA_H_L_WARMUEBERWACHUNG -> nicht_aktiv : Disabling warm bulb checks for Rear Left Turn Signal.
FRA_H_L_IS_LED -> aktiv : Setting Rear Left Turn Signal type to LED.

FRA_H_R_KALTUEBERWACHUNG -> nicht_aktiv : Disabling cold bulb checks for Rear Right Turn Signal.
FRA_H_R_WARMUEBERWACHUNG -> nicht_aktiv : Disabling warm bulb checks for Rear Right Turn Signal.
FRA_H_R_IS_LED -> aktiv : Setting Rear Right Turn Signal type to LED.

Any help please?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:02 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST