F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > 2015 BMW F30 335i N55 MISFIRE BUT NO CODES!
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      03-26-2020, 03:11 AM   #1
Moe_F30
New Member
2
Rep
5
Posts

Drives: 2013 BMW F30 328i
Join Date: Jul 2018
Location: Indianapolis

iTrader: (0)

Exclamation 2015 BMW F30 335i N55 MISFIRE BUT NO CODES!

Hey guys, so I just got a 25k miles engine put into my 67k miles 335i 2015, and after I took it out the shop, 200 miles later I start getting a misfire and the car drives rough! The only code for the check engine light I get is that I need a new o2 sensor because it's bad, I ordered another 1. All we used from the 25k miles engine was the block, and everything else was used from the old engine that locked on me. we used same coils and plugs from my old engine, but I had just gotten new plugs for my old engine a month before it stopped on me.

Current Mods:
Catless Downpipe
Stage 1 93 Bootmod3
VRSF Chargepipe
Appreciate 0
      03-26-2020, 03:19 AM   #2
davidr3
Private
21
Rep
66
Posts

Drives: 335i
Join Date: May 2019
Location: Riverside

iTrader: (1)

I'm thinking spark plugs, but i'm not as knowledgeable as others on this forum so take what I say as a grain of salt.
Appreciate 0
      03-26-2020, 04:00 AM   #3
jcordier
First Lieutenant
jcordier's Avatar
United_States
81
Rep
302
Posts

Drives: 2013 black F30 N55
Join Date: Sep 2016
Location: cypress

iTrader: (1)

Quote:
Originally Posted by Moe_F30 View Post
Hey guys, so I just got a 25k miles engine put into my 67k miles 335i 2015, and after I took it out the shop, 200 miles later I start getting a misfire and the car drives rough! The only code for the check engine light I get is that I need a new o2 sensor because it's bad, I ordered another 1. All we used from the 25k miles engine was the block, and everything else was used from the old engine that locked on me. we used same coils and plugs from my old engine, but I had just gotten new plugs for my old engine a month before it stopped on me.

Current Mods:
Catless Downpipe
Stage 1 93 Bootmod3
VRSF Chargepipe
May I ask, "what was wrong with the original engine?".
__________________
J. D. Cordier
Appreciate 0
      03-26-2020, 06:38 AM   #4
dmaxdmax
Private First Class
dmaxdmax's Avatar
United_States
59
Rep
157
Posts

Drives: 2016 340i xD 6-spd
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

The 02 code could be for a variety of things upstream... things like clogged air filter or filter; failing fuel pump?

As asked, what was wrong before. Had you overheated and just replaced your warped block? You sure cylinder head wasn't cracked?

There are so many things, and it could be as simple as something left unplugged.

If it was me, I'd drink something, vape, and stare at the engine with a good led flashlight and hope I find a loose connector. Some hide very well.
__________________
'92 325i RIP, '99 328i RIP, '16 340i
Appreciate 0
Post Reply

Bookmarks

Tags
bmw, f30, misfire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:22 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST