F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > Drivetrain Malfunction Help
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      12-10-2018, 06:25 PM   #1
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
On the car ride home from work I decide to make a couple throttle rips. Music off, windows closed. Here are the details. Any help would be appreciated.

At this point, codes are cleared and everything seems fine.

Where would you look first?

1st rip: Dead stop, comfort mode, let roll a bit then WOT... nothing vicious at all. Car ran like a top and shifted well through all gears.

2nd rip: Rolling momentum, rocker button into Sport (thats it) again nothing viscous and car ran fine... until the 3rd or 4th shift when I got my FIRST EVER drivetrain malfunction...

No noises or issues whatsoever... immediately let off throttle and crawled to a safe spot to check codes.

This is what I see...

The one is obviously from my Catless Downpipe and is always there... its the other three that Im concerned with.

64k miles. N26, FBO, never been tuned.
Attached Images
 
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 06:43 PM   #2
rjdnyy224
Brigadier General
rjdnyy224's Avatar
United_States
1568
Rep
3,232
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by sspade View Post
On the car ride home from work I decide to make a couple throttle rips. Music off, windows closed. Here are the details. Any help would be appreciated.

At this point, codes are cleared and everything seems fine.

Where would you look first?

1st rip: Dead stop, comfort mode, let roll a bit then WOT... nothing vicious at all. Car ran like a top and shifted well through all gears.

2nd rip: Rolling momentum, rocker button into Sport (thats it) again nothing viscous and car ran fine... until the 3rd or 4th shift when I got my FIRST EVER drivetrain malfunction...

No noises or issues whatsoever... immediately let off throttle and crawled to a safe spot to check codes.

This is what I see...

The one is obviously from my Catless Downpipe and is always there... its the other three that Im concerned with.

64k miles. N26, FBO, never been tuned.
Hmmmm. You just did a MAF clean right. Seems like awfully suspect timing...

If I were in your shoes, that's where I would first look. Maybe it didn't dry all the way, or the MAF is shot. That wouldn't be my first guess if I didn't know you just cleaned the MAF, but that's where I would look first given the circumstances.
__________________
Instagram: rjd_f30 | 2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct | Bootmod3 8AT TCU flash | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | 2.5" custom exhaust cutout | M Performance Exhaust | NGK L/I Spark Plugs | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      12-10-2018, 06:46 PM   #3
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by rjdnyy224 View Post
Quote:
Originally Posted by sspade View Post
On the car ride home from work I decide to make a couple throttle rips. Music off, windows closed. Here are the details. Any help would be appreciated.

At this point, codes are cleared and everything seems fine.

Where would you look first?

1st rip: Dead stop, comfort mode, let roll a bit then WOT... nothing vicious at all. Car ran like a top and shifted well through all gears.

2nd rip: Rolling momentum, rocker button into Sport (thats it) again nothing viscous and car ran fine... until the 3rd or 4th shift when I got my FIRST EVER drivetrain malfunction...

No noises or issues whatsoever... immediately let off throttle and crawled to a safe spot to check codes.

This is what I see...

The one is obviously from my Catless Downpipe and is always there... its the other three that Im concerned with.

64k miles. N26, FBO, never been tuned.
Hmmmm. You just did a MAF clean right. Seems like awfully suspect timing...

If I were in your shoes, that's where I would first look. Maybe it didn't dry all the way, or the MAF is shot. That wouldn't be my first guess if I didn't know you just cleaned the MAF, but that's where I would look first given the circumstances.
Yes, this is true. And that specific code has appeared before intermittently but never caused a drivetrain malfunction.

The thing is perfectly clean and was dry when I reinstalled. Plus I didn't start the car until the next day.

I agree with what your saying but its definitely been thoroughly cleaned... plugged in a few minutes later and left overnight before starting car.

This was also a few days ago. Dont think these were my first two WOT runs but maybe they were?

Idk...
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 06:48 PM   #4
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by rjdnyy224 View Post
Quote:
Originally Posted by sspade View Post
On the car ride home from work I decide to make a couple throttle rips. Music off, windows closed. Here are the details. Any help would be appreciated.

At this point, codes are cleared and everything seems fine.

Where would you look first?

1st rip: Dead stop, comfort mode, let roll a bit then WOT... nothing vicious at all. Car ran like a top and shifted well through all gears.

2nd rip: Rolling momentum, rocker button into Sport (thats it) again nothing viscous and car ran fine... until the 3rd or 4th shift when I got my FIRST EVER drivetrain malfunction...

No noises or issues whatsoever... immediately let off throttle and crawled to a safe spot to check codes.

This is what I see...

The one is obviously from my Catless Downpipe and is always there... its the other three that Im concerned with.

64k miles. N26, FBO, never been tuned.
Hmmmm. You just did a MAF clean right. Seems like awfully suspect timing...

If I were in your shoes, that's where I would first look. Maybe it didn't dry all the way, or the MAF is shot. That wouldn't be my first guess if I didn't know you just cleaned the MAF, but that's where I would look first given the circumstances.
So you think the other codes are related not due to a leak of sorts?

I know its a crapshoot just making sure I understand.

Would you pop for a new MAF at 64k miles or check other things first?
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 07:31 PM   #5
lonecitizenfour
Second Lieutenant
88
Rep
249
Posts

Drives: 2014 428i XDrive
Join Date: Feb 2018
Location: North East

iTrader: (0)

Garage List
Quote:
Originally Posted by sspade View Post
So you think the other codes are related not due to a leak of sorts?

I know its a crapshoot just making sure I understand.

Would you pop for a new MAF at 64k miles or check other things first?
Isn't a MAF $100? can you use it and return it if it doesn't fix your issue? XD AMAZON PRIME IT!
Appreciate 1
sspade1693.50

      12-10-2018, 08:05 PM   #6
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by lonecitizenfour View Post
Isn't a MAF $100? can you use it and return it if it doesn't fix your issue? XD AMAZON PRIME IT!
Doubtful I can return it once used... a week or so. But I get your point.

Cheapest on eBay for OEM brand new is $214


PN 13-62-7-602-038
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 08:10 PM   #7
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by lonecitizenfour View Post
Isn't a MAF $100? can you use it and return it if it doesn't fix your issue? XD AMAZON PRIME IT!
Cheapest on amazon is $410.

Much more that "a hundred."
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 08:11 PM   #8
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Thoughts on aftermarket MAF sensor for your personal, owned vehicle?
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 08:19 PM   #9
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Damn... Im inpatient!

Just bought this one... didnt come up when I clicked BMW as brand before but still states OEM... hmm?

***I know that it is Bosch manufactured but normally - I have best luck when searching for OEM to choose the OEM as brand.

We'll see. I can say that it is from the exact same company that I bought my front strut mounts from (which have worked well)... so Im not too worried.

Hopefully this is a simple plug and play solution!

https://www.ebay.com/itm/283103533436
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-10-2018, 08:40 PM   #10
rjdnyy224
Brigadier General
rjdnyy224's Avatar
United_States
1568
Rep
3,232
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

FCP Euro carries an OEM Bosch MAF for $143. I know you already bought one lol, but you can never go wrong with FCP Euro.

Either way, a bad MAF can throw off a lot of things, so I wouldn't be surprised if the other codes were caused by that, but like I said, it wouldn't be my first guess if you hadn't just cleaned it, but I also wouldn't be surprised if it was the fix.

Let's assume you hadn't just done the MAF, I would guess, given the descriptions of the codes, that you blew a CP off but I know you have Treadstones so that's unlikely, but it can't hurt to check 'em if you haven't already.
__________________
Instagram: rjd_f30 | 2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct | Bootmod3 8AT TCU flash | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | 2.5" custom exhaust cutout | M Performance Exhaust | NGK L/I Spark Plugs | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 1
sspade1693.50

      12-10-2018, 09:53 PM   #11
lonecitizenfour
Second Lieutenant
88
Rep
249
Posts

Drives: 2014 428i XDrive
Join Date: Feb 2018
Location: North East

iTrader: (0)

Garage List
Inlet pipe?
Appreciate 0
      12-14-2018, 12:06 PM   #12
IraHayes
First Lieutenant
United_States
120
Rep
312
Posts

Drives: 328i
Join Date: Apr 2018
Location: CA

iTrader: (0)

Any luck resolving this Spade?
Appreciate 0
      12-14-2018, 12:52 PM   #13
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by IraHayes View Post
Any luck resolving this Spade?
MAF meter arrives today!

Literally have been praying this fixes my issue because I dont want to show up to the dealer... ass first...

Ive been able to repeat the issue a couple times. Seems that in Sport mode, if I rip it hard enough for RPM's to
hit 5k or better and boom... drivetrain malfunction. No sounds or feelings or anything negative... just the onboard message and then I let off and go home and cry... next time I start it, its gone whether I clear codes or not.

Last time I had it happen (yesterday)... the following codes were thrown (no MAF code?!)

I never ended up cleaning or touching it again since the only time I cleaned it (a few days back).
Attached Images
 
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-14-2018, 01:24 PM   #14
lonecitizenfour
Second Lieutenant
88
Rep
249
Posts

Drives: 2014 428i XDrive
Join Date: Feb 2018
Location: North East

iTrader: (0)

Garage List
and you're sure it's not a leak anywhere?
Appreciate 0
      12-14-2018, 02:13 PM   #15
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by lonecitizenfour View Post
and you're sure it's not a leak anywhere?
I do not believe there is a exhaust leak because I feel like I would hear it and smell it in the engine bay...

Its definitely possible to have something loose in the air intake / induction system but then again I havent touched that in months...

When I install MAF meter tonight, Ill dissemble the air box and have a good look at everything hidden by it.

Of course adjust anything that looks funky and reassemble nice and snug along with a fresh MAF.

Clear codes and see what happens over the next week.

Ill take some pics for the hell of it.
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-14-2018, 02:14 PM   #16
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Hoping it's not something deeper than this (ie. Turbo or Engine related).
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-14-2018, 03:38 PM   #17
rjdnyy224
Brigadier General
rjdnyy224's Avatar
United_States
1568
Rep
3,232
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

I know a bad MAF can really f*ck things up, so I honestly wouldn't be surprised if it fixed it. Let's hope it does. If not you'll have to dig a bit deeper, but hopefully not too deep.
__________________
Instagram: rjd_f30 | 2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct | Bootmod3 8AT TCU flash | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | 2.5" custom exhaust cutout | M Performance Exhaust | NGK L/I Spark Plugs | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      12-14-2018, 06:40 PM   #18
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
First evidence of the problem!
Attached Images
 
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-14-2018, 07:04 PM   #19
JoeyMcMahon101
Banned
45
Rep
202
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Nov 2018
Location: Iselin NJ

iTrader: (0)

What are we looking at here???
Appreciate 0
      12-14-2018, 07:20 PM   #20
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Turbo to Intercooler (TIC) pipe was causing a boost leak due to the worm screw loosening on one of the clamps...

Makes me wonder how tight it ever was.

At this point Im cleaning the original MAF meter again and clearing codes to see what happens over the next week.

New MAF arrived but Im not sold I need it yet.

I suspect the boost related two codes will be gone... hoping the MAF code disappears too... leaving me with one known code (catless downpipe).

Worst case, MAF code reappears and I will swap sensors. Wont be surprised if it does but want to make sure now that I know I had a boost leak.

Question: is driving around with a boost leak (very casually) for a week or so an issue for damaging anything else?

I only made it do the engine malfunction two times. 96% of the time I baby my car around.
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-14-2018, 07:27 PM   #21
sspade
Brigadier General
sspade's Avatar
United_States
1694
Rep
4,209
Posts

Drives: F30
Join Date: Oct 2017
Location: Folsom, California

iTrader: (2)

Garage List
2014 BMW 328i  [5.00]
Quote:
Originally Posted by JoeyMcMahon101 View Post
What are we looking at here???
See the silver ring clamp around the pipe?

Should be up on the silicone coupler.
__________________
BMW 328i FBO, Bootmod3 Stage 1
Appreciate 0
      12-14-2018, 08:00 PM   #22
lonecitizenfour
Second Lieutenant
88
Rep
249
Posts

Drives: 2014 428i XDrive
Join Date: Feb 2018
Location: North East

iTrader: (0)

Garage List
Quote:
Originally Posted by sspade View Post
Turbo to Intercooler (TIC) pipe was causing a boost leak due to the worm screw loosening on one of the clamps...

Makes me wonder how tight it ever was.

At this point Im cleaning the original MAF meter again and clearing codes to see what happens over the next week.

New MAF arrived but Im not sold I need it yet.

I suspect the boost related two codes will be gone... hoping the MAF code disappears too... leaving me with one known code (catless downpipe).

Worst case, MAF code reappears and I will swap sensors. Wont be surprised if it does but want to make sure now that I know I had a boost leak.

Question: is driving around with a boost leak (very casually) for a week or so an issue for damaging anything else?

I only made it do the engine malfunction two times. 96% of the time I baby my car around.
Yes I believe this will cause the car to limp because the AFR canít be anticipated / controlled correctly.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:52 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST