F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Mechanical Maintenance and TSBs: Break-in / Oil & Fluids / Servicing / TSBs and Service Bulletin > Weak keyfob signal?
ARMA SPEED
Post Reply
 
Thread Tools Search this Thread
      02-12-2021, 03:42 PM   #1
f304dr
Enlisted Member
3
Rep
32
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Weak keyfob signal?

Hello!

First winter with this car, I'm having a really weak signal whenever trying to lock and unlock the car. It seems to really struggle in the winter which is strange as I had worse cars that never had this.

The car can't find the fob most times I get in and i have to push start multiple times to get going, I've also left the car running and locked while getting something and almost couldn't get back in. I've replaced the keyfob battery (2450 3v lithium coin battery off amazon so it might be old) to little result and also the main car battery with another bmw one.

Is there anything I can do to fix this? Insulation for the battery? Is it even a battery issue if it happens when the cars left on? It will usually only unlock when your right next to it when really cold and maybe a meter when not freezing.

Thanks!
Appreciate 0
      02-12-2021, 05:04 PM   #2
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5406
Rep
11,514
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

If the car battery isn't fully charged you can get these symptoms. Even a new battery can have problems in winter if you typically drive only short distances. The fob battery might be crap as well, especially if it's an off brand. What about your spare fob?
Appreciate 0
      02-17-2021, 02:41 PM   #3
f304dr
Enlisted Member
3
Rep
32
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
If the car battery isn't fully charged you can get these symptoms. Even a new battery can have problems in winter if you typically drive only short distances. The fob battery might be crap as well, especially if it's an off brand. What about your spare fob?
The spare was dead when I got it, its energizer brand but amazon may have just sent an old pair. I'll get a battery booster to top it up but it still seems to die fast even after long drives. Is it really supposed to do that? I would sit in all my cars in acc mode chilling for an hour or two and would be surprisingly fine, but can't last even 20 mins here.

I didn't have this issue when I first got the car but can't remember when it started but definitely got worse in the winter.
Appreciate 0
      02-17-2021, 03:10 PM   #4
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5406
Rep
11,514
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

By spare I meant your spare fob. If both have the same symptom it's the car, not the keys. You may have a battery drain issue. Those are always worse in winter, as battery efficiency drops in cold weather. My battery is always on a maintainer when the temperatures go below freezing.
Appreciate 1
      02-27-2021, 09:03 AM   #5
Haywood187
New Member
6
Rep
18
Posts

Drives: 2014 335i xDrive
Join Date: Sep 2017
Location: KS

iTrader: (0)

I had similar issues consistently, just replaced my battery and all gone. I never had any issues with the battery until it gave out after sitting for a while (pandemic, work from home, etc). Dealer didn't even have a solution when I took it in once for those issues. Battery change, poof all problems gone.
__________________
_________________________________________________
2014 335xi - CTS Turbo Intake and Charge Pipe - BM3 Stage 1 - VMR V801s
Appreciate 0
      02-27-2021, 10:12 PM   #6
f304dr
Enlisted Member
3
Rep
32
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
By spare I meant your spare fob. If both have the same symptom it's the car, not the keys. You may have a battery drain issue. Those are always worse in winter, as battery efficiency drops in cold weather. My battery is always on a maintainer when the temperatures go below freezing.
Yesterday it was warm and did alot of driving all day so the battery was for sure topped up yet I still had the same problems. Im going to replace the battery in the fob and if it still continues just talk to a car electrician or something because its not the car battery itself and not the weather.

Quote:
Originally Posted by Haywood187 View Post
I had similar issues consistently, just replaced my battery and all gone. I never had any issues with the battery until it gave out after sitting for a while (pandemic, work from home, etc). Dealer didn't even have a solution when I took it in once for those issues. Battery change, poof all problems gone.
I changed the battery already, not much changed.
Appreciate 0
      02-28-2021, 12:55 PM   #7
thejeremyman9
Brigadier General
thejeremyman9's Avatar
2194
Rep
4,272
Posts

Drives: 2015 BMW 335i
Join Date: May 2019
Location: Cali

iTrader: (0)

Quote:
Originally Posted by f304dr View Post
Yesterday it was warm and did alot of driving all day so the battery was for sure topped up yet I still had the same problems. Im going to replace the battery in the fob and if it still continues just talk to a car electrician or something because its not the car battery itself and not the weather.



I changed the battery already, not much changed.
Even a new battery will suffer in cold weather. I suggest putting a charger/maintainer on the battery and seeing if the issue persist once it is fully charged. The car wont even bring the battery to 100%, and it takes a lot of driving to even get it to ~75%.
Appreciate 0
      03-11-2021, 01:52 AM   #8
f304dr
Enlisted Member
3
Rep
32
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by thejeremyman9 View Post
Even a new battery will suffer in cold weather. I suggest putting a charger/maintainer on the battery and seeing if the issue persist once it is fully charged. The car wont even bring the battery to 100%, and it takes a lot of driving to even get it to ~75%.
I really don't think its the battery, it happens even when the car is on. The situation just doesn't make sense, why can I unlock fine but has a problem with anything else. I'm getting a bmw independent to take a look at it so we'll see or should I just take it straight to bmw?
Appreciate 0
      03-11-2021, 08:22 AM   #9
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5406
Rep
11,514
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

You still haven't said if this occurs with both fobs.
Appreciate 0
      04-08-2021, 11:07 PM   #10
f304dr
Enlisted Member
3
Rep
32
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
You still haven't said if this occurs with both fobs.
Sorry for the late reply, I still have to test that lol. I did try when I first got the car but with the old battery it already had and it was the same problem.

I took it back to the place that installed it and it seems to be a problem with the security system because even when the backup camera is fully unplugged it continues but if you point the fob at your chin to extend the range it works on and off.

I do also have the mmi carplay installed but it seems to shut off with the car fine so not sure.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:18 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST