F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > Turbo Whine/Whistle After Getting DP, CP and FMIC Installed
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      01-22-2019, 02:45 AM   #1
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Turbo Whine/Whistle After Getting DP, CP and FMIC Installed

Today I dropped off my car at a tuning shop to get a VRSF dp, cp and fmic installed so that I could go stage 2 BM3. After I picked it up, I noticed a fairly loud whine/whistle coming from the driver side. I texted one of the guys at the tuning shop and they told me that they had been hearing it too and that they checked for boost leaks around the DP and didn't find anything. I am doubting that it's downpipe related and am now looking at the chargepipe. I noticed that the chargepipe has some wiggle and play. I would just like to see what people on here think. Originally I wasn't thinking much of it, but I am almost certain it's a boost leak at this point. It just doesn't sound correct and I can't tell if the car is pulling as hard as it should be for BM3 Stage 2 AGG. I'll try and run a datalog tomorrow. What boost numbers should I be seeing for stage 2 agg for 93 octane? BTW, I have a 428i so it's the N20.

Thanks in advance!

Last edited by ethanm5000; 01-22-2019 at 03:05 AM.
Appreciate 0
      01-22-2019, 09:33 AM   #2
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

You should see 22 psi or thereabouts up to about 4500rpm at WOT, and it will taper off to 18-19psi in the upper rpms to redline. Run a datalog and post it up and we'll know pretty quickly if you have a leak. Could very well be the CP.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 1
      01-22-2019, 05:39 PM   #3
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Here's a quick datalog I did, I'll try to get a better one.
http://www.bootmod3.net/log?id=5c4792c0c090c61e5911d282
Appreciate 0
      01-22-2019, 05:56 PM   #4
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by ethanm5000 View Post
Here's a quick datalog I did, I'll try to get a better one.
http://www.bootmod3.net/log?id=5c4792c0c090c61e5911d282
That log looks perfectly fine in terms of boost, no leak. The last section was a little weird though, looks like the throttle closed up and timing fell off. I guess it's hard for you to tell seeing as you just installed these parts, but did the car feel like it was pulling strongly?

Is there any way you can capture the sound on video?
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      01-22-2019, 07:57 PM   #5
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
That log looks perfectly fine in terms of boost, no leak. The last section was a little weird though, looks like the throttle closed up and timing fell off. I guess it's hard for you to tell seeing as you just installed these parts, but did the car feel like it was pulling strongly?

Is there any way you can capture the sound on video?
So before I had the parts installed, I was running stage 1 93 octane. It doesn't seem to be pulling any harder than it was on stage 1. Perhaps I am psyching myself out, but it just doesn't feel noticeably faster. Sometimes the boost just feels slow and almost like it's stock. I was able to get it on video, it's kinda hard to hear from within the car, but I couldn't record with the window down because of wind. It's very high pitched, so it makes me think it's a small hole.

Here's an image of the CP connection to the throttle body.
View post on imgur.com


Here's a longer datalog:
http://www.bootmod3.net/log?id=5c47a12fc090c61e5911d292

And here's the video from within the cabin:
https://drive.google.com/file/d/1LZo...ew?usp=sharing
Appreciate 0
      01-22-2019, 09:05 PM   #6
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by ethanm5000 View Post
So before I had the parts installed, I was running stage 1 93 octane. It doesn't seem to be pulling any harder than it was on stage 1. Perhaps I am psyching myself out, but it just doesn't feel noticeably faster. Sometimes the boost just feels slow and almost like it's stock. I was able to get it on video, it's kinda hard to hear from within the car, but I couldn't record with the window down because of wind. It's very high pitched, so it makes me think it's a small hole.

Here's an image of the CP connection to the throttle body.
View post on imgur.com


Here's a longer datalog:
http://www.bootmod3.net/log?id=5c47a12fc090c61e5911d292

And here's the video from within the cabin:
https://drive.google.com/file/d/1LZo...ew?usp=sharing
Gotcha. The car should pull much harder on stage 2, so there's definitely something going on. That's an interesting sound though, can hear it pretty clearly in the video. Is it louder with the windows open, or can you not hear it because the wind drowns it out. I'd honestly be surprised if it was a boost leak judging by that sound, and the logs indicate it's not, but the symptoms are definitely of a boost leak... Also for logs, try to keep them short and sweet, just do a 2 or 3 gear wide open throttle pull, that's the best way to look for a boost leak.

Also, hard to tell if the CP is seated all the way in there. Not sure if we should be seeing shiny stuff. Is there a lot of play right there?

EDIT: the more I listen to it the more it does kinda sound like some air escaping... hard to be certain.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |

Last edited by rjdnyy224; 01-22-2019 at 09:12 PM.
Appreciate 0
      01-22-2019, 10:35 PM   #7
canman111
Enlisted Member
7
Rep
30
Posts

Drives: F30 328i RWD
Join Date: Apr 2018
Location: Australia

iTrader: (0)

Garage List
2014 BMW 328i  [0.00]
You should also check the chargepipe to intercooler side.
The metal c ring on both throttle body and intercooler side should look recessed into the gap provided. If one looks different, or not fully flush, you may have a leak there.
Appreciate 0
      01-23-2019, 01:02 AM   #8
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Gotcha. The car should pull much harder on stage 2, so there's definitely something going on. That's an interesting sound though, can hear it pretty clearly in the video. Is it louder with the windows open, or can you not hear it because the wind drowns it out. I'd honestly be surprised if it was a boost leak judging by that sound, and the logs indicate it's not, but the symptoms are definitely of a boost leak... Also for logs, try to keep them short and sweet, just do a 2 or 3 gear wide open throttle pull, that's the best way to look for a boost leak.

Also, hard to tell if the CP is seated all the way in there. Not sure if we should be seeing shiny stuff. Is there a lot of play right there?

EDIT: the more I listen to it the more it does kinda sound like some air escaping... hard to be certain.
So it's louder with the windows down. Especially when there is something for it to echo off. For example, if I am building boost as I pass a car It's obnoxiously loud. There is a lot of play where the CP connects to the throttle body.
Appreciate 0
      01-23-2019, 01:07 AM   #9
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by canman111 View Post
You should also check the chargepipe to intercooler side.
The metal c ring on both throttle body and intercooler side should look recessed into the gap provided. If one looks different, or not fully flush, you may have a leak there.
Yeah, the problem is that I had these parts installed at a shop since I am in college and have no way of doing any of this myself. Of course, with my luck, either the part is bad or the shop just didn't install something properly. I had a friend rev my car as I listened from the outside and I didn't notice the sound. I am pretty certain at this point there is some sort of boost leak.
Appreciate 0
      01-23-2019, 01:16 AM   #10
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Gotcha. The car should pull much harder on stage 2, so there's definitely something going on. That's an interesting sound though, can hear it pretty clearly in the video. Is it louder with the windows open, or can you not hear it because the wind drowns it out. I'd honestly be surprised if it was a boost leak judging by that sound, and the logs indicate it's not, but the symptoms are definitely of a boost leak... Also for logs, try to keep them short and sweet, just do a 2 or 3 gear wide open throttle pull, that's the best way to look for a boost leak.

Also, hard to tell if the CP is seated all the way in there. Not sure if we should be seeing shiny stuff. Is there a lot of play right there?

EDIT: the more I listen to it the more it does kinda sound like some air escaping... hard to be certain.
The other thing one of the guys at the shop was telling me over the phone is that it could still be leaking regardless of what the datalog showed if it's a small enough leak that the turbo is able to overcome it. Not sure if that's true, but I guess it's a thought.
Appreciate 0
      01-23-2019, 07:31 AM   #11
canman111
Enlisted Member
7
Rep
30
Posts

Drives: F30 328i RWD
Join Date: Apr 2018
Location: Australia

iTrader: (0)

Garage List
2014 BMW 328i  [0.00]
You may have to take it back to the shop that installed it for you to have them check everything over.
Surely theyd do it free of charge as a "warranty job" for their labour. Wouldn't be too hard to make sure everything is seated well.

My experience was when i installed my CP as the first mod, the CP at the intercooler side didnt have the c clip all the way in. It looked ok but under throttle i could hear a sound like air escaping. I had a lookover and could push the pipe in a little further and the clip seated more flush. No sounds after that. It may look ok idle but may be loose under throttle. YMMV. Good luck
Appreciate 0
      01-23-2019, 07:32 AM   #12
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Yah, hearing that, I guess my guess is it's leaking at the throttle body, just the logs contradict that. Could be a faulty pipe or a botched install, neither one are terribly unlikely. It's also not uncommon that you don't hear it when your friend revs it standing still as there's no load on the engine. Also not impossible to have a leak go undetected I guess, but if the leak is big enough to make the car feel slow like you're saying it does, that's 100% something we would see.

I agree with the above post, take it back and have them look at it. If they back up their work, talk with Tiago@VRSF about getting a refund if you can for certain blame it on the pipe. Hopefully he'll take care of you.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      01-23-2019, 05:24 PM   #13
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Yah, hearing that, I guess my guess is it's leaking at the throttle body, just the logs contradict that. Could be a faulty pipe or a botched install, neither one are terribly unlikely. It's also not uncommon that you don't hear it when your friend revs it standing still as there's no load on the engine. Also not impossible to have a leak go undetected I guess, but if the leak is big enough to make the car feel slow like you're saying it does, that's 100% something we would see.

I agree with the above post, take it back and have them look at it. If they back up their work, talk with Tiago@VRSF about getting a refund if you can for certain blame it on the pipe. Hopefully he'll take care of you.
Yeah, unfortunately I tried reseating it at the throttlebody last night and dropped the c clip. I lost it in the engine bay after it landed on the floor pan.
Appreciate 0
      01-23-2019, 06:17 PM   #14
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by ethanm5000 View Post
Yeah, unfortunately I tried reseating it at the throttlebody last night and dropped the c clip. I lost it in the engine bay after it landed on the floor pan.
That stinks. Shouldn't be too hard to drop the belly pan if you have to. If it isn't seating all the way in there, it's probably a problem with the pipe.

Different motor, but this thread might be of interest to you https://f30.bimmerpost.com/forums/sh...1236747&page=2
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      01-23-2019, 08:58 PM   #15
canman111
Enlisted Member
7
Rep
30
Posts

Drives: F30 328i RWD
Join Date: Apr 2018
Location: Australia

iTrader: (0)

Garage List
2014 BMW 328i  [0.00]
rjdnyy224 puts up a good point with the link.
Shop may have possibly forgotten to transfer o-ring?
Appreciate 1
rjdnyy2241048.50

      01-24-2019, 05:46 PM   #16
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

So what do I do if I can’t find the c clip?
Appreciate 0
      01-24-2019, 06:16 PM   #17
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by ethanm5000 View Post
So what do I do if I can’t find the c clip?
You should definitely be able to find it... Drop all the under belly pans, should only take 10 minutes, and it should be there. If not, just pick up another clip online.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      01-25-2019, 07:26 PM   #18
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
You should definitely be able to find it... Drop all the under belly pans, should only take 10 minutes, and it should be there. If not, just pick up another clip online.
I managed to find one website that sells them. Will get here on Monday. Still gotta figure out the boost leak issue. Pretty sure it's at the throttle body connection though.
Appreciate 0
      01-25-2019, 10:35 PM   #19
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by ethanm5000 View Post
I managed to find one website that sells them. Will get here on Monday. Still gotta figure out the boost leak issue. Pretty sure it's at the throttle body connection though.
Nice, and I'm with ya. That throttle body connection is a likely problem spot.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      02-01-2019, 06:39 PM   #20
ethanm5000
New Member
2
Rep
22
Posts

Drives: 2014 428i
Join Date: Dec 2018
Location: College Station, TX

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Nice, and I'm with ya. That throttle body connection is a likely problem spot.
Yeah so I put the c clip back on and put some tape around the throttle body connection and meth bungs and the car pulls super hard now. Just gotta figure out which one is causing the leak. Gonna try tightening the meth bungs first.
Appreciate 0
      02-01-2019, 07:18 PM   #21
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1049
Rep
2,565
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by ethanm5000 View Post
Yeah so I put the c clip back on and put some tape around the throttle body connection and meth bungs and the car pulls super hard now. Just gotta figure out which one is causing the leak. Gonna try tightening the meth bungs first.
Nice, making progress. Trial and error with the tape at those two spots and you should find it.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
Post Reply

Bookmarks

Tags
boost leak, bootmod3, chargepipe, vrsf

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:40 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST