F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Updating idrive history with HU-ServiceManager
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      10-31-2018, 10:39 AM   #45
ir655
New Member
Sweden
0
Rep
6
Posts

Drives: F31 320d and F11 530d
Join Date: Sep 2018
Location: Sweden

iTrader: (0)

Quote:
Originally Posted by Sasquartch View Post
Is your ediabas.ini file definitely correct, ie set to ethernet (ENET) ?
I think it was set to OBD and I changed it to ENET.

When I changed it to ENET that the little icon on the right hand lower taskbar for Ediabas was Red. I tried connecting to HU and had a different error message.

I switched it back to OBD and the icon turned Green and I get the current fault message that i posted earlier.

Worth to mention is that I am using a USB to Ethernet adapter since my laptop does not have a real Ethernet port. Latency is set to 1 and COM1 is set for the adapter. Anyway, feels like if something was wrong with that I wouldnt have been able to do functions with ISTA-D and ESYS.

Anyway, I will update tomorrow night after trying different settings with the Ediabas.ini file.
Appreciate 0
      11-01-2018, 04:13 AM   #46
Sasquartch
Captain
263
Rep
885
Posts

Drives: 328i Luxury auto
Join Date: Aug 2016
Location: Herts

iTrader: (0)

COM port settings are irrelevant

As long as the USB ethernet port functions correctly it should be OK but disable any firewalls in case these are preventing a connection

Make sure there are no other ethernet interfaces in use

When you connect the car it usually takes a few (20-ish) seconds for the PC to auto configure

Use the ipconfig command to check you have a 169. IP address.

Please post up any solution you find for the benefit of others.
Appreciate 0
      11-11-2018, 09:55 AM   #47
Cetar
New Member
3
Rep
16
Posts

Drives: BMW F20 116i 2014 AT
Join Date: Feb 2017
Location: Czech Republic

iTrader: (0)

Hi BMW fans,

some remarks i found out today:
The structure of the Service history record is as follows:
A;0xB;C;D;
Where A is type of the record (1= engine oil); B is if it was late; C = how late in KM; D how late in months.
So for example:
1;0x"not sure about the number";0;2; means Engine oil changed 2 months late.
You can found the exact number for "late" record when you change "Service carried out" to carried out late.

Cheers


Last edited by Cetar; 11-11-2018 at 09:57 AM. Reason: added image
Appreciate 0
      11-12-2018, 05:03 AM   #48
cedchung
First Lieutenant
Canada
24
Rep
388
Posts

Drives: 2006 E92 335i, 2014 F30 320i
Join Date: May 2005
Location: Montreal/Mauritius

iTrader: (1)

What is this error code?
92: SYS-0002: ECU OBJECT FILE NOT FOUND
Appreciate 0
      01-15-2019, 07:36 AM   #49
ir655
New Member
Sweden
0
Rep
6
Posts

Drives: F31 320d and F11 530d
Join Date: Sep 2018
Location: Sweden

iTrader: (0)

Quote:
Originally Posted by Sasquartch View Post
COM port settings are irrelevant

As long as the USB ethernet port functions correctly it should be OK but disable any firewalls in case these are preventing a connection

Make sure there are no other ethernet interfaces in use

When you connect the car it usually takes a few (20-ish) seconds for the PC to auto configure

Use the ipconfig command to check you have a 169. IP address.

Please post up any solution you find for the benefit of others.
Hi! Been a while I was at this, but now needing this to work to enter some service that I have done myself.

In Ediabas.ini I set the interface to OBD and even tried ENET still no Go.

Com port settings is COM3 with latency to 1 and 1.

OBD.ini file matched COM port setting of COM3.

in Ediabas.ini I read that I have to change the remote host section to: 192.168.68.1 from original 192.168.68.40

Port is 6801.

Today I got a different message when trying to connect to HU:

IFH-0018 INITIALIZATION ERROR

I have the required .prg files in Ediabas/ECU folder (Not all from Rheingold, just those relevant to the different HU's).

New tips and tricks pleeeease
Appreciate 0
      01-17-2019, 04:27 PM   #50
ir655
New Member
Sweden
0
Rep
6
Posts

Drives: F31 320d and F11 530d
Join Date: Sep 2018
Location: Sweden

iTrader: (0)

Just noticed I have 2 different EDIABAS folders...

One located in C:\Ediabas

And one in my Rheingold folder (Rheingold\Ediabas)

Should there be 2? The EDIABAS.ini file in the Rheingold\Ediabas\bin folder refers to C:\Ediabas for certain lines.

Is this supposed to be like this or?
Appreciate 0
      01-19-2019, 07:49 AM   #51
ir655
New Member
Sweden
0
Rep
6
Posts

Drives: F31 320d and F11 530d
Join Date: Sep 2018
Location: Sweden

iTrader: (0)

Just to update: Got it working now!

Reinstalled Ediabas etc using Standard BMW Tools pack and downloaded Ediabas configurator to config the ediabas.ini

HU Service manager connects to car and I am able to write service. I managed to delete all the service history already in there, but took pics before I did anything so I can enter those again 😊
Appreciate 0
      01-22-2019, 02:35 AM   #52
Chris_330
New Member
9
Rep
17
Posts

Drives: F31 330d Msport
Join Date: Jan 2017
Location: Yorkshire

iTrader: (0)

can anyone give me a link to download this please?
Appreciate 0
      01-22-2019, 04:36 AM   #53
Sasquartch
Captain
263
Rep
885
Posts

Drives: 328i Luxury auto
Join Date: Aug 2016
Location: Herts

iTrader: (0)

Just google "hu service manager download"

Its all there if you look
Appreciate 0
      01-22-2019, 02:36 PM   #54
neo61uk
Second Lieutenant
neo61uk's Avatar
United Kingdom
60
Rep
241
Posts

Drives: F31 340i Performance Edition
Join Date: Feb 2014
Location: Bristol

iTrader: (0)

Quote:
Originally Posted by ir655 View Post
Just to update: Got it working now!

Reinstalled Ediabas etc using Standard BMW Tools pack and downloaded Ediabas configurator to config the ediabas.ini

HU Service manager connects to car and I am able to write service. I managed to delete all the service history already in there, but took pics before I did anything so I can enter those again 😊
Hi there

Reading your posts I'm trying to get mine to work.
I have esys and coded my cars many times no problem.

Installed HU-SERVICEMANAGER and had initialization error.
So edited ediabas.ini file from obd to esys and it went to different error saying Cannot Connect

I've checked my Ediabas/ecu files and there is no nbt.prg files or anything similar.

Could you tell me where to take all those ediabas/ecu files needed for nbt connection?
Also what else should be changed in ediabas.ini file to make sure its right?
Should I just edit it or use ini editor?

Can't find any instructions online at all.

Many thanks for all the help.
Appreciate 0
      02-13-2019, 01:22 PM   #55
coskunhc
New Member
0
Rep
6
Posts

Drives: BMW 118D
Join Date: Jun 2018
Location: Danmark

iTrader: (0)

Service menu disappeared

Hi all,

I hope there still are someone in this thread. I've done everything as written in the comments and got a connection to my NBT. I have a BMW F20 2014 with NBT Prof.

So normally my service history was visible in the idrive menu, and I wanted to add a manual listing as well, because I've just did a service on my car with oil change and so on. But after I did everything with HU ServiceManager, some how my service history disappeared from my iDrive menu.

And I noticed that you need to change the date format manually to MONTH;DAY;YEAR instead of MONTH-DAY-YEAR, but that didn't change anything either.

So guys/girls, what am I doing wrong?
Attached Images
  
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:31 AM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST