F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > B58 Turbo Engine / Drivetrain / Exhaust Modifications > B58 Engine: please post your experience, including problems / resolutions
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      02-27-2017, 06:16 AM   #67
x5mad
Lieutenant Colonel
x5mad's Avatar
178
Rep
1,620
Posts

Drives: F30 340i
Join Date: May 2009
Location: Australia

iTrader: (0)

So far looks very promising. Hopefully picking mine up in 2 weeks. Can't wait!
Appreciate 0
      02-27-2017, 02:13 PM   #68
Remonster
Major
United_States
340
Rep
1,302
Posts

Drives: F80 M3 Avus Blue
Join Date: Dec 2007
Location: San Diego

iTrader: (0)

19,500 miles and 14 months after picking up my 340i, no real issues and haven't had to take it to the dealership for anything besides the normal maintenance.

I did get a low coolant warning but wasn't able to find a leak anywhere, I topped the coolant up and that's been the end of that so far. Coolant level is still right at the top after a few months.

I absolutely love this engine and would recommend it to anyone interested.

Also, MPPSK is 100% worth it. The power gains aren't huge, especially on 91 octane fuel, but the increase in smoothness and responsiveness is very real and the exhaust is a work of art. My car did run rough on cold start and would even feel like it was misfiring at times right after starting it up, this has gone away ever since I had the MPPSK installed. I don't know if the M kit software is based on a newer revision of the DME software (so maybe this is fixed on all 340s now) but cold starts are much smoother and this is very noticeable in a manual car like mine.
Appreciate 0
      03-02-2017, 12:01 PM   #69
mwh2009
Lieutenant
144
Rep
454
Posts

Drives: Former F80, Former F30 340i
Join Date: Aug 2009
Location: VA

iTrader: (0)

16k miles, 9 mos

Dead A/C compressor

Bummed.
__________________
2018 Golf R / 6 MT / Lapiz Blue
No longer with me:
2017 F80 M3 / 6MT / Black Sapphire Metallic / Sonoma Beige / Executive Pkg / CarPlay
2016 F30 340i xDrive EBII / Saddle Brown / 6MT / Msport / Trk Pkg / other stuff
Appreciate 0
      03-02-2017, 12:50 PM   #70
Araemo
Lieutenant
146
Rep
452
Posts

Drives: 2017 340iX 6MT
Join Date: Mar 2016
Location: NE Ohio

iTrader: (0)

Quote:
Originally Posted by mwh2009 View Post
16k miles, 9 mos

Dead A/C compressor

Bummed.
Were there any symptoms or warning signs?

I noticed when it got warmer out, the car was lurching noticeably whenever the compressor kicks in. Lurching a lot harder than I'd expect. Once it gets warmer again so it's noticeable I was planning on taking it to the dealer to be looked at.
Appreciate 0
      03-02-2017, 02:50 PM   #71
mwh2009
Lieutenant
144
Rep
454
Posts

Drives: Former F80, Former F30 340i
Join Date: Aug 2009
Location: VA

iTrader: (0)

Quote:
Originally Posted by Araemo View Post
Were there any symptoms or warning signs?

I noticed when it got warmer out, the car was lurching noticeably whenever the compressor kicks in. Lurching a lot harder than I'd expect. Once it gets warmer again so it's noticeable I was planning on taking it to the dealer to be looked at.
Nothing like that - just all of the sudden it stopped blowing cold air. When it was new, the A/C could turn your fingers blue - but 70 degree day, and it couldn't keep up.

Supposed to get the car back Monday/Tuesday...

Driving a 320xi loaner in the meantime...
__________________
2018 Golf R / 6 MT / Lapiz Blue
No longer with me:
2017 F80 M3 / 6MT / Black Sapphire Metallic / Sonoma Beige / Executive Pkg / CarPlay
2016 F30 340i xDrive EBII / Saddle Brown / 6MT / Msport / Trk Pkg / other stuff
Appreciate 0
      03-02-2017, 03:16 PM   #72
Araemo
Lieutenant
146
Rep
452
Posts

Drives: 2017 340iX 6MT
Join Date: Mar 2016
Location: NE Ohio

iTrader: (0)

Quote:
Originally Posted by mwh2009 View Post
Nothing like that - just all of the sudden it stopped blowing cold air. When it was new, the A/C could turn your fingers blue - but 70 degree day, and it couldn't keep up.

Supposed to get the car back Monday/Tuesday...

Driving a 320xi loaner in the meantime...
Can you speak to whether the compressor kicking on/off was noticeable if you were idling at a stop? The compressor specifically, not auto start/stop... Engine already running, neutral or clutch depressed, the whole car could feel the shake from the A/C compressor engaging/disengaging. Is that normal, or do I likely have something wrong? (Like I said, not going to bother taking it into the dealer when it's 28F outside, they won't be able to reproduce. I will take it once it is warm again.)
Appreciate 0
      03-02-2017, 03:50 PM   #73
mwh2009
Lieutenant
144
Rep
454
Posts

Drives: Former F80, Former F30 340i
Join Date: Aug 2009
Location: VA

iTrader: (0)

Quote:
Originally Posted by Araemo View Post
Can you speak to whether the compressor kicking on/off was noticeable if you were idling at a stop? The compressor specifically, not auto start/stop... Engine already running, neutral or clutch depressed, the whole car could feel the shake from the A/C compressor engaging/disengaging. Is that normal, or do I likely have something wrong? (Like I said, not going to bother taking it into the dealer when it's 28F outside, they won't be able to reproduce. I will take it once it is warm again.)
Mine had none of that. I repeatedly switched the on/off a/c button and couldn't feel a change at all. I'll admit I didn't get under the hood to try to listen - but I couldn't hear/feel a thing inside the cabin.

Yours sounds different/more serious. If the compressor clutch is frozen in an engaged state, and the belt can't turn the pulley, would that cause a problem like that? I'm not the right guy to ask I'm afraid.
__________________
2018 Golf R / 6 MT / Lapiz Blue
No longer with me:
2017 F80 M3 / 6MT / Black Sapphire Metallic / Sonoma Beige / Executive Pkg / CarPlay
2016 F30 340i xDrive EBII / Saddle Brown / 6MT / Msport / Trk Pkg / other stuff
Appreciate 0
      03-02-2017, 07:06 PM   #74
Araemo
Lieutenant
146
Rep
452
Posts

Drives: 2017 340iX 6MT
Join Date: Mar 2016
Location: NE Ohio

iTrader: (0)

Quote:
Originally Posted by mwh2009 View Post
Mine had none of that. I repeatedly switched the on/off a/c button and couldn't feel a change at all. I'll admit I didn't get under the hood to try to listen - but I couldn't hear/feel a thing inside the cabin.

Yours sounds different/more serious. If the compressor clutch is frozen in an engaged state, and the belt can't turn the pulley, would that cause a problem like that? I'm not the right guy to ask I'm afraid.
Thanks for the response. Like I said, I'll have the dealer look at it once there is a decent chance they can replicate it. It was pretty clearly the compressor clutch applying/disengaging, it just was very harsh and made me wonder if the compressor is going bad. (If I turned off the AC, it stopped doing it entirely.)
Appreciate 0
      03-03-2017, 09:48 AM   #75
joeyb26
Lieutenant
170
Rep
542
Posts

Drives: 2017 340i xDrive M-Sport 6MT
Join Date: May 2013
Location: North NJ

iTrader: (1)

4500 miles and found out my turbo was leaking oil. Dealership replaced the whole turbo under warranty. Kinda concerning to have a car with such low miles have such a major issue. Dealership claimed it was a defective turbo and that they went went through the rest of the car and found no other issues
__________________
2017 340i xDrive 6MT
Appreciate 0
      03-04-2017, 02:53 AM   #76
tpwer
New Member
3
Rep
12
Posts

Drives: F31 340ix
Join Date: Jul 2016
Location: Sweden

iTrader: (0)

Picked up a new F31 340i xdrive a couple of weeks ago from a dealer 400km (~4hrs) from home. Headed out with a smile and got 300meters (!) from the dealer when the 'drivetrain malfunction' light came on. Got back in limp mode to the dealer and then had to drive home the 400km in a loaner.

Got the car back one week (not a great week) later and the only explanation was that some kind of sensor had been replaced. Since then i have just passed the break-in at 2000km without any further issues except some interior rattles. My first "buy new" experience was not as i had imagined it.
Appreciate 2
bueller160.00

      03-10-2017, 01:11 PM   #77
englishguy84
Second Lieutenant
44
Rep
205
Posts

Drives: 230i M-Sport
Join Date: Feb 2016
Location: SF Bay

iTrader: (0)

If someone were buying, not leasing, would it be a safer bet to go with the B48 or B58 at this point from a reliability standpoint? Since both of these engines are new, there's not much data, but maybe people who have seen the rollout of previous BMW engines can offer some insight.
Appreciate 0
      03-12-2017, 05:36 PM   #78
SLOWER
Lieutenant Colonel
SLOWER's Avatar
United_States
258
Rep
1,643
Posts

Drives: 2015 M5
Join Date: Apr 2013
Location: MA

iTrader: (6)

Garage List
2015 BMW M5  [0.00]
2003 M3 Convertible  [0.00]
Just rolled past one year and 15k (right on schedule with my lease) and all is well.
Appreciate 0
      03-12-2017, 06:35 PM   #79
insanecoder
Brigadier General
1302
Rep
3,206
Posts

Drives: 340isDrive
Join Date: May 2016
Location: East Coast USA

iTrader: (0)


For years I had backed off the 335 for those HPFP nightmares and then even when they said it was fixed I backed off til the LCI then i thought what a dumbasp I was to try a new engine on its debut..
Looks like we hit the lotto cause its been very quiet (not the engine).. chalk it up to component engineering.. fingers crossed dont wanna jinx it but the B58
power and maybe reliable as well?
Appreciate 0
      03-13-2017, 10:44 PM   #80
boosted
enthusiast
boosted's Avatar
United_States
24
Rep
99
Posts

Drives: 340i x-drive
Join Date: Sep 2006
Location: IL

iTrader: (0)

0 issues with 15k mi already on my xdrive and AA 8 tune . Always drive aggressive, but responsible
__________________

2016 340i x-drive 8AT. Fully loaded (M-Package, Tech, Cold, Adaptive, etc) - AA 8 tune
2006 GTO NA 473whp - sold
Appreciate 0
      03-15-2017, 09:38 AM   #81
MMacx1
Private
MMacx1's Avatar
United_States
25
Rep
64
Posts

Drives: 2016 BMW 340i M
Join Date: Nov 2014
Location: Calif

iTrader: (0)

AGAIN!! Drivetrain Malfunction

1st time this happen was at 1500 miles
2nd time @5000K miles
on the FWY cruising at 70, I needed to pass a truck so I stepped on it
and Bam! Error message - Drivetrain Malfunction: Whats so weird is when this
happens, the rear of the car feels like the rear end is going to fall out.

pull off the Fwy, shut it down, 1min later re start all normal
Attached Images
 
Appreciate 0
      03-15-2017, 10:13 AM   #82
insanecoder
Brigadier General
1302
Rep
3,206
Posts

Drives: 340isDrive
Join Date: May 2016
Location: East Coast USA

iTrader: (0)

Quote:
Originally Posted by MMacx1 View Post
1st time this happen was at 1500 miles
2nd time @5000K miles
on the FWY cruising at 70, I needed to pass a truck so I stepped on it
and Bam! Error message - Drivetrain Malfunction: Whats so weird is when this
happens, the rear of the car feels like the rear end is going to fall out.

pull off the Fwy, shut it down, 1min later re start all normal
Stock or tuned?
Appreciate 0
      03-15-2017, 11:24 AM   #83
HitmanHearns
Second Lieutenant
78
Rep
295
Posts

Drives: 14' Infiniti Q50 / 16' Audi A4
Join Date: May 2016
Location: Emins house

iTrader: (0)

Quote:
Originally Posted by MMacx1 View Post
1st time this happen was at 1500 miles
2nd time @5000K miles
on the FWY cruising at 70, I needed to pass a truck so I stepped on it
and Bam! Error message - Drivetrain Malfunction: Whats so weird is when this
happens, the rear of the car feels like the rear end is going to fall out.

pull off the Fwy, shut it down, 1min later re start all normal
This has happened to me about 5-7 times so far. It always happens when I'm a bit hesitant with the pedal at WOT. This never happened to me when I was stock.

My mods are JB4, intake and ER downpipe. I will feel better if you tell me your stock

Anyways..same thing for me, turn the car off/on and it's like nothing ever happened.
Appreciate 0
      03-15-2017, 01:01 PM   #84
Araemo
Lieutenant
146
Rep
452
Posts

Drives: 2017 340iX 6MT
Join Date: Mar 2016
Location: NE Ohio

iTrader: (0)

Quote:
Originally Posted by insanecoder View Post
Stock or tuned?
Quote:
Originally Posted by MMacx1 View Post
1st time this happen was at 1500 miles
2nd time @5000K miles
on the FWY cruising at 70, I needed to pass a truck so I stepped on it
and Bam! Error message - Drivetrain Malfunction: Whats so weird is when this
happens, the rear of the car feels like the rear end is going to fall out.

pull off the Fwy, shut it down, 1min later re start all normal

Is this with your Dinantronics sport installed?
Appreciate 0
      03-16-2017, 08:19 AM   #85
MMacx1
Private
MMacx1's Avatar
United_States
25
Rep
64
Posts

Drives: 2016 BMW 340i M
Join Date: Nov 2014
Location: Calif

iTrader: (0)

340i error

The first time it happen, the car was 100% stock, Now it has a Remus mid pipe, with a Dinan Sport tune,
Appreciate 0
      03-16-2017, 08:47 AM   #86
insanecoder
Brigadier General
1302
Rep
3,206
Posts

Drives: 340isDrive
Join Date: May 2016
Location: East Coast USA

iTrader: (0)

Quote:
Originally Posted by mwh2009 View Post
Mine had none of that. I repeatedly switched the on/off a/c button and couldn't feel a change at all. I'll admit I didn't get under the hood to try to listen - but I couldn't hear/feel a thing inside the cabin.

Yours sounds different/more serious. If the compressor clutch is frozen in an engaged state, and the belt can't turn the pulley, would that cause a problem like that? I'm not the right guy to ask I'm afraid.
I wonder if the compressor weakness has anything to do with some of 340i owners experiencing screeching belt issues when shifting. Many of them reported the issue only happened when the A/C was on.
Appreciate 0
      03-16-2017, 09:53 PM   #87
Jaghave
Colonel
785
Rep
2,136
Posts

Drives: 2016 BMW 340i (Auto) RWD
Join Date: Jul 2016
Location: New Jersey

iTrader: (0)

Hit 20k 0 issues outside of needing coolant
Appreciate 0
      03-17-2017, 06:37 AM   #88
jalkster
Lieutenant
145
Rep
406
Posts

Drives: 340i M-Sport
Join Date: Jan 2017
Location: Dallas, TX

iTrader: (2)

Quote:
Originally Posted by insanecoder View Post
Stock or tuned?
Happened to me stock... I stepped on it pretty good in the express lane and it popped up. I was on reserve fuel tank, though. Hasn't returned after 6k miles.
Appreciate 0
Post Reply

Bookmarks

Tags
b58

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:06 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST