F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > 10.25" Android 9.0 HU discussion
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      Today, 06:54 AM   #2157
Kostisuk
New Member
0
Rep
5
Posts

Drives: Bmw e64
Join Date: Jan 2020
Location: Greece

iTrader: (0)

Quote:
Originally Posted by seaman5705 View Post
Disconnect AUX port in armrest .

It worked directly without having to connect anything in the aux in the armrest. Is that what you mean ?

Or i should do something more ?
Appreciate 0
      Today, 07:00 AM   #2158
endursa
New Member
2
Rep
11
Posts

Drives: BMW f20
Join Date: Sep 2019
Location: austria

iTrader: (0)

Quote:
Originally Posted by RedErik View Post
Many thanks for this clarification, and yes, I hear that Lucky Patcher is necessary step here as all rom / ksw apps are signed with the same key - SharedUserID thing etc.

However you say if one was to replace only png resources this whole odex issue wouldn't be a problem. This is exactly what I'm trying to do i.e. replace few pngs and couple of xml files. The problem is, when Kri (just to test things out) deleted launcher apk, system still booted up with, well, all launcher stuff present. So this would mean that resources are also precompiled and stored elsewhere?
try only replacing he pngs and leave out the modified xmls, and test if this works!

also do not unpack the original apk, but open the apk file with 7zip, and drag the new pngs inside and close it again (with saving), this should not modify the signature, but only replace graphics!
Appreciate 0
      Today, 07:38 AM   #2159
Kri
First Lieutenant
Austria
159
Rep
329
Posts

Drives: E87
Join Date: Dec 2017
Location: Germany

iTrader: (0)

Quote:
Originally Posted by franbass View Post
The PC didn't found the android ip, for that, I'd to set the port tcp.ip 5555 following the guide. To "open" or "set" this port we need a terminal app in the android system.

Ok, I'm going to do that, thank you so much Kri!
When it does not find the IP Adress then there is some other issue before the 5555 Port.
My script does ping the unit first to se if it is in the same network, if this does not work, then there is some other issue before.

Which IP and MAC Adress do your unit and your PC get ?

Kri
Appreciate 0
      Today, 07:45 AM   #2160
RedErik
Private
RedErik's Avatar
Scotland
16
Rep
63
Posts

Drives: BMW 645Ci
Join Date: Oct 2019
Location: Inverness

iTrader: (0)

Garage List
2004 E63 645Ci  [0.00]
Quote:
Originally Posted by endursa View Post
try only replacing he pngs and leave out the modified xmls, and test if this works!

also do not unpack the original apk, but open the apk file with 7zip, and drag the new pngs inside and close it again (with saving), this should not modify the signature, but only replace graphics!
Thanks for that, but this creates an issue as I need to modify xmls to have some of the new pngs aligned correctly. However I can replace just a couple of pngs and check if that works at all.

Edit: I believe smahel managed to successfully modify and install KswPLauncher.apk in the past. Any input would be much appreciated. Also what are the chances of ending up in a boot loop by swapping just a few png files?

Last edited by RedErik; Today at 08:08 AM..
Appreciate 0
      Today, 11:30 AM   #2161
koutsouk
Private First Class
25
Rep
166
Posts

Drives: BMW E60
Join Date: Mar 2018
Location: Greece

iTrader: (0)

Quote:
Originally Posted by RedErik View Post
I'm interested myself, however I don't think this would sort CID issue. CAN is like LAN network - doesn't matter where in the network you have your device plugged in. As long as it's connected it will show up. Same with CAN, you would need to emulate CID to get rid of this error.
Well i would like to make the system stay on for more time than a minute after i turn the ignition off.
I think that 30g terminal stays on for more time.
I tried that already but didn`t work.
I bridged the cable from CID to the yellow cable of the unit .
But i did not cut out the original harness before the bridge from the yellow cable.
I thought that if the system cuts power coming from CCC if i give power from the CID also it will keep working.
Unfortunately not.
Perhaps i must connect the CAN lines from CID to the unit because i think that MCU gives the signal to the system to power on.
Am i wrong with that?
Appreciate 0
      Today, 12:28 PM   #2162
RedErik
Private
RedErik's Avatar
Scotland
16
Rep
63
Posts

Drives: BMW 645Ci
Join Date: Oct 2019
Location: Inverness

iTrader: (0)

Garage List
2004 E63 645Ci  [0.00]
Quote:
Originally Posted by koutsouk View Post
Well i would like to make the system stay on for more time than a minute after i turn the ignition off.
I think that 30g terminal stays on for more time.
I tried that already but didn`t work.
I bridged the cable from CID to the yellow cable of the unit .
But i did not cut out the original harness before the bridge from the yellow cable.
I thought that if the system cuts power coming from CCC if i give power from the CID also it will keep working.
Unfortunately not.
Perhaps i must connect the CAN lines from CID to the unit because i think that MCU gives the signal to the system to power on.
Am i wrong with that?
I'm not convinced that terminal 30g is a good solution. Yes, it would be nice to have the unit powered up as soon as car is unlocked, but it would stay awake and lit up for 30min after car is locked which doesn't sound reasonable. Also every time you accidentally press a button on your key fob the whole thing comes to life for another 30min.

Unless I'm mistaken about this 30min, but I'm pretty sure that's what TIS says.

Also you've used yellow cable to bridge power to the unit. I wouldn't go by colours, these can vary car to car. You need to find in TIS which pin on the CID connector provides 12V.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:35 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST