F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > 2016 325d Wagon -- Nav and Presets don't seem to work
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      Today, 11:09 AM   #1
jagnweiner
Registered
0
Rep
4
Posts

Drives: 2012 Regal GS (no BMW yet)
Join Date: Feb 2020
Location: Geneseo, IL

iTrader: (0)

2016 325d Wagon -- Nav and Presets don't seem to work

New guy here. I bought my first BMW yesterday, a 2016 325d Wagon. I generally love the car so far, but was somewhat vexed to discover on the 350 mile drive home that the navigation system does not work. It just says "starting navigation system", but never actually starts working.

Also, don't know if these two are related, but I can't get the radio presets to stay in the system. I can set a series of presets and access them through the scrolling button on the steering wheel, but when I shut the car off for more than a few seconds and turn it back on, they are gone. Could be operator error, but I don't know.

Thoughts?

Thanks,
Scott
Appreciate 0
      Today, 11:39 AM   #2
Billfitz
Major General
Billfitz's Avatar
United_States
3530
Rep
8,376
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Take it back to get the nav fixed. The presets aren't radio presets, they're presets for whatever you have on the iDrive screen. That can be a radio station, it can be a nav destination, it can be a phone number. If you're listening to a station and the screen is showing something else pressing a preset button doesn't save the radio station, it saves what's on the screen. The scroll button on the wheel doesn't show presets, it shows any and all radio stations within range. This is all in your Entertainment and Navigation manual.
Appreciate 0
      Today, 11:59 AM   #3
jagnweiner
Registered
0
Rep
4
Posts

Drives: 2012 Regal GS (no BMW yet)
Join Date: Feb 2020
Location: Geneseo, IL

iTrader: (0)

Thanks for the quick reply, Bill.

Quote:
Originally Posted by Billfitz View Post
Take it back to get the nav fixed. .
Unfortunately, that's not really an option. Bought it from a gentleman in Kansas City and I'm in Illinois. He did not mention the non-functioning nav. I'll probably pay my first visit to the local BMW dealer.

Anyone have any idea of a likely cause of the nav issue? A programming problem?

On the preset issue, if I have my iDrive set for "Presets," rather than FM, AM, or Satellite, the scroll does only show preset stations. But in my case, they all disappear from there and from the iDrive when I turn the car off.

Last edited by jagnweiner; Today at 04:09 PM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:43 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST