F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > 10.25" Android 9.0 HU discussion
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      11-09-2019, 06:31 PM   #1057
marakeh
Private
17
Rep
64
Posts

Drives: BMW 118D
Join Date: Jun 2019
Location: Germany

iTrader: (0)

Quote:
Originally Posted by QUiKSR20 View Post
Anyone else have an issue where it just doesnt keep the correct time? Any tricks?

Ive tried "Android Time", Ive tried "iDrive Time" no matter what combination it either always goes back to the 24HR clock or the wrong time after the car is shutdown and restarted.
with root, you can try to modify the build.prop for your timezone, alternative, use original time (will get the time from the car clock through can)
Appreciate 0
      11-09-2019, 07:39 PM   #1058
QUiKSR20
Major
QUiKSR20's Avatar
United_States
234
Rep
1,251
Posts

Drives: 13' F30 328i 6MT
Join Date: Mar 2012
Location: NJ

iTrader: (17)

Garage List
Quote:
Originally Posted by marakeh View Post
with root, you can try to modify the build.prop for your timezone, alternative, use original time (will get the time from the car clock through can)
Hello Marakeh, Appreciate your input.... Thats what I mentioned though, Ive set it to "CAR TIME" ie CANBUS it still either puts itself back in 24hour mode or the wrong time.
__________________
13 F30 328i Sport 6MT
95 E36 325i Vert 5MT
92 Sentra SE-R SR20DET DET Build Thread
08 E90 328i Sport [sold]
89 E30 325is [sold & missed]
Appreciate 0
      11-10-2019, 05:34 AM   #1059
marakeh
Private
17
Rep
64
Posts

Drives: BMW 118D
Join Date: Jun 2019
Location: Germany

iTrader: (0)

i had the issue too, i unchecked all the time check boxes, did a reboot through the system settings, enabled original time, did a reboot and after that the unit applied the car clock directly after boot.
Appreciate 0
      11-10-2019, 05:54 AM   #1060
QUiKSR20
Major
QUiKSR20's Avatar
United_States
234
Rep
1,251
Posts

Drives: 13' F30 328i 6MT
Join Date: Mar 2012
Location: NJ

iTrader: (17)

Garage List
Quote:
Originally Posted by marakeh View Post
i had the issue too, i unchecked all the time check boxes, did a reboot through the system settings, enabled original time, did a reboot and after that the unit applied the car clock directly after boot.
Cool ill give that a try, thank u
__________________
13 F30 328i Sport 6MT
95 E36 325i Vert 5MT
92 Sentra SE-R SR20DET DET Build Thread
08 E90 328i Sport [sold]
89 E30 325is [sold & missed]
Appreciate 0
      11-10-2019, 06:57 AM   #1061
mrsimes
Enlisted Member
9
Rep
45
Posts

Drives: BMW
Join Date: Nov 2015
Location: UK

iTrader: (0)

Quote:
Originally Posted by marakeh View Post
well, before removing the caps it would be easier to just unplug the aux port in the armrest
It's the Android unit that's blowing the sound out though because if I plug anything else into AUX it is perfectly clear. I just got unlucky with a crap unit.
Appreciate 0
      11-10-2019, 12:00 PM   #1062
twoface
Enlisted Member
15
Rep
44
Posts

Drives: BMW 316D
Join Date: Aug 2019
Location: Croatia

iTrader: (0)

How do you report bugs or feature requests? Seller doesn't really respond to my requests. There is app called "User feedback" but its one way communication.

Its really annoying me that all apps in Android will close if I switch to idrive and then Android again. I bought Tasker app in order to try to solve it but I'm a noob for it.
Appreciate 0
      11-10-2019, 12:07 PM   #1063
Kri
First Lieutenant
Austria
193
Rep
398
Posts

Drives: E87
Join Date: Dec 2017
Location: Germany

iTrader: (0)

Quote:
Originally Posted by twoface View Post
How do you report bugs or feature requests? Seller doesn't really respond to my requests. There is app called "User feedback" but its one way communication.

Its really annoying me that all apps in Android will close if I switch to idrive and then Android again. I bought Tasker app in order to try to solve it but I'm a noob for it.
The only way to report bugs is to write your seller.
They normally do not listen to feature requests.

Chri
Appreciate 0
      11-11-2019, 03:29 PM   #1064
Xanderl
Enlisted Member
0
Rep
34
Posts

Drives: F30
Join Date: Aug 2019
Location: Germany

iTrader: (0)

How can i Open the Back rear View? I have a Wireless Camera But my Snapdragon didnt Turn on the Back up View (manual shift gear)
Appreciate 0
      11-11-2019, 05:16 PM   #1065
Spanielgita
New Member
United Kingdom
2
Rep
11
Posts

Drives: BMW F30
Join Date: Nov 2019
Location: Lauder

iTrader: (0)

Hello to all, I have installed a 10.25" android 9.0 headunit and would like to warn everyone reading this of the dangers of not routing your cables carefully behind said unit.

After reinstalling my headunit there was a bit of a struggle to get it back in the recess. I may have pushed a bit too hard and one of my connectors has unfortunately snapped off. I am now in a position were my headunit does not seem to power up at all and I have a connector to fix of which I may struggle to source the new part.

Here are some pictures of my plight. Please don't be as foolish as me.
Attached Images
     
Appreciate 0
      11-11-2019, 05:29 PM   #1066
QUiKSR20
Major
QUiKSR20's Avatar
United_States
234
Rep
1,251
Posts

Drives: 13' F30 328i 6MT
Join Date: Mar 2012
Location: NJ

iTrader: (17)

Garage List
Has anyone successfully paired an OBD Dongle such as veepeak's OBD dongle to these Snapdragon head-units. I wanted to setup a dash app like Torque or RealDash?
__________________
13 F30 328i Sport 6MT
95 E36 325i Vert 5MT
92 Sentra SE-R SR20DET DET Build Thread
08 E90 328i Sport [sold]
89 E30 325is [sold & missed]
Appreciate 0
      11-11-2019, 06:36 PM   #1067
Kri
First Lieutenant
Austria
193
Rep
398
Posts

Drives: E87
Join Date: Dec 2017
Location: Germany

iTrader: (0)

Quote:
Originally Posted by QUiKSR20 View Post
Has anyone successfully paired an OBD Dongle such as veepeak's OBD dongle to these Snapdragon head-units. I wanted to setup a dash app like Torque or RealDash?
Bluetooth does only work with Smartphones / Phone Music app, not other stuff.
If you want to use a ODB Dongle you need to user either a USB or Wirless LAN Interface.

Kri
Appreciate 0
      11-11-2019, 06:48 PM   #1068
Gabrielisimous
Enlisted Member
Gabrielisimous's Avatar
United_States
6
Rep
39
Posts

Drives: F30 328i 2013
Join Date: Apr 2018
Location: California

iTrader: (0)

Anyone who can help I have installed Avinusa 10.25 PX6 head unit and also installed an aftermarket reverse camera but when switching to "P" from "R" it takes about 5 secs to switch back to the normal screen, thank you in advance
Appreciate 0
      11-11-2019, 06:56 PM   #1069
Gabrielisimous
Enlisted Member
Gabrielisimous's Avatar
United_States
6
Rep
39
Posts

Drives: F30 328i 2013
Join Date: Apr 2018
Location: California

iTrader: (0)

Quote:
Originally Posted by QUiKSR20 View Post
Quote:
Originally Posted by marakeh View Post
i had the issue too, i unchecked all the time check boxes, did a reboot through the system settings, enabled original time, did a reboot and after that the unit applied the car clock directly after boot.
Cool ill give that a try, thank u
I did the following

Go to "time" and put manually the time and date then check original time, after this go to "more settings" Date & Time (this is on Android kind of settings) set the correct time zone for your area (default it wills how "China")now your clock should be set and remembered each time your unit restarts
Appreciate 0
      11-12-2019, 12:25 AM   #1070
QUiKSR20
Major
QUiKSR20's Avatar
United_States
234
Rep
1,251
Posts

Drives: 13' F30 328i 6MT
Join Date: Mar 2012
Location: NJ

iTrader: (17)

Garage List
Quote:
Originally Posted by Kri View Post
Bluetooth does only work with Smartphones / Phone Music app, not other stuff.
If you want to use a ODB Dongle you need to user either a USB or Wirless LAN Interface.

Kri

That stinks but good to know, I just purchased a Veepeak OBD Dongle that looks like I wont be able to use it outside of Bimmercode & other apps.

Quote:
Originally Posted by Gabrielisimous View Post
I did the following

Go to "time" and put manually the time and date then check original time, after this go to "more settings" Date & Time (this is on Android kind of settings) set the correct time zone for your area (default it wills how "China")now your clock should be set and remembered each time your unit restarts
Cool thanks ill try this as well, I think I got the time to stick somehow but it keeps going to 24hr
__________________
13 F30 328i Sport 6MT
95 E36 325i Vert 5MT
92 Sentra SE-R SR20DET DET Build Thread
08 E90 328i Sport [sold]
89 E30 325is [sold & missed]
Appreciate 0
      11-12-2019, 09:00 AM   #1071
Spanielgita
New Member
United Kingdom
2
Rep
11
Posts

Drives: BMW F30
Join Date: Nov 2019
Location: Lauder

iTrader: (0)

Quote:
Originally Posted by Spanielgita View Post
Hello to all, I have installed a 10.25" android 9.0 headunit and would like to warn everyone reading this of the dangers of not routing your cables carefully behind said unit.

After reinstalling my headunit there was a bit of a struggle to get it back in the recess. I may have pushed a bit too hard and one of my connectors has unfortunately snapped off. I am now in a position were my headunit does not seem to power up at all and I have a connector to fix of which I may struggle to source the new part.

Here are some pictures of my plight. Please don't be as foolish as me.
Just an update in case anyone else does similar, turned out I had blown a 20 AMP fuse, number 121 (for the headunit) located in the boot fuse box. Replaced this and the headunit came back to life, albeit with no FM radio reception now. Not an issue for me as I use DAB.

I re-installed my screen with the negative off the battery and made sure to route the cables better so I wasn't likely to break anything again. So far so good, all working again. I am well pleased!
Appreciate 0
      11-12-2019, 09:48 AM   #1072
Mirjam
Private First Class
30
Rep
134
Posts

Drives: BMW E87, F10, i3
Join Date: Sep 2019
Location: Europe

iTrader: (0)

Quote:
Originally Posted by Xanderl View Post
How can i Open the Back rear View? I have a Wireless Camera But my Snapdragon didnt Turn on the Back up View (manual shift gear)
Look for Gear Selection in the Factory Settings, Vehicle, it works like this:

Automatic: The red Camera Power cable should be getting power when in reverse gear. Measure with a voltmeter. If so, this is where you should connect the power cable to the camera.

Manual: If Automatic doesn't work, you must manually tell the Android unit when in reverse gear. To do this, power the purple DET cable (detect).
Appreciate 0
      11-12-2019, 10:14 AM   #1073
Mirjam
Private First Class
30
Rep
134
Posts

Drives: BMW E87, F10, i3
Join Date: Sep 2019
Location: Europe

iTrader: (0)

After a few weeks experience, I have three main problems with my Snapdragon unit (E87, 2009, M-ASK Business Navi).

1. PDC doesn't work. This is a major issue. I've tried everything. MCU and App upgraded to 3.0.8. PDC is just not getting power when CAN cable is connected to the Android unit. Disconnect CAN1 and it lights up (but then Android shuts down without CAN connection). I even tried powering the Detect cable, the camera interface is triggered then, and it shows the PDC graphics, but it doesn't work. Android must be interpreting CAN signals wrong?

2. The unit is powering off after only ten seconds when the key is removed, and does a full boot when key is re-inserted. The normal behavior is that it goes to sleep for about 5 minutes before powering off?

3. Like others I experience problem with sound from Navi apps if the built in music player is not started first: Full volume from front left speaker. When music player is started first, music is muted and Navi commands (Waze) are transmitted though all speakers, in a pleasant voice and volume.
Appreciate 0
      11-12-2019, 11:24 AM   #1074
Kri
First Lieutenant
Austria
193
Rep
398
Posts

Drives: E87
Join Date: Dec 2017
Location: Germany

iTrader: (0)

Quote:
Originally Posted by Mirjam View Post
After a few weeks experience, I have three main problems with my Snapdragon unit (E87, 2009, M-ASK Business Navi).

1. PDC doesn't work. This is a major issue. I've tried everything. MCU and App upgraded to 3.0.8. PDC is just not getting power when CAN cable is connected to the Android unit. Disconnect CAN1 and it lights up (but then Android shuts down without CAN connection). I even tried powering the Detect cable, the camera interface is triggered then, and it shows the PDC graphics, but it doesn't work. Android must be interpreting CAN signals wrong?
does PDC not work at all, also no beeping ? or does it just show no picture / signal ?
Does it work when you are at the original Display screen?
PDC-ECU and the Button at the center console are not directly connected to CAN directly, and not to the HU directly.

Quote:
2. The unit is powering off after only ten seconds when the key is removed, and does a full boot when key is re-inserted. The normal behavior is that it goes to sleep for about 5 minutes before powering off?
This is a normal behavior of the Snapdragon HU, it does shut down after 10-30 seconds and not changeable at the moment.

Kri
Appreciate 0
      11-12-2019, 11:55 AM   #1075
Joe111
Registered
0
Rep
1
Posts

Drives: F30 320D
Join Date: Nov 2019
Location: United Kingdom

iTrader: (0)

I recently purchased the andriod screen from Avin and I have just completed the install. Everything seems to be working properly apart from the GPS.

The only problem I'm having is with the unit no being able to lock onto a satellite, so at the moment the navigation side of things is not working. I placed the GPS receiver on top on the glove box under the dash.

My car had the 6.5inch screen with no nav.

Any advise or tips from anyone?
Appreciate 0
      11-12-2019, 11:57 AM   #1076
grocerylist
Private First Class
78
Rep
139
Posts

Drives: BMW M235i
Join Date: Jun 2019
Location: Seattle, WA

iTrader: (0)

Garage List
2016 BMW M235i  [0.00]
Has anyone tried the new Android Auto for phone screens app that was released about 2 weeks ago? Wondering how or if this works and entirely eliminates the need to physically connect an android phone via USB to the head unit display?
Appreciate 0
      11-12-2019, 12:17 PM   #1077
seaman5705
Private First Class
12
Rep
110
Posts

Drives: BMW F10
Join Date: Aug 2019
Location: Europe

iTrader: (0)

headunit internals

I have opened my Snapdragon unit, due to my problem (stuck at fastboot), in search for OTG resistor .
I have the unit with external box, from Andream . I am posting pictures of the board which is hosted by external box. Processor, auxiliaries and connections are in this box, display contains only LCD with touch and controllers .
If anyone wants more detailed pictures or is curious about something , I am ready to help , while the unit is on the table.
So far I could not identify any resistor marked as OTG . Only a strange golden one (marked as "b" or something , in red circle).
Attached Images
   
Appreciate 0
      11-12-2019, 12:36 PM   #1078
Xanderl
Enlisted Member
0
Rep
34
Posts

Drives: F30
Join Date: Aug 2019
Location: Germany

iTrader: (0)

Where i can get the newest updates for Android headunits? 🙈 have a avinusa Snapdragon 625 headunit
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:33 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST