F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > DIY: F30 Rear Park Distance Control (PDC) Retrofit
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      05-03-2018, 02:38 PM   #287
Jhnblckwood
Captain
96
Rep
708
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Also after I hooked everything up and coded I was getting error for park assist on screen no beeps or anything n after I upgraded rem istep it works fine. Thanks again roxxor for all is diyís!!
Appreciate 0
      07-20-2018, 05:52 AM   #288
teutf30
New Member
0
Rep
11
Posts

Drives: F30, 2015
Join Date: Jul 2018
Location: Portugal

iTrader: (0)

Installing a used REM from a car with different options

I did the physical installation part - installed sensors and ran the wiring to the boot.
Since this is my first time coding, or even using E-Sys for that matter, I want to be completely sure before doing anything.

I had a very basic REM (virtually no options) and will be replacing it with the XXX700 unit, as advised here.
The XXX700 REM came from another car, so from what I understand, the procedure is slighlty different from that for a new REM.
Are the instructions provided by RSinc applicable to my case? I quote them below:

Quote:
Originally Posted by RSnic View Post
SquidlyBoy & Shazsta,

Thanks to advice from Shawn Sheridan, when I replaced the REM in my car, I injected CAFD into the REM ECU; to do so, after connecting to car with E-Sys
  • Click on READ FA/VO
  • Right Click on FA/VO and ACTIVATE FA/VO
  • Click on READ SVT(VCM)
  • Left Click on ECU (not the associated CAFD)
  • Cleck on DETECT CAF FROM SWE
  • Select CAFD matching car's I-Level
  • Select OK

That will bring the REM into line with the rest of the car; then you can VO Code it

Second question: does this procedure make a backup of my current setup, so that I can go back to the original REM should anything go wrong?
Appreciate 0
      07-20-2018, 03:04 PM   #289
jkwhar
Lieutenant
104
Rep
482
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (4)

Quote:
Originally Posted by teutf30 View Post
I did the physical installation part - installed sensors and ran the wiring to the boot.
Since this is my first time coding, or even using E-Sys for that matter, I want to be completely sure before doing anything.

I had a very basic REM (virtually no options) and will be replacing it with the XXX700 unit, as advised here.
The XXX700 REM came from another car, so from what I understand, the procedure is slighlty different from that for a new REM.
Are the instructions provided by RSinc applicable to my case? I quote them below:




Second question: does this procedure make a backup of my current setup, so that I can go back to the original REM should anything go wrong?
Someone correct me if I'm wrong but the instruction should work with either new or used REM.

If you need to go back to your original REM, you should be able to follow the steps you quoted to revert it back.
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | 475 BSM | 2A5 18" | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers | Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | VLD | 2TB SAT | 508 | 3AG | 5DL | 6WB | 8TH
Appreciate 0
      07-21-2018, 06:41 PM   #290
teutf30
New Member
0
Rep
11
Posts

Drives: F30, 2015
Join Date: Jul 2018
Location: Portugal

iTrader: (0)

After coding, there's no sound, and I'm also getting the Parking Assistance error screen previously shown by Rubber_Ducky:
"No parking assistance, please park unaided. Consult Service Centre"

Injected cafd on the new REM and HU_entry and added VO 507 (rear only for now).

My questions:

1-I'm using psdzdata light - should I have used psdzdata full instead?

2-My car's i-step is F020-15-03-503, but the highest available in psdzdata 4.12.12 is F020-14-03-503 - so I selected this. Could this be the culprit?

3-The only other possible problem I can think of is the wire connection - perhaps a couple of pins are shorted, or not making contact at all - I'll look at that tomorrow. Would the other tool (Rheingold/ISTA) I frequently see mentioned here be useful in diagnosing a possible bad connection?
Appreciate 0
      07-21-2018, 09:01 PM   #291
jkwhar
Lieutenant
104
Rep
482
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (4)

Quote:
Originally Posted by teutf30 View Post
After coding, there's no sound, and I'm also getting the Parking Assistance error screen previously shown by Rubber_Ducky:
"No parking assistance, please park unaided. Consult Service Centre"

Injected cafd on the new REM and HU_entry and added VO 507 (rear only for now).

My questions:

1-I'm using psdzdata light - should I have used psdzdata full instead?

2-My car's i-step is F020-15-03-503, but the highest available in psdzdata 4.12.12 is F020-14-03-503 - so I selected this. Could this be the culprit?

3-The only other possible problem I can think of is the wire connection - perhaps a couple of pins are shorted, or not making contact at all - I'll look at that tomorrow. Would the other tool (Rheingold/ISTA) I frequently see mentioned here be useful in diagnosing a possible bad connection?
1- Psdzdata lite is all you need. The full version is to flash the ECU.

2- Check this thread, especially post #3 https://www.bimmerfest.com/forums/sh...d.php?t=883416
I would download the most current psdzdata and try again.

3- Try ISTA/d and run a vehicle tests and then view fault. It may give you a sense of direction.
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | 475 BSM | 2A5 18" | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers | Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | VLD | 2TB SAT | 508 | 3AG | 5DL | 6WB | 8TH
Appreciate 0
      07-22-2018, 01:43 AM   #292
teutf30
New Member
0
Rep
11
Posts

Drives: F30, 2015
Join Date: Jul 2018
Location: Portugal

iTrader: (0)

Quote:
Originally Posted by jkwhar View Post
2- Check this thread, especially post #3 https://www.bimmerfest.com/forums/sh...d.php?t=883416
I would download the most current psdzdata and try again.
The i-step available in psdzdata is older than the car's (the car is from 2015/11 and the latest psdzdata i-step is from 2014). Does the chosen i-step for CAFD have to match the car's i-step, or the REM's i-step - the REM is from 2013 I believe.

My version of psdzdata is 4.12.12 - is there a newer version?
Appreciate 0
      07-22-2018, 02:00 AM   #293
jkwhar
Lieutenant
104
Rep
482
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (4)

Quote:
Originally Posted by teutf30 View Post
The i-step available in psdzdata is older than the car's (the car is from 2015/11 and the latest psdzdata i-step is from 2014). Does the chosen i-step for CAFD have to match the car's i-step, or the REM's i-step - the REM is from 2013 I believe.

My version of psdzdata is 4.12.12 - is there a newer version?
It should match the car's istep, or close to it. The istep of your car is from March 2015 (F020-15(year)-03(month)-503).
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | 475 BSM | 2A5 18" | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers | Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | VLD | 2TB SAT | 508 | 3AG | 5DL | 6WB | 8TH
Appreciate 0
      07-22-2018, 02:30 AM   #294
teutf30
New Member
0
Rep
11
Posts

Drives: F30, 2015
Join Date: Jul 2018
Location: Portugal

iTrader: (0)

And do you know if there's an available psdzdata supporting 2015+ i-levels? 4.12.12 doesn't seem to.
Appreciate 0
      07-22-2018, 03:19 AM   #295
atzebmw
Major
Germany
243
Rep
1,154
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by teutf30 View Post
After coding, there's no sound, and I'm also getting the Parking Assistance error screen previously shown by Rubber_Ducky:
"No parking assistance, please park unaided. Consult Service Centre"

Injected cafd on the new REM and HU_entry and added VO 507 (rear only for now).
Did you also code (hit the button code) the REM and HU_Entry after adding 507 and injecting cafd?
I think the choosen cafd is no Problem and the psdzdata also not.
Appreciate 0
      07-22-2018, 08:07 PM   #296
teutf30
New Member
0
Rep
11
Posts

Drives: F30, 2015
Join Date: Jul 2018
Location: Portugal

iTrader: (0)

Two pins were touching

It's working now.
The coding had been properly done.
It was just that two pins on the end of the PDC cable were touching, something that I identified with a Multimeter.
After reseating one of the two pins, re-connected them to the REM and it worked. PDC is working fine, with no lag.

After reseatting the connector, both the brown connector and pins are in bad shape, so I'll order those and make a new cable termination, especially as I intend to do the front PDC in the next few days.
Appreciate 0
      07-23-2018, 12:02 AM   #297
jkwhar
Lieutenant
104
Rep
482
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (4)

Quote:
Originally Posted by teutf30 View Post
It's working now.
The coding had been properly done.
It was just that two pins on the end of the PDC cable were touching, something that I identified with a Multimeter.
After reseating one of the two pins, re-connected them to the REM and it worked. PDC is working fine, with no lag.

After reseatting the connector, both the brown connector and pins are in bad shape, so I'll order those and make a new cable termination, especially as I intend to do the front PDC in the next few days.
Sounds like my previous post #266 except I noticed it during installation. Glad you got yours working!
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | 475 BSM | 2A5 18" | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers | Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | VLD | 2TB SAT | 508 | 3AG | 5DL | 6WB | 8TH
Appreciate 0
      10-30-2018, 10:08 AM   #298
adapada
New Member
2
Rep
22
Posts

Drives: F30 335i xDrive
Join Date: Sep 2017
Location: MD

iTrader: (0)

Quote:
Originally Posted by squidlyboy View Post
Ok... i have a pretty good idea what needs to be done. Everything is in that inner connector, which won't be too bad. I'll try your suggestion and wire the PDC wires directly into the REM as a test once i extract all the wires back out of the connector. Had to smile a little bit as i already trimmed the L into an I with a nail clipper file when i was doing the initial install. When i was doing it, I was like WTF.. why do i have to do this??? Why is this so f****** difficult to put in??

Fortunately, the connector only has 3 other existing wires running into it - i.e. 2 K-CAN signal wires (pins #28 and #43) and a common Ground wire (pin #33). My F30 doesn't have a lot of extra options, and that helps a lot in this situation - only 3 existing wires to deal with in case i end up destroying the whole connector. Worst case if i have to replace the connector, i found the part number on the side of it (9253102-2). I prepended the common 6113 prefix and removed the "-2" rev level and voila - 61139253102. Some parts just can't be found by browsing RealOEM or ETK...






Anyone know what the part number for the external housing below is? Its the part that the inner connector above slides into before pushing the whole thing back into the REM. It fits into the A174*14B slot in the REM. Its an external carrier with the safety latch that holds the two inner connectors that contains a total of 54-pins (54-pol). The only identifier i saw written on the side of it was the numbers "214 1491-1". I tried adding the prefix and deleting the rev suffix, but that didn't turn up anything.



I know this is a 3 year old post but the part number for the housing I have is 61139253104. I've been unable to source it domestically so if you think you'll need to replace it quickly I highly recommend ordering in advance or pulling the part from a wrecked car (might as well grab that brown connector too since I bent the crap out of the housing when reinstalling it.

I got the "Parking Assistance is unavailable" message but after a few seconds the PDC kicks back on and starts working again. My guess is that I'm intermittently shorting some pins.

Last edited by adapada; 10-30-2018 at 10:19 AM..
Appreciate 0
      11-18-2018, 07:35 AM   #299
AL20153
New Member
0
Rep
6
Posts

Drives: F30 2015-03
Join Date: Nov 2018
Location: Florida

iTrader: (0)

errors after PDC installed

Thank all very much for sharing your experiences and for your guidance. I just finished the rear PDC install and I am getting an error on display when car is shifted to rear drive: "No parking assistance, please park unaided. Consult service center", followed by an image showing the car from rear with an exclamation symbol on rear - same as in rubber_ducky's post #228 on 05-27-2016, 09:56 PM.

Here is what I've done so far:
- replaced the REM (from no PINs to the one ending in 700) - it did not detect the CAFD corresponding to my car version (mfg. date March 2015) but trying couple other options it worked.
- installed 2 new sensors and two repainted.
- added option 507 to FA, then coded REM & HU_NAVENTRY.
- checked the correct PIN assignment on REM and made sure there are no short cuts. I used the retrofit kit and I had to force back the brown pin holder into its housing. Based on rubber_duckyís post Iíve ordered replacement pins (61130005197); ordered the bank as well in case gets destroyed while removing old PINs.

Q: Can anyone share Rheingold/ISTA to try to identify what errors were thrown? Is there anything else I should look for?
Thank you!
Appreciate 0
      11-18-2018, 11:55 PM   #300
jkwhar
Lieutenant
104
Rep
482
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (4)

Quote:
Originally Posted by AL20153 View Post
Thank all very much for sharing your experiences and for your guidance. I just finished the rear PDC install and I am getting an error on display when car is shifted to rear drive: "No parking assistance, please park unaided. Consult service center", followed by an image showing the car from rear with an exclamation symbol on rear - same as in rubber_ducky's post #228 on 05-27-2016, 09:56 PM.

Here is what I've done so far:
- replaced the REM (from no PINs to the one ending in 700) - it did not detect the CAFD corresponding to my car version (mfg. date March 2015) but trying couple other options it worked.
- installed 2 new sensors and two repainted.
- added option 507 to FA, then coded REM & HU_NAVENTRY.
- checked the correct PIN assignment on REM and made sure there are no short cuts. I used the retrofit kit and I had to force back the brown pin holder into its housing. Based on rubber_duckyís post Iíve ordered replacement pins (61130005197); ordered the bank as well in case gets destroyed while removing old PINs.

Q: Can anyone share Rheingold/ISTA to try to identify what errors were thrown? Is there anything else I should look for?
Thank you!
Go on this thread and ask for the download link. Its a VirtualBox virtual machine with ISTA preinstalled.

Let us know what error it finds.

https://f30.bimmerpost.com/forums/sh....php?t=1350558
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | 475 BSM | 2A5 18" | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers | Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | VLD | 2TB SAT | 508 | 3AG | 5DL | 6WB | 8TH
Appreciate 1
      11-28-2018, 07:28 AM   #301
AL20153
New Member
0
Rep
6
Posts

Drives: F30 2015-03
Join Date: Nov 2018
Location: Florida

iTrader: (0)

The relevant error to my issue was "803217 - Ultrasonic sensor error, rear center right, sensor fault: Final oscillation time of diaphragm...". Swapped sensors position and the error moved with the sensor. I've concluded that the wire connection is OK, and the sensor is faulty. it was a used one purchased on eBay and repainted. Since ISTA recommendation was to clean the sensor and make sure it installed correctly, I've sanded the paint and retried - same error. So definitively a bad sensor.

Ordered another one and hopefully this weekend will have it completed .

Other relevant notes: as mentioned above, I replaced the REM and I found same errors 030115, 030120, 030195 and 0301A0 same as described in post #138. Solution suggested by Chris@codemybimmer worked for me and now I have an error clean REM (except sensor's one) and rear windows working as designed.

Again, thank you all for supporting this forum!
Appreciate 0
      11-28-2018, 05:09 PM   #302
Jhnblckwood
Captain
96
Rep
708
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

For those having issues I had to flash the rem to an updated istep even tho the rem came from s car with pdc already working. Needs to b the same (or st least close) to the same istep level as the rest of the ecu's
Appreciate 0
      01-12-2019, 08:32 PM   #303
jklau_NYC
New Member
0
Rep
15
Posts

Drives: 328i xDrive m sport
Join Date: Jan 2018
Location: NYC

iTrader: (0)

Keeping this 4 year old post alive

Awesome 4 year old thread!!!

I have a 14' 428ix with Sports line. I'm looking to retrofit Rear PDC and just waiting for the retrofit that should be here by the first or second week next month.

I'm doing my research while i'm waiting. I picked up REM after confirming my REM doesn't have the 12 pin for rear PDC. I picked up this REM Part #61359866978. (https://www.ecstuning.com/.../61359866978/)

Would anyone happen to know if this REM pin out and wiring colors are the same as the 700 that has been mentioned in numerous posts?

Thanks in advance.
Appreciate 0
      01-13-2019, 02:35 AM   #304
jkwhar
Lieutenant
104
Rep
482
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (4)

Quote:
Originally Posted by jklau_NYC View Post
Awesome 4 year old thread!!!

I have a 14' 428ix with Sports line. I'm looking to retrofit Rear PDC and just waiting for the retrofit that should be here by the first or second week next month.

I'm doing my research while i'm waiting. I picked up REM after confirming my REM doesn't have the 12 pin for rear PDC. I picked up this REM Part #61359866978. (https://www.ecstuning.com/.../61359866978/)

Would anyone happen to know if this REM pin out and wiring colors are the same as the 700 that has been mentioned in numerous posts?

Thanks in advance.
As far as I know, as long as they have the pins needed for the PDC, it should be identical.
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | 475 BSM | 2A5 18" | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers | Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | VLD | 2TB SAT | 508 | 3AG | 5DL | 6WB | 8TH
Appreciate 0
      01-14-2019, 02:12 PM   #305
jklau_NYC
New Member
0
Rep
15
Posts

Drives: 328i xDrive m sport
Join Date: Jan 2018
Location: NYC

iTrader: (0)

Jkwher

Thank much!!! Can’t wait to get the wiring to start on this.
Appreciate 0
      09-16-2019, 02:32 AM   #306
dbozhilov
Registered
0
Rep
2
Posts

Drives: BMW f30
Join Date: Sep 2019
Location: Bulgaria

iTrader: (0)

Very useful post, everytning works great!
Appreciate 0
      09-18-2019, 07:52 AM   #307
dbozhilov
Registered
0
Rep
2
Posts

Drives: BMW f30
Join Date: Sep 2019
Location: Bulgaria

iTrader: (0)

There is only one thing - the images are blurred with a "Photobucket" label on them. How can I see their originals?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:15 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST