F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > xDrive All-Wheel Drive Discussions > XDelete- the answer to XDrive?
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      09-17-2020, 12:27 PM   #485
LYTSOUT
Private First Class
89
Rep
143
Posts

Drives: F80 M3 6MT
Join Date: Jan 2013
Location: Indianapolis, IN

iTrader: (0)

Quote:
Originally Posted by UGA99 View Post
Picking up my 6MT 335i xdrive friday and really thinking about the xdelete since I live in georgia. Anybody been running it for an extended period that can speak to their experience? My plan would be set it and be done.
I ran it for a couple months with zero issues. My N55 is FBO/Stage 2 6MT with DWS 06 in OEM sizes (255 rear). xDelete is certainly fun. When I completely disabled DSC, I could absolutely roast them in first and all the way through second...like...sitting in one spot with just tires spinning level of roasting. With DSC on, I was routinely breaking them loose, and DSC was having to intervene as I shifted from first to second even in normal driving/traffic at maybe 50% throttle.

But that's a car with somewhere around 400hp and 450 lb-ft. On those tires, there's just not enough grip for that level of power. So I turned it back to AWD just so I'd be able to hook up and put the power down better. If your car is bone stock and/or you have larger tires and/or summer only tires, you probably won't have the same problem. Bottom line is that I went back to AWD b/c of a problem with my power-to-grip ratio, not a problem with the xDelete app itself.
__________________
-PCA Instructor #201804533
-F80 M3 6MT, BM3 GTS tune, Thor GTS tune, otherwise stock
-My F80 Build Thread https://f80.bimmerpost.com/forums/sh....php?t=1757458
-F30 EWG N55 M Sport xDrive 6MT, FBO, BM3 Stage 2 93oct, Bilstein B16 Damptronics
-My F30 Build Thread https://f30.bimmerpost.com/forums/sh....php?t=1739248
Appreciate 2
      09-18-2020, 01:38 AM   #486
brigade24
Second Lieutenant
brigade24's Avatar
Canada
83
Rep
263
Posts

Drives: 2013 335 X-dive
Join Date: Jun 2018
Location: Canada

iTrader: (0)

The transfer case is a weak point on the F30 so i would run xdelete. Ive been running it for a while and its been great. Im thinking of getting rid of my transfer case since i don't drive the car much in the winter.
Appreciate 0
      11-19-2020, 01:44 AM   #487
Simon89
Second Lieutenant
Simon89's Avatar
United Kingdom
39
Rep
218
Posts

Drives: F30 330D XDrive
Join Date: Oct 2018
Location: Yorkshire

iTrader: (0)

Is there normally a black friday deal with the app?
__________________
13' F30 330D XDrive
Appreciate 0
      01-31-2021, 06:47 PM   #488
SERIK
Enlisted Member
2
Rep
32
Posts

Drives: 2014 335i xdrive AW
Join Date: Sep 2018
Location: Brooklyn, NY

iTrader: (0)

Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.

2/1/2021 update to anyone interested
Today, in the morning i have tried to manually calibrate clutch again, and calibration went through, cold car/not warmed up or anything. Also i have received a reply from xdelete as follows:
Quote"

Hi,

please take the car for a short drive to warm up. Then connect to xDelete and press on the 3 white dots in the top right corner and use "full stock flash". This should calibrate your VTG and the errors should disappear.

Best Regards,
Semin Biscevic
Product Genius xHP & xDelete
RBT TUNING GMBH – Home of xHP Flashtool & xDelete

End of quote"

Hope it helps anyone running into the same issue, because its one of those moment when i go "maybe i should have not touched it"
Attached Images
 
Appreciate 0
      01-31-2021, 06:51 PM   #489
antzcrashing
Colonel
antzcrashing's Avatar
United_States
1091
Rep
2,635
Posts

Drives: 2018 BMW 440i GC
Join Date: Sep 2007
Location: Eastern MA

iTrader: (1)

Garage List
Quote:
Originally Posted by SERIK View Post
Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.
From the error, it seems that you are missing a file (possibly a file that gets stored after you complete some process). Maybe you can check for that file and if its not there find the way to add it?
Appreciate 1
SERIK1.50

      01-31-2021, 07:09 PM   #490
SERIK
Enlisted Member
2
Rep
32
Posts

Drives: 2014 335i xdrive AW
Join Date: Sep 2018
Location: Brooklyn, NY

iTrader: (0)

Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.
From the error, it seems that you are missing a file (possibly a file that gets stored after you complete some process). Maybe you can check for that file and if its not there find the way to add it?
I am not sure where or what file to look for, i kind of understand that every time you flash it, it saves the previous settings i would assume i just dont understand the reason for it not being able to flash back. I tried simple xdelete on/off, flash back to stock, clutch just doesnt calibrate...
Appreciate 0
      01-31-2021, 07:44 PM   #491
antzcrashing
Colonel
antzcrashing's Avatar
United_States
1091
Rep
2,635
Posts

Drives: 2018 BMW 440i GC
Join Date: Sep 2007
Location: Eastern MA

iTrader: (1)

Garage List
Quote:
Originally Posted by SERIK View Post
Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.
From the error, it seems that you are missing a file (possibly a file that gets stored after you complete some process). Maybe you can check for that file and if its not there find the way to add it?
I am not sure where or what file to look for, i kind of understand that every time you flash it, it saves the previous settings i would assume i just dont understand the reason for it not being able to flash back. I tried simple xdelete on/off, flash back to stock, clutch just doesnt calibrate...
Found this on another site:


Originally Posted by JaxD View Post
So I purchased xdelete and am attempting to flash on a 2013 bmw 335i xdrive with a manual transmission using a galaxy s10+ with the obd2 to ethernet option and keep hitting an error on "preparing vgs" I've tried every solution under the sun with no luck, xdelete support has been slow getting back to me, anyone else been having this problem and found a workaround?
Make sure you have the latest version of the app installed and cycle your ignition on/off. Also, airplane mode.
Appreciate 1
SERIK1.50

      01-31-2021, 08:04 PM   #492
SERIK
Enlisted Member
2
Rep
32
Posts

Drives: 2014 335i xdrive AW
Join Date: Sep 2018
Location: Brooklyn, NY

iTrader: (0)

Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.
From the error, it seems that you are missing a file (possibly a file that gets stored after you complete some process). Maybe you can check for that file and if its not there find the way to add it?
I am not sure where or what file to look for, i kind of understand that every time you flash it, it saves the previous settings i would assume i just dont understand the reason for it not being able to flash back. I tried simple xdelete on/off, flash back to stock, clutch just doesnt calibrate...
Found this on another site:


Originally Posted by JaxD View Post
So I purchased xdelete and am attempting to flash on a 2013 bmw 335i xdrive with a manual transmission using a galaxy s10+ with the obd2 to ethernet option and keep hitting an error on "preparing vgs" I've tried every solution under the sun with no luck, xdelete support has been slow getting back to me, anyone else been having this problem and found a workaround?
Make sure you have the latest version of the app installed and cycle your ignition on/off. Also, airplane mode.
Thank you very much trying to help.
Yeah, ive seen this post i tried searching myself before writing here but my search came back negative regarding my issue. Ill try to flash again. I have even tried driving a car a bit thinking maybe clutch pack got stuck or something but still no luck. I even tried deleting and reinstalling the app-still no luck. And other phones it was a fresh install of the app no previous installation files because i thought maybe my phone has a bug or something but no, turns xdelete on/off, stock flash successfully but gives and error everytime that clutch pack is not calibrating. It suggests doing manual calibration by clicking on the three dots in right hand corner but it still fails to calibrate. You can hear clutch actuator clicking but it still fails
Appreciate 0
      01-31-2021, 08:34 PM   #493
antzcrashing
Colonel
antzcrashing's Avatar
United_States
1091
Rep
2,635
Posts

Drives: 2018 BMW 440i GC
Join Date: Sep 2007
Location: Eastern MA

iTrader: (1)

Garage List
Quote:
Originally Posted by SERIK View Post
Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.
From the error, it seems that you are missing a file (possibly a file that gets stored after you complete some process). Maybe you can check for that file and if its not there find the way to add it?
I am not sure where or what file to look for, i kind of understand that every time you flash it, it saves the previous settings i would assume i just dont understand the reason for it not being able to flash back. I tried simple xdelete on/off, flash back to stock, clutch just doesnt calibrate...
Found this on another site:


Originally Posted by JaxD View Post
So I purchased xdelete and am attempting to flash on a 2013 bmw 335i xdrive with a manual transmission using a galaxy s10+ with the obd2 to ethernet option and keep hitting an error on "preparing vgs" I've tried every solution under the sun with no luck, xdelete support has been slow getting back to me, anyone else been having this problem and found a workaround?
Make sure you have the latest version of the app installed and cycle your ignition on/off. Also, airplane mode.
Thank you very much trying to help.
Yeah, ive seen this post i tried searching myself before writing here but my search came back negative regarding my issue. Ill try to flash again. I have even tried driving a car a bit thinking maybe clutch pack got stuck or something but still no luck. I even tried deleting and reinstalling the app-still no luck. And other phones it was a fresh install of the app no previous installation files because i thought maybe my phone has a bug or something but no, turns xdelete on/off, stock flash successfully but gives and error everytime that clutch pack is not calibrating. It suggests doing manual calibration by clicking on the three dots in right hand corner but it still fails to calibrate. You can hear clutch actuator clicking but it still fails
Is it expecting you to depress the clutch and you arent? Or visa versa?

What about trying to get in touch with the tech support of the xdelete?
Appreciate 0
      01-31-2021, 08:38 PM   #494
SERIK
Enlisted Member
2
Rep
32
Posts

Drives: 2014 335i xdrive AW
Join Date: Sep 2018
Location: Brooklyn, NY

iTrader: (0)

Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Quote:
Originally Posted by antzcrashing View Post
Quote:
Originally Posted by SERIK View Post
Anybody getting any errors flashing with clutch not being able to calibrate and dsc error on dash afterwards? I have 2014 335ix 6mt have been running xdelete since its launch and recently with snow conditions tried to enable xdrive just to have error where clutch is not calibrating for whatever reason. I have tried flashing with 3 different phones ios and android using mhd adapter and wired with lan to obd cable with no luck. Dsc error on dash and error in xdelete app.
Wrote to xdelete developers yet to hear from their tech support.
From the error, it seems that you are missing a file (possibly a file that gets stored after you complete some process). Maybe you can check for that file and if its not there find the way to add it?
I am not sure where or what file to look for, i kind of understand that every time you flash it, it saves the previous settings i would assume i just dont understand the reason for it not being able to flash back. I tried simple xdelete on/off, flash back to stock, clutch just doesnt calibrate...
Found this on another site:


Originally Posted by JaxD View Post
So I purchased xdelete and am attempting to flash on a 2013 bmw 335i xdrive with a manual transmission using a galaxy s10+ with the obd2 to ethernet option and keep hitting an error on "preparing vgs" I've tried every solution under the sun with no luck, xdelete support has been slow getting back to me, anyone else been having this problem and found a workaround?
Make sure you have the latest version of the app installed and cycle your ignition on/off. Also, airplane mode.
Thank you very much trying to help.
Yeah, ive seen this post i tried searching myself before writing here but my search came back negative regarding my issue. Ill try to flash again. I have even tried driving a car a bit thinking maybe clutch pack got stuck or something but still no luck. I even tried deleting and reinstalling the app-still no luck. And other phones it was a fresh install of the app no previous installation files because i thought maybe my phone has a bug or something but no, turns xdelete on/off, stock flash successfully but gives and error everytime that clutch pack is not calibrating. It suggests doing manual calibration by clicking on the three dots in right hand corner but it still fails to calibrate. You can hear clutch actuator clicking but it still fails
Is it expecting you to depress the clutch and you arent? Or visa versa?

What about trying to get in touch with the tech support of the xdelete?
No, manual tranny clutch has nothing to do with transfer case clutch pack. I emailed tech support will post back their answer and if i get to resolve my issue.
Appreciate 1
      01-31-2021, 11:33 PM   #495
Grisha
Registered
0
Rep
1
Posts

Drives: BMW 328i F30
Join Date: Jan 2021
Location: NYC

iTrader: (0)

Quote:
Originally Posted by nickf30 View Post
Not able to connect with my 2014 (2014/02 build, SA) F30 335ix. Galaxy S10 / Latest version software 2.1.15 / Ethernet connected on static IP 169.254.250.250 per connection guide / seat belt on / ignition on. Maybe bootloader need to be updated? How can I do that?

"Connection failed! Sorry xdelete can not connect to your car. Please make sure the ignition is on."

I get the same issue, 2014 F30 328 xDrive. Followed all steps but still get the "Connection failed!". Did you ever figure out how to resolve this issue?
Appreciate 0
      02-07-2021, 09:32 PM   #496
Issa.M
New Member
2
Rep
8
Posts

Drives: BMW 335i xdrive (F30)
Join Date: Feb 2021
Location: North Jersey

iTrader: (0)

Quote:
Originally Posted by SteelBlue46 View Post
Was curious what you guys thought. it seems the guys behind the xHP flasher have an android app called XDelete that will successfully disable Xdrive without impairing any other functions of the vehicle. Currently it only supports E series vehicles the few reviews I see of it show that it works pretty good. They claim the F series cars will be supported some time soon. Is $150 worth it to disable XDrive to you? I can see this being useful for users who have an XDrive vehicle but no AWD dynos near them and the people who want to do the occasional burnout. Even after disabling you still will have the extra weight and XDrive suspension obviously so I dont know how this will help in the driveability department.

Edit: I forgot to mention the creator says that you can switch back and forth when ever you feel like it. Similar to flashing a tune.
The benefit to using x delete is to get the rwd experience and to potentially get a better mpg. The cost of the Xdelete is 150 but with the cable or wireless tool needed it'll be around $200.
Appreciate 1
      02-28-2021, 07:39 PM   #497
Wires
Colonel
Canada
764
Rep
2,951
Posts

Drives: 2016 340i xDrive
Join Date: Apr 2008
Location: Calgary

iTrader: (0)

Quote:
Originally Posted by Issa.M View Post
The benefit to using x delete is to get the rwd experience and to potentially get a better mpg. The cost of the Xdelete is 150 but with the cable or wireless tool needed it'll be around $200.
I'd highly doubt there are any mileage gains. They are is natively RWD biased unless there is wheel slip, and you still have to spin the front driveline even when disabled so there is always those rotational loses.

I watched a Kies motorsport video, and it was interesting how he had it, but typically disables it. He didn't seem overly sold on the idea.

All I know if I go to sport+, I can kick the rear out with ease on my AWD. Sure, burnouts are most likely off the table, but who actually does that on a regular basis, and why would you anyways? Tires and driveline cost too much to treat these cars like a POS beater.
Appreciate 0
      02-28-2021, 10:55 PM   #498
Onizukachan
Great Teacher
Onizukachan's Avatar
United_States
230
Rep
455
Posts

Drives: E46/3 M56 & F31d
Join Date: Aug 2015
Location: El Paso

iTrader: (0)

Quote:
Originally Posted by Issa.M View Post
The benefit to using x delete is to get the rwd experience and to potentially get a better mpg. The cost of the Xdelete is 150 but with the cable or wireless tool needed it'll be around $200.
Itís been proven to not positively affect power or mileage.
__________________
Ď15 F31d M-Sport with the usual OEM+ mods:
B Pillar Ambient lighting, LCI AC control & ambient lighted panel + LCI anthracite trim & vent,
F80 paddles + extendable merino armrest + trim cover w/ merino knee bolster, EU headlight switch, 340/330 brake upgrade.
Appreciate 0
      03-01-2021, 02:51 AM   #499
Skyhigh
Colonel
Skyhigh's Avatar
859
Rep
2,119
Posts

Drives: BMW F36
Join Date: Apr 2018
Location: Europe

iTrader: (0)

Of course it has. Isaac Newton did it some time before xDelete was released...
__________________
"Large increases in cost with questionable increases in performance can be tolerated only in cars and women."
Appreciate 0
      03-09-2021, 10:12 AM   #500
Insane435
Major
Insane435's Avatar
United_States
268
Rep
1,015
Posts

Drives: 435ix M Sport EWG
Join Date: Jul 2016
Location: Michigan

iTrader: (1)

Has anyone tried the AWD sport tune from x delete? Does it improve handling like they say?
__________________
2014 EBII 435ix - OEM Frotn pipe + SSS2 + VRSF Race, Evolution Racewerks Downpipe - Chargepipe - Intercooler, Bootmod3 7.1, xHP Stage 3 Trans Tune, NGK 97506's, AFE Dry Filter, KW V1, Forgestar F14 19s, Pilot 4S, M Performance Brakes, M Power Pads
2011 BSM 328ix
IG: @f32_rmacher
Appreciate 0
      03-09-2021, 07:48 PM   #501
chowser51
Colonel
chowser51's Avatar
United_States
1140
Rep
2,089
Posts

Drives: F33 430 and F39 X2 M35i
Join Date: Feb 2009
Location: Cleveland, OH

iTrader: (3)

Garage List
Mileage did not improve with xDelete for me. It did allow me to wear out my rear tires faster. That's about it.
Appreciate 3
      03-31-2021, 12:38 PM   #502
BMW335icjz
New Member
BMW335icjz's Avatar
9
Rep
21
Posts

Drives: 2013 bmw 335i xdrive
Join Date: Aug 2019
Location: ut

iTrader: (0)

I dont know bout the rest of you but personally I bought the XDelete for only one reason because honestly I love my AWD. Whiukle RWD is great its not good for off idle or from a dig. But I actually wanted to be able to adjust my front to rear bias or even just install the sport mode with a 80/20 split. So I buy the license and for some reason the F series does not get the sport, winter, or custom settings. I think that should be boldly presented before you buy it or they need to get on doing it and making it available. I messaged them and they simply said sorry nothing more. I mean I made sure it was compatible for my car so I assumed because I wasnt told that it was available. I dont need to spin my tires and the lil extra HP available in rwd is not very much
Appreciate 3
johnung1948.00

      03-31-2021, 02:39 PM   #503
chowser51
Colonel
chowser51's Avatar
United_States
1140
Rep
2,089
Posts

Drives: F33 430 and F39 X2 M35i
Join Date: Feb 2009
Location: Cleveland, OH

iTrader: (3)

Garage List
i knew it didn't come with those settings for F3x cars. It was pointed out early on.
Appreciate 0
      03-31-2021, 02:49 PM   #504
Skyhigh
Colonel
Skyhigh's Avatar
859
Rep
2,119
Posts

Drives: BMW F36
Join Date: Apr 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by BMW335icjz View Post
and the lil extra HP available in rwd is not very much
There is no "lil extra HP" through xDelete either Just FYI.
__________________
"Large increases in cost with questionable increases in performance can be tolerated only in cars and women."
Appreciate 0
      04-01-2021, 12:17 PM   #505
brigade24
Second Lieutenant
brigade24's Avatar
Canada
83
Rep
263
Posts

Drives: 2013 335 X-dive
Join Date: Jun 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by BMW335icjz View Post
I dont know bout the rest of you but personally I bought the XDelete for only one reason because honestly I love my AWD. Whiukle RWD is great its not good for off idle or from a dig. But I actually wanted to be able to adjust my front to rear bias or even just install the sport mode with a 80/20 split. So I buy the license and for some reason the F series does not get the sport, winter, or custom settings. I think that should be boldly presented before you buy it or they need to get on doing it and making it available. I messaged them and they simply said sorry nothing more. I mean I made sure it was compatible for my car so I assumed because I wasnt told that it was available. I dont need to spin my tires and the lil extra HP available in rwd is not very much
That was one of the reasons i purchased xdelete as well. I did some research and was told that the transfer case in the e90 chassis is more 'robust' that the one in the F30 and as such, the only option was in fact AWD or RWD... no option for a 30/70 or 20/80 split. I doubt its more robust but it could be more tuneable...the e90 transfer case does have a drain plug after all so that must be it LOL.

I installed xdelete last year it has worked well in rwd mode. i recently switched back to awd and now, its asking me to buy a licence to go back to rwd. weird.
Appreciate 0
      Today, 07:09 AM   #506
Laros1988
Registered
2
Rep
2
Posts

Drives: BMW F11
Join Date: Apr 2021
Location: Amsterdam

iTrader: (0)

So.. improved fuel economy: myth or truth? It has been mentioned many times here (and also asked about..). Is there someone that measured fuel consumption before and after turning it off via the app?
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:58 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST