F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > Regional Forums > CANADA > Post battery replacement issues with Auto Start/Stop and more
Vorsteiner
Post Reply
 
Thread Tools Search this Thread
      05-25-2018, 02:20 PM   #1
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Post battery replacement issues with Auto Start/Stop and more

TL;DR:2012 F30 335i battery changed, from old BMW Varta 900CCA/90Ah to Bosch 900CCA/90Ah, did the registration using Carly. Issue is that Auto Start/Stop and right mirror tilting down while reversing is not working.

I don't really have any issues or any lights/error messages prior to the battery swap, I just decided to be proactive about maintenance and so I had it done last night. The guy installed a Bosch 900CCA/90Ah battery and did the registration using Carly. As normal, settings were reset and I just had to restore them all back one by one. However, after driving the car from his place, I immediately noticed that the auto start/stop wasn't restored back even though the switch for ASS is set to default (enabled). When I got to the office parking lot and did a reverse parking, I noticed too that my right side mirror didn't tilt down. Those are the 2 things that I have observed so far that was different after the battery swap and I was wondering if anyone here who has experienced similar behavior what did you do to restore/fix it?

P.S. A little side topic though, what's the general opinion or feedback from owners regarding the ASS? Is it really better for fuel economy? With the engine starting/stopping more when this feature is on, does it have a tendency to wear out the engine/parts faster? I would like to hear your thoughts, maybe it's just better for me to leave things be.

Thank you.
Appreciate 0
      05-25-2018, 03:23 PM   #2
TheUltimateDrivingManiac
Freude am Fahren.
Canada
144
Rep
390
Posts

Drives: F15 X5 xDrive35i
Join Date: Jul 2009
Location: Toronto, Ontario

iTrader: (0)

Garage List
Is your mirror selector switch on the door in the left position?
__________________
Freude am Fahren.
Appreciate 0
      05-25-2018, 03:44 PM   #3
TheUltimateDrivingManiac
Freude am Fahren.
Canada
144
Rep
390
Posts

Drives: F15 X5 xDrive35i
Join Date: Jul 2009
Location: Toronto, Ontario

iTrader: (0)

Garage List
Quote:
Originally Posted by TPYD View Post
As normal, settings were reset and I just had to restore them all back one by one.
I don't think it's normal.
__________________
Freude am Fahren.
Appreciate 0
      05-25-2018, 03:55 PM   #4
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by TheUltimateDrivingManiac View Post
Is your mirror selector switch on the door in the left position?
I am unsure at the moment and I will check. Does that selector affect the right mirror tilting down during reverse?
Appreciate 0
      05-25-2018, 04:03 PM   #5
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by TheUltimateDrivingManiac View Post
I don't think it's normal.
When the guy did the swap he advised me that the time will be reset and thus I have to just set it back. All else, I figured a few settings here and there would get affected hence I deemed it to be normal. If not so, may I ask what was your experience?
Appreciate 0
      05-25-2018, 06:03 PM   #6
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by TheUltimateDrivingManiac View Post
Is your mirror selector switch on the door in the left position?
Just tried this and you are right. Selector had to be on the left for the mirror to tilt down during reversing. Thank you! All thatís left is the auto start/stop issue.
Appreciate 0
      05-27-2018, 08:01 AM   #7
larrylam646
Private First Class
larrylam646's Avatar
Canada
65
Rep
112
Posts

Drives: 2014 435i xDrive
Join Date: Jul 2015
Location: Ottawa

iTrader: (1)

Quote:
Originally Posted by TPYD View Post
Just tried this and you are right. Selector had to be on the left for the mirror to tilt down during reversing. Thank you! All that’s left is the auto start/stop issue.
Hi TPYD,

By now, Auto Start Stop may be working for you. In my experience, ASS takes some time to become functional after the battery is disconnected or errors cleared (when using ISTA+). Give it 15-20kms.

Edit - text extracted from ISTA+

"Power management and battery exchange
For vehicles with automatic engine start-stop function, an AGM battery must be installed and after a battery exchange, it must be registered with the service function < Register battery exchange> so that the automatic engine start-stop function can function properly.

When a battery is exchanged, a battery is disconnected or after the engine control unit is programmed, the reference data for the state of charge and battery condition may be lost. These are only available again after an open-circuit voltage measurement of approx. 6 hours (e.g. rest phase overnight) during which the vehicle may not be woken up. In this training period, the ASSF function is not active (switch-off inhibitor = state of charge not plausible). The customer is to be notified of this when the vehicle is handed over. The automatic engine start-stop function switches back automatically to active as soon as the necessary routines have been completed successfully."



Larry
__________________
2014 435i xDrive M-Sport, Executive, Premium, Active LED, M Performance (Red) brake kit, KW V2, M Performance Carbon Fiber & Alcantara Interior Trim, M3/M4 MP V2 Steering wheel, MPPK, SLI (FSC 7E), 437M, HJS Catted Downpipe, Wagner EVO2 Competition, TPMS/RDC, AFE Momentum Pro 5R, NBT EVO ID6-light (US), ATM w/ Professional ConnectedDrive, BM3 Stage 2 91 OTS, Euro LCI taillights, LCI 6WB, LCI HVAC/IHKA3, PMA Gen2, LCI CID Touchscreen

Last edited by larrylam646; 05-27-2018 at 08:06 AM. Reason: Extract from ISTA+
Appreciate 1
obert432.50

      05-28-2018, 11:15 AM   #8
TheUltimateDrivingManiac
Freude am Fahren.
Canada
144
Rep
390
Posts

Drives: F15 X5 xDrive35i
Join Date: Jul 2009
Location: Toronto, Ontario

iTrader: (0)

Garage List
Quote:
Originally Posted by TPYD View Post
When the guy did the swap he advised me that the time will be reset and thus I have to just set it back. All else, I figured a few settings here and there would get affected hence I deemed it to be normal. If not so, may I ask what was your experience?
Time and few other things are normal, I thought you've lost all your settings.
__________________
Freude am Fahren.
Appreciate 0
      05-28-2018, 02:34 PM   #9
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by larrylam646 View Post

By now, Auto Start Stop may be working for you. In my experience, ASS takes some time to become functional after the battery is disconnected or errors cleared (when using ISTA+). Give it 15-20kms.

Edit - text extracted from ISTA+

"Power management and battery exchange
For vehicles with automatic engine start-stop function, an AGM battery must be installed and after a battery exchange, it must be registered with the service function < Register battery exchange> so that the automatic engine start-stop function can function properly.

When a battery is exchanged, a battery is disconnected or after the engine control unit is programmed, the reference data for the state of charge and battery condition may be lost. These are only available again after an open-circuit voltage measurement of approx. 6 hours (e.g. rest phase overnight) during which the vehicle may not be woken up. In this training period, the ASSF function is not active (switch-off inhibitor = state of charge not plausible). The customer is to be notified of this when the vehicle is handed over. The automatic engine start-stop function switches back automatically to active as soon as the necessary routines have been completed successfully."
Dumb questions here, does it have to be AGM battery for the ASS to work? The bosch battery installed is a lead-acid.

The guy used Carly to register the Bosch Battery. Is this process similar or considered the same as using an ISTA+?

I have driven the car already more than 300KM since Thursday, May 24 and the ASSF has not returned since I drove it last Saturday. My car is with the dealer starting today for a pending warranty issue and I've asked them to look into the ASSF. Can anyone confirm if it's a quick "re-coding" to possibly get that feature restored? All else is working as before, just except that feature.

Last edited by TPYD; 05-28-2018 at 03:36 PM.
Appreciate 0
      05-28-2018, 02:38 PM   #10
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by TheUltimateDrivingManiac View Post
Time and few other things are normal, I thought you've lost all your settings.
Ok thank you and that is good to know.
Appreciate 0
      05-28-2018, 03:07 PM   #11
Sam!
Private
40
Rep
81
Posts

Drives: 2014 328xi Touring
Join Date: Mar 2017
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by TPYD View Post
Dumb questions here, is there anyway for me to easily determine if the Bosch Battery I used to replace my old one is an AGM? The top label had the exact same specs as the old one, but both batteries have no mention/label that it is an AGM battery.

The guy used Carly to register the Bosch Battery. Is this process similar or considered the same as using an ISTA+?

I have driven the car already more than 300KM since Thursday, May 24 and the ASSF has not returned since I drove it last Saturday. My car is with the dealer starting today for a pending warranty issue and I've asked them to look into the ASSF. Can anyone confirm if it's a quick "re-coding" to possibly get that feature restored? All else is working as before, just except that feature.
Dumb question here as well, but did you press the ASS button (heh) to turn it back on? In the process, he may have coded in retain last setting for start/stop and you currently have it as off. Also, does it work in ECO mode which forces it to turn on?
Appreciate 0
      05-28-2018, 03:44 PM   #12
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by Sam! View Post
Dumb question here as well, but did you press the ASS button (heh) to turn it back on? In the process, he may have coded in retain last setting for start/stop and you currently have it as off. Also, does it work in ECO mode which forces it to turn on?
I would love to press that ASS button LOL! Kidding aside, by default my car has the ASS to enable (with the light off) and I've always had it in this setting - never changed it. After the battery swap, the ASS LED indicator is always off once the engine starts, hence it is enabled like before, but sadly it still does not work. Going eco mode does not force the ASS to be restored as well. My guy had told me just now that the new battery is lead acid. Could that have affected it?

Last edited by TPYD; 05-28-2018 at 03:49 PM.
Appreciate 0
      05-28-2018, 04:05 PM   #13
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

I want to ask you guys though, am I better off with that feature disabled anyway? After some reading regarding feedback with ASS, seems like more drivers prefer to have this feature off/removed as the cost to maintain and possible wear and tear to the engine was not worth it apparently. I've driven CITY since I got the car in 2013 to 1 month ago. But from that point on I'll be driving more on the HWY.
Appreciate 0
      05-28-2018, 05:24 PM   #14
Sam!
Private
40
Rep
81
Posts

Drives: 2014 328xi Touring
Join Date: Mar 2017
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by TPYD View Post
I would love to press that ASS button LOL! Kidding aside, by default my car has the ASS to enable (with the light off) and I've always had it in this setting - never changed it. After the battery swap, the ASS LED indicator is always off once the engine starts, hence it is enabled like before, but sadly it still does not work. Going eco mode does not force the ASS to be restored as well. My guy had told me just now that the new battery is lead acid. Could that have affected it?
AGM is a type of lead acid battery, yes. You probably need to find a new guy if that's his response to your problem.
Appreciate 0
      05-29-2018, 09:12 AM   #15
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by Sam! View Post
AGM is a type of lead acid battery, yes. You probably need to find a new guy if that's his response to your problem.
Thank you. My car is with the dealer right now and fixing the ASS is covered under warranty so let's see what happens.
Appreciate 0
      05-29-2018, 01:49 PM   #16
TPYD
Private
TPYD's Avatar
Canada
0
Rep
95
Posts

Drives: 2012 F30 335i
Join Date: Feb 2013
Location: Mississauga

iTrader: (0)

Turns out that an AGM battery is indeed required per my dealer and as shared by Larry to be able to restore the Auto Start/Stop features. I went ahead and gave the green light for the dealer to install and register that new battery.

Last edited by TPYD; 05-29-2018 at 03:50 PM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:41 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST