F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Help: Launch control not working
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      05-18-2020, 08:08 PM   #1
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Help: Launch control not working

Hi. I have a 2020 440i gc M sport and I canít get launch control to work. had since January. Iíve done the steps as written, Driven the 10 miles and waited for the engine to get warm. DSC off, Sport +, Shifter to S, brake All the way down, gas down to floor quickly pushing the resistance button. The car hunkers down, wheels donít spin, but rpm only goes up to about 2500 and stays there, rises to about 2800. No flag comes up, and when Iíve ďlaunchedĒ that way the wheels donít stop burning out until about 25mph. Anyone know what to do?

Help?

Last edited by Bimba_440i; 05-24-2020 at 05:43 PM..
Appreciate 0
      05-18-2020, 08:57 PM   #2
pongkin
Second Lieutenant
81
Rep
279
Posts

Drives: f30
Join Date: Jul 2017
Location: mia

iTrader: (1)

if its the same as previous years
sport +
shifter to S
brake pressed
accelerator pedal to the floor


dont mess with the dsc
Appreciate 0
      05-20-2020, 10:41 AM   #3
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by pongkin View Post
if its the same as previous years
sport +
shifter to S
brake pressed
accelerator pedal to the floor


dont mess with the dsc
Hi, thank for responding. I tried again with no luck.
Appreciate 0
      05-21-2020, 01:42 AM   #4
f30b58pwr
Private
52
Rep
85
Posts

Drives: 16' 340i, 18' M3
Join Date: Mar 2020
Location: Chicago, USA

iTrader: (0)

Do you tend to launch your car often? I believe there is a lifetime "limit" to how many time you can launch the car.
Appreciate 0
      05-24-2020, 03:33 AM   #5
chr
Private
Romania
8
Rep
55
Posts

Drives: 2014 F31 320d xDrive
Join Date: Sep 2018
Location: Timis, Romania

iTrader: (0)

You need a minimum 10 km (6 miles) ride to heat the engine.
Then completely stop the car and shift to P.
To start LC, as already said:
- sport+
- brake pedal depressed with left foot
- shift to D, then move to left (S)
- accelerator to the floor
- now you should see the LC flag and can start by quickly release the brake
Appreciate 0
      05-24-2020, 05:41 PM   #6
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by chr View Post
You need a minimum 10 km (6 miles) ride to heat the engine.
Then completely stop the car and shift to P.
To start LC, as already said:
- sport+
- brake pedal depressed with left foot
- shift to D, then move to left (S)
- accelerator to the floor
- now you should see the LC flag and can start by quickly release the brake
Guys. Iíve done this all. No flag comes up. Tried it again last night after 50 miles of driving.
Also; itís never launched before. IĎve never gotten it to work.
Appreciate 0
      05-24-2020, 05:44 PM   #7
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by f30b58pwr View Post
Do you tend to launch your car often? I believe there is a lifetime "limit" to how many time you can launch the car.
Never launched before. Itís a 2020
Appreciate 0
      05-25-2020, 01:58 PM   #8
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1514
Rep
2,879
Posts

Drives: Ď20 330i,Ď16 X3,Ď18 SQ5,Ď17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

When you put it to sport+, does the traction also change? In the G20, in sport+, traction is the same. We have to click (not long press) the traction button to show traction optimised (and not DSC OFF when long pressed, wherein LC won’t work). It might be different in the F30. Also, the car has to have done around 1200 or so miles before LC can be activated. I’m not very sure about that though.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      05-25-2020, 09:26 PM   #9
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by VipinLJ View Post
When you put it to sport+, does the traction also change? In the G20, in sport+, traction is the same. We have to click (not long press) the traction button to show traction optimised (and not DSC OFF when long pressed, wherein LC wonít work). It might be different in the F30. Also, the car has to have done around 1200 or so miles before LC can be activated. Iím not very sure about that though.
Thanks but Iíve got about 9k miles on my f36 since January. Vegas runs. So I do 10 miles in sports +. Sport +, shifter left, brake down to floor and gas down to floor. Canít get it to work.
Appreciate 0
      05-26-2020, 12:09 AM   #10
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1514
Rep
2,879
Posts

Drives: Ď20 330i,Ď16 X3,Ď18 SQ5,Ď17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Bimba_440i View Post
Thanks but Iíve got about 9k miles on my f36 since January. Vegas runs. So I do 10 miles in sports +. Sport +, shifter left, brake down to floor and gas down to floor. Canít get it to work.
Weird. That should get it to work. Iím guessing youíre pushing the throttle all the way down past the kick down button right?
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      05-27-2020, 07:21 AM   #11
chr
Private
Romania
8
Rep
55
Posts

Drives: 2014 F31 320d xDrive
Join Date: Sep 2018
Location: Timis, Romania

iTrader: (0)

Also the brake pedal has to be pushed really hard with left foot, otherwise LC will not work.
Appreciate 0
      05-27-2020, 02:19 PM   #12
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by VipinLJ View Post
Quote:
Originally Posted by Bimba_440i View Post
Thanks but I've got about 9k miles on my f36 since January. Vegas runs. So I do 10 miles in sports +. Sport +, shifter left, brake down to floor and gas down to floor. Can't get it to work.
Weird. That should get it to work. I'm guessing you're pushing the throttle all the way down past the kick down button right?
Guys. It really doesn't work.
This is last night. To make it clear what going on.
(the button on the floor) is the resistance point.

6 mile drive to warm up car.
Sport +
Shifter Left
Brake down to floor with left foot
Gas pedal down to floor, pushing the button on the floor with right foot.
Tried twice. No flag.

I went into bimmercode expert options under "Electronic Transmission Control" to 3000 Aplikation, LC, and it was already coded on "on".

Coded if off
Drove 8 miles.
Sport +
Shifter Left
Brake down to floor with left foot
Gas pedal down to floor, pushing the button on the floor with right foot.
Tried twice. No dice.

Then coded it back on.
Then drove 10 miles.
Sport +
Shifter Left
Brake down to floor with left foot
Gas pedal down to floor, pushing the button on the floor with right foot.
Tried thrice.
Still no flag.
Appreciate 0
      05-27-2020, 02:40 PM   #13
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1514
Rep
2,879
Posts

Drives: Ď20 330i,Ď16 X3,Ď18 SQ5,Ď17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Bimba_440i View Post
Guys. It really doesn't work.
This is last night. To make it clear what going on.
(the button on the floor) is the resistance point.

6 mile drive to warm up car.
Sport +
Shifter Left
Brake down to floor with left foot
Gas pedal down to floor, pushing the button on the floor with right foot.
Tried twice. No flag.

I went into bimmercode expert options under "Electronic Transmission Control" to 3000 Aplikation, LC, and it was already coded on "on".

Coded if off
Drove 8 miles.
Sport +
Shifter Left
Brake down to floor with left foot
Gas pedal down to floor, pushing the button on the floor with right foot.
Tried twice. No dice.

Then coded it back on.
Then drove 10 miles.
Sport +
Shifter Left
Brake down to floor with left foot
Gas pedal down to floor, pushing the button on the floor with right foot.
Tried thrice.
Still no flag.
Does the on-board manual say how launch control works on your car? If it says how to activate it and that the checkered flag should be visible, you can ask your BMW genius why it isnít working on your car?
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      05-28-2020, 04:35 AM   #14
Steakpizza
Second Lieutenant
103
Rep
283
Posts

Drives: 320i
Join Date: May 2018
Location: Philadelphia

iTrader: (0)

Are you pressing the DSC button at all? I think it'd be useful to maybe take a vid of the BimmerCode settings. This is weird
Appreciate 0
      05-28-2020, 06:43 AM   #15
fantanas
First Lieutenant
United Kingdom
75
Rep
318
Posts

Drives: F33 435d
Join Date: Mar 2019
Location: London

iTrader: (0)

Did you car come with LC from factory? I think if it was coded afterwards in some cars it won't show the flag but it will work. What year and model is your car? Do you have sport gearbox (maybe you need to code that as well?)?

EDIT: I just saw that it is a 2020 40i M Sport. It should work then. When you do it does it feel like LC is working and you just not get the flag?
Appreciate 0
      05-28-2020, 02:27 PM   #16
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by fantanas View Post
Did you car come with LC from factory? I think if it was coded afterwards in some cars it won't show the flag but it will work. What year and model is your car? Do you have sport gearbox (maybe you need to code that as well?)?

EDIT: I just saw that it is a 2020 40i M Sport. It should work then. When you do it does it feel like LC is working and you just not get the flag?
No flag for me. I went cruising yesterday through the canyons and halfway through A friend of mine with a 2018 440i gc tried and also no flag.
Appreciate 0
      05-28-2020, 02:29 PM   #17
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Quote:
Originally Posted by Steakpizza View Post
Are you pressing the DSC button at all? I think it'd be useful to maybe take a vid of the BimmerCode settings. This is weird
I've tried it undocumented in my rant previously however I was unsuccessful with both sport and dsc set to TRACTION
As well as Sport+ holding the dsc

If you do Sport+ and press dsc it drops to sport.
Appreciate 0
      05-28-2020, 03:34 PM   #18
Steakpizza
Second Lieutenant
103
Rep
283
Posts

Drives: 320i
Join Date: May 2018
Location: Philadelphia

iTrader: (0)

Quote:
Originally Posted by Bimba_440i View Post
Quote:
Originally Posted by Steakpizza View Post
Are you pressing the DSC button at all? I think it'd be useful to maybe take a vid of the BimmerCode settings. This is weird
I've tried it undocumented in my rant previously however I was unsuccessful with both sport and dsc set to TRACTION
As well as Sport+ holding the dsc

If you do Sport+ and press dsc it drops to sport.
I would honestly take a vid or just take the car back in to BMW and ask what the deal is lol. The only thing I could think of is that they upped the miles that are needed to start LC.
Appreciate 0
      06-04-2020, 07:31 PM   #19
Bimba_440i
Private First Class
12
Rep
129
Posts

Drives: 2020 BMW 440i GC Msport
Join Date: Feb 2020
Location: California

iTrader: (1)

Thanks everyone.
I took it to bmw. No one was able to get the flag up. Bmw ran the codes and recoded- still didn't work. Taking it to get installed on Monday. Just wanted to thank you all for your efforts. I really appreciate the time y'all took out of your day to help me.
Appreciate 1
VipinLJ1513.50
Post Reply

Bookmarks

Tags
440i, f36, launch control

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:33 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST