F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > DIY Complete Guide to full LED bulb swap for the F30s with halogen headlights
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      12-04-2018, 05:35 PM   #111
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

I didn't have any problems fitting the drivers in the housings, but with the lows I cut the top off the housings to get access, my post explains it.
Appreciate 1
      12-06-2018, 02:05 PM   #112
Hammer Werke
Private First Class
United_States
89
Rep
196
Posts

Drives: '15 328d Touring
Join Date: Jan 2018
Location: LA

iTrader: (0)

I tried coding it another time. I switched some items back to normal, coded it, and then coded it back to LED etc. Knock on wood but I haven't noticed it flickering again.

I'll be keeping my eye on the market as new bulbs come and go monthly. I want some fanless legit Lumileds. We'll see.
Appreciate 0
      12-30-2018, 11:15 AM   #113
Hammer Werke
Private First Class
United_States
89
Rep
196
Posts

Drives: '15 328d Touring
Join Date: Jan 2018
Location: LA

iTrader: (0)

Question about the front signal light bulb change. I changed my bulbs to the orange Osram Leds and they look great but now I get a lighting malfunction error when I start up.

Which bimmercode things do I change?

Sidemarkers? Indicator?

Little confused on this. I think I changed both to LED (checks off) but maybe one of them is causing the error for me....Thanks for the help.
Appreciate 0
      12-30-2018, 03:13 PM   #114
crimson_king
Private
United_States
26
Rep
55
Posts

Drives: 2014 328i F30 Manual Trans
Join Date: Feb 2018
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Hammer Werke View Post
Question about the front signal light bulb change. I changed my bulbs to the orange Osram Leds and they look great but now I get a lighting malfunction error when I start up.

Which bimmercode things do I change?

Sidemarkers? Indicator?

Little confused on this. I think I changed both to LED (checks off) but maybe one of them is causing the error for me....Thanks for the help.
Ok, go back and code sidemarkers back to how they were and only change the front indicators as these should be for the signal lights
Appreciate 0
      12-30-2018, 04:10 PM   #115
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Quote:
Originally Posted by Hammer Werke View Post
Which bimmercode things do I change?
I can only say what I changed using E-Sys:

Code front turn signals for LED-Bulb replacing halogen bulbs:

FEM 3061FRA_V_L_KALTUEBERWACHUNG set to: nicht_aktiv

3061FRA_V_L_WARMUEBERWACHUNG set to: nicht_aktiv

3061FRA_V_L_IS_LED set to: aktiv

3061FRA_V_R_KALTUEBERWACHUNG set to: nicht_aktiv

3061FRA_V_R_WARMUEBERWACHUNG set to: nicht_aktiv

3061FRA_V_R_IS_LED set to: aktiv
Appreciate 0
      12-31-2018, 03:30 AM   #116
crimson_king
Private
United_States
26
Rep
55
Posts

Drives: 2014 328i F30 Manual Trans
Join Date: Feb 2018
Location: Socal

iTrader: (0)

Here you go

Appreciate 0
      01-03-2019, 08:50 PM   #117
PKR
Enlisted Member
United_States
12
Rep
37
Posts

Drives: 2014 F31
Join Date: Nov 2009
Location: NE Florida

iTrader: (1)

Is there another 6000k (not 6500) alternative to the RoadSun H7 that was originally posted?
Appreciate 0
      01-03-2019, 09:00 PM   #118
crimson_king
Private
United_States
26
Rep
55
Posts

Drives: 2014 328i F30 Manual Trans
Join Date: Feb 2018
Location: Socal

iTrader: (0)

Quote:
Originally Posted by PKR View Post
Is there another 6000k (not 6500) alternative to the RoadSun H7 that was originally posted?
There is, but recently I have been getting the headlight malfunction error so I am thinking of going fanless. Maybe trying the beamtech ones since they are fanless and pretty cheap:

https://rover.ebay.com/rover/0/0/0?m...2F132735805038
Appreciate 0
      01-05-2019, 01:33 AM   #119
JonF3015
Registered
0
Rep
4
Posts

Drives: 2015 F30 328i
Join Date: Nov 2018
Location: Scottsdale

iTrader: (0)

Amazing job on this. Has anyone used DEPO ANGEL EYES HALO RINGS PROJECTOR HEADLIGHTS doing this swap? I'm thinking about doing all this here real soon.

Jon
Appreciate 0
      01-05-2019, 09:09 AM   #120
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Quote:
Originally Posted by crimson_king View Post
There is, but recently I have been getting the headlight malfunction error so I am thinking of going fanless. Maybe trying the beamtech ones since they are fanless and pretty cheap:
I can't see the fan causing an error. I can see the fan failing, causing the bulb to burn out. That, and the potential for fan noise, is why I didn't use fan cooled bulbs. I did get an error message a few weeks ago, but it cleared immediately and hasn't come back again. I haven't bothered to use my OBD diagnostic to see which bulb caused the message. I'll do that when I do my spring upkeep and detailing chores.
Appreciate 0
      01-05-2019, 02:41 PM   #121
crimson_king
Private
United_States
26
Rep
55
Posts

Drives: 2014 328i F30 Manual Trans
Join Date: Feb 2018
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
I can't see the fan causing an error. I can see the fan failing, causing the bulb to burn out. That, and the potential for fan noise, is why I didn't use fan cooled bulbs. I did get an error message a few weeks ago, but it cleared immediately and hasn't come back again. I haven't bothered to use my OBD diagnostic to see which bulb caused the message. I'll do that when I do my spring upkeep and detailing chores.
Interesting, I was getting the error like every five mins while driving with the headlights on so I went back to halogen low best only for now
Appreciate 0
      01-05-2019, 03:25 PM   #122
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

I got a generic 'lighting malfunction' message on my iDrive screen, saying to check out the lighting system, not a specific bulb. It was at night and my headlights were operating normally. I acknowledged the message by pressing the controller, it went away and it hasn't come back on since then.
Appreciate 0
      01-05-2019, 03:30 PM   #123
crimson_king
Private
United_States
26
Rep
55
Posts

Drives: 2014 328i F30 Manual Trans
Join Date: Feb 2018
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
I got a generic 'lighting malfunction' message on my iDrive screen, saying to check out the lighting system, not a specific bulb. It was at night and my headlights were operating normally. I acknowledged the message by pressing the controller, it went away and it hasn't come back on since then.
Hmm that's exactly the same message I was getting, but it was happening very frequently when the headlights were on and my headlights would flash when the message popped up so I just decided to go back to halogens for now
Appreciate 0
      01-05-2019, 04:22 PM   #124
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

I just checked my lights and one of the front turn signals is out. Odd that the warning only flashed the one time. Whatever is with your lights I can't say. Do you have drive ballasts? Mine do, and they never threw a warning even before I coded out the warm and cold checks.
Appreciate 0
      01-05-2019, 05:05 PM   #125
crimson_king
Private
United_States
26
Rep
55
Posts

Drives: 2014 328i F30 Manual Trans
Join Date: Feb 2018
Location: Socal

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
I just checked my lights and one of the front turn signals is out. Odd that the warning only flashed the one time. Whatever is with your lights I can't say. Do you have drive ballasts? Mine do, and they never threw a warning even before I coded out the warm and cold checks.
What exactly are the drive ballasts?
Appreciate 0
      01-05-2019, 09:10 PM   #126
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

If you have to ask I guess you don't have them. Have a look at this link to the bulbs I used:
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
Appreciate 0
      01-10-2019, 11:10 AM   #127
PKR
Enlisted Member
United_States
12
Rep
37
Posts

Drives: 2014 F31
Join Date: Nov 2009
Location: NE Florida

iTrader: (1)

Confused

I'm confused Billfitz ... abit earlier you wrote that you don't use fan cooled bulbs ... but the ones you point to are fan cooled.
Appreciate 0
      01-10-2019, 01:17 PM   #128
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Those are not fan cooled, heat sinks only.
Appreciate 0
      01-10-2019, 01:34 PM   #129
PKR
Enlisted Member
United_States
12
Rep
37
Posts

Drives: 2014 F31
Join Date: Nov 2009
Location: NE Florida

iTrader: (1)

OK, got it. Thanks

... and the drive ballasts are included .... or ?
Appreciate 0
      01-10-2019, 01:45 PM   #130
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

They are on the linked bulbs. Look at the pictures of what's included.
Scrolling down the page I see the description mentions a fan, but there is none.
Appreciate 0
      01-11-2019, 12:24 PM   #131
testcodes
New Member
2
Rep
21
Posts

Drives: BMW 328i
Join Date: Jul 2018
Location: PA

iTrader: (0)

I replaced mine a while back using the beamtech ones:
https://www.ebay.com/itm/2xH11-H7-H1...72.m2749.l2649


my cutoff is horrible though, kinda looks like the one from @hakisalapaki
https://f30.bimmerpost.com/forums/sh...1&postcount=54

mine's a bit worse, the left side is aimed way lower than the right so the cutoff is also uneven. the left is already adjusted to the highest it would go, while the right still has space to move up/down


I'm going to try to see if I can fix this this weekend. Any tips on what I should do? I guess some ideas:
1. I've read the headlights will not adjust up/down if its too far left/right. I'll try adjusting left/right first then adjust up/down
2. Does the way the bulb sits in the housing affect how high it aims? I noticed the bulb on my left is mounted like a millimeter or two higher than the right (comparing against the cutoff metal thingy)
3. Hopefully I wouldn't have to, but I guess I can try switching left and right bulbs
4. Finally last resort would be to buy a new pair of bulbs
Appreciate 0
      01-11-2019, 12:49 PM   #132
Billfitz
Major General
Billfitz's Avatar
United_States
2950
Rep
7,189
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Quote:
Originally Posted by testcodes View Post
Does the way the bulb sits in the housing affect how high it aims?
It does. The H7 mounting clips are very flimsy, as the halogen bulbs weigh practically nothing. The LEDs are heavy, due to the heatsinks. I used high temp RTV to firmly secure the LEDs. With the low beams that made it necessary to cut access to reach the mounts, as noted in my LED thread.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:54 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST