F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > Headlights wont turn off when using switch
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      04-05-2020, 07:51 PM   #1
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

Headlights wont turn off when using switch

Kind of confused here, tried searching but cant seem to find anyone with the same issue. They're all related to auto mode.

2017 340i RWD, adaptive LED headlights

Anyways, I always use the switch for my headlights / DRLs and never use the auto mode.
For some reason, even in the off position, my headlights and tail lights are on now. The switch doesn't do anything anymore no matter what position it's in. I checked all the fuses and all seem to be good. Is there a relay somewhere that could be bad?

Anyone have any other suggestions or know what the problem may be?
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
      04-05-2020, 08:00 PM   #2
chowser51
Colonel
chowser51's Avatar
United_States
1323
Rep
2,335
Posts

Drives: F33 430 and F39 M35i
Join Date: Feb 2009
Location: Cleveland, OH

iTrader: (3)

Garage List
Did the switch go bad? Pull the switch out and look at the insides. Maybe it's worn and stuck in the auto position?

Dang it, I left my old switch at work when I replaced mine with a EU spec one. Can't show you pics

Basically take it out from the dash, disconnect the harness and pull the knob off and see if the knob connection is worn
Appreciate 0
      04-06-2020, 06:42 AM   #3
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

Quote:
Originally Posted by chowser51 View Post
Did the switch go bad? Pull the switch out and look at the insides. Maybe it's worn and stuck in the auto position?

Dang it, I left my old switch at work when I replaced mine with a EU spec one. Can't show you pics

Basically take it out from the dash, disconnect the harness and pull the knob off and see if the knob connection is worn
I'll give that a look later on today, although it hasn't been in auto mode for a long time to get stuck there in the first place
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
      04-06-2020, 07:32 AM   #4
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5638
Rep
11,905
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

It's possible that the fault is in the FEM. The switch has no direct connection to the lights, it just tells the FEM what to do with them.
Appreciate 0
      04-06-2020, 08:33 AM   #5
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

Quote:
Originally Posted by Billfitz View Post
It's possible that the fault is in the FEM. The switch has no direct connection to the lights, it just tells the FEM what to do with them.
Is there a way to self diagnose that or scan it?
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
      04-06-2020, 09:30 AM   #6
im_an_alien
Captain
im_an_alien's Avatar
504
Rep
760
Posts

Drives: 2016 340i
Join Date: Jul 2019
Location: Tha south

iTrader: (0)

What happens when you unplug the switch assembly...
Appreciate 0
      04-06-2020, 10:13 AM   #7
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

Quote:
Originally Posted by im_an_alien View Post
What happens when you unplug the switch assembly...
Haven't tried that yet. I'll give it a try later today
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
      04-06-2020, 10:17 AM   #8
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5638
Rep
11,905
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Quote:
Originally Posted by pauli18c View Post
Is there a way to self diagnose that or scan it?
Probably, there isn't much that can happen that the car won't diagnose. IMO at the very least every BMW owner should have a OBD bluetooth adaptor and a diagnostic app. It will pay for itself the first time it avoids a trip to the dealer.
Appreciate 0
      04-06-2020, 11:04 AM   #9
Astone22
First Lieutenant
61
Rep
379
Posts

Drives: F30 320 xdrive, f32 428
Join Date: Mar 2017
Location: Stl

iTrader: (1)

Quote:
Originally Posted by Billfitz View Post
Quote:
Originally Posted by pauli18c View Post
Is there a way to self diagnose that or scan it?
Probably, there isn't much that can happen that the car won't diagnose. IMO at the very least every BMW owner should have a OBD bluetooth adaptor and a diagnostic app. It will pay for itself the first time it avoids a trip to the dealer.
What is the best Bmw diagnostic app? I have BimmerCode but that doesn't do diagnostics
Appreciate 0
      04-06-2020, 11:23 AM   #10
Liandri
Second Lieutenant
Liandri's Avatar
United_States
124
Rep
233
Posts

Drives: 2016 M235i
Join Date: Jul 2019
Location: Manchester, NH

iTrader: (0)

Before you go off on anything involved, try pulling the battery cables for 10 minutes (power cycle/reset every module). Or you could recode the FEM with bimmercode as that will reset it as well. Sounds like a glitch vs an actual problem, just my .02
Appreciate 1
      04-06-2020, 12:06 PM   #11
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

Quote:
Originally Posted by Billfitz View Post
Probably, there isn't much that can happen that the car won't diagnose. IMO at the very least every BMW owner should have a OBD bluetooth adaptor and a diagnostic app. It will pay for itself the first time it avoids a trip to the dealer.
What would you suggest for a bluetooth adapter? Been meaning to get one of them anyway
I have a Bimmergeeks cable already as well
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
      04-06-2020, 02:26 PM   #12
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
5638
Rep
11,905
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

I don't have an app, for diagnosis and repair I use a Foxwell NT510, so I can't recommend an app from personal experience. There are plenty of them in Google apps, many are no charge but those are limited in what they can do. If you're going to get an adapter you might as well get one that works with Bimmercode. For that I have a Veepeak OBDCheck BLE. I got mine with a coupon through Bimmercode.
Appreciate 1
      04-06-2020, 03:38 PM   #13
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

Quote:
Originally Posted by Billfitz View Post
I don't have an app, for diagnosis and repair I use a Foxwell NT510, so I can't recommend an app from personal experience. There are plenty of them in Google apps, many are no charge but those are limited in what they can do. If you're going to get an adapter you might as well get one that works with Bimmercode. For that I have a Veepeak OBDCheck BLE. I got mine with a coupon through Bimmercode.
Thanks for the suggestion, I'll check them out
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
      04-06-2020, 03:40 PM   #14
pauli18c
First Lieutenant
pauli18c's Avatar
United_States
98
Rep
341
Posts

Drives: 2017 BMW 340i M Sport
Join Date: Jun 2019
Location: Chicago

iTrader: (2)

As for the light issue.

I unplugged the switch, hit the ignition on. Lights still turned on.

Left the ignition on, plugged the switch back in. Lights turned off.

Seems to be working as normal again. Strange, hopefully this helps someone else out at some point.
__________________
2017 340i M Sport Alpine White / Coral
Dorch Stg2, CTS catless, xHP, Custom E50 Tuned by Shoup
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:50 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST